XP folder permissions problem.
February 4, 2004 11:18 AM   Subscribe

XP folder permissions problem. [more inside]

I am running XP Pro, and share my mp3 folder with my wife's ME Notebook. I have shared the mp3 folder and set its permissions to "Full Control" for Administrators, Everyone, Mycomputername, System and Users. I tried to do the same for Creaotr Owner, but it doesn't take. This works.

When I add files or folders, however, she can see them but not play them in Winamp. I then have to go and dick around for a bit with the permissions on the mp3 folder and/or new files & folders until I get it to work right again. This is all quite annoying.

Is there any global setting which would get rid of this problem, something that said "from now on, share anything in the mp3 folder and stop being an ass"?

I share my Internet connection with her and that works fine. I am using ZoneAlarm Pro 4.5.530, and have XP's Internet Connection Firewall off, as it stopped my wife from being able to access the Internet. I am NOT using "simple file sharing", as I couldn't share anything at all with it on.
posted by signal to Computers & Internet (2 answers total)
The first thing I would check is to make sure that Allow Inheritable Permissions is turned on.

What account is your wife using to access the files? Is that account a member of one of the groups you have granted access on?
posted by internal at 12:44 PM on February 4, 2004

If you have added full control to "everyone" that should cover you. As internal says, the problem is probably that the new subdirectories are no inheriting the permissions from the mp3 folder, but are getting the system default permissions. As well as making sure that you select "Inherit from parent the permissions that apply to child objects" from the Advanced Security Settings screen (Right click directory, choose properties, choose security tab, click advanced button), before closing the Advanced Security Settings tab, select "Replace permission entries in all child objects ..." to set permissions on all the current subdirectories the way you want them.

I am assuming that she is on the same workgroup or domain, otherwise you may have to add her as a user from the control panel and grant the appropriate permissions there.
posted by dg at 3:27 PM on February 4, 2004

« Older What is the Japanese photographer saying in Lost...   |   Alternative browsers Newer »
This thread is closed to new comments.