Why won't Amazon open in Firefox 2.0?
November 17, 2006 6:54 AM   Subscribe

In Firefox 2.0, Amazon will not load for me. It doesn't time out, exactly, just keeps trying and trying and trying. It works fine in IE. What can I do? Everything seemed fine before I upgraded to 2.0, and I've tried reinstalling Firefox. Mac OSX 10.2.8, if that matters. Obviously(?) I know very little about computers, so keep that in mind.
posted by unknowncommand to Computers & Internet (16 answers total)
 
Try tools->Clear Private Date, check all the boxes, and press ok (this will clear any saved passwords, etc).

This process is what your ISP would tell you to do first if you called them with the problem (clear the application's cache) as it seems as though it is a firefox issue, not a machine issue.
posted by SirStan at 6:58 AM on November 17, 2006


I would make sure that you don't have any extensions running. Some extensions aren't yet compatible with FF 2.0 and have been causing problems.

Go to: Tools -> Add-ons ->Extensions and make sure everything is disabled, then try. If you want certain extensions, add them one by one until it doesn't work, then you have your bad extension.
posted by unexpected at 7:00 AM on November 17, 2006


Response by poster: Done and done. I delete private data regularly. I could call the ISP, but I feel dumb saying it's just this one stupid page. "OMG How can I shop for all my pink bows and frilly dresses now!?!?!"
posted by unknowncommand at 7:15 AM on November 17, 2006


It looks like their IP address is 207.171.166.102 . Can you get there, or does that also timeout for you?
posted by willnot at 7:23 AM on November 17, 2006


Response by poster: It also times out.
posted by unknowncommand at 7:27 AM on November 17, 2006


Reinstalling Firefox probably didn't change anything. All of the files that are changed are in your profile and installing/reinstall Firefox doesn't delete or touch your profile. The general advice is to try with a brand new profile.

You can either move the profile folder or create a new profile by (I assume this still works in OS X) starting firefox with the -ProfileManager command line option. Then try going to Amazon.
posted by skynxnex at 7:34 AM on November 17, 2006


Response by poster: Created a new profile. Did not migrate settings. Now when I open Firefox, it gives me the Firefox start page rather than my previous homepage. Still won't go to Amazon. Meh. Maybe I will give up.
posted by unknowncommand at 7:52 AM on November 17, 2006


Response by poster: Which is not to say that I'm worried about the Firefox start page. Just indicating that the profile creation worked.
posted by unknowncommand at 8:01 AM on November 17, 2006


Strange, that. Works for me, but I'm on a PC.

Have you tried pinging 207.171.166.102 and amazon.com?

I don't know what the mac equivalent of ipconfig is, but you might consider trying a ipconfig /release then ipconfig /renew.

Either it's not actually just that one site, or there's some setting(proxy or siteblocking) that you've overlooked.

Perhaps IE was pulling the site of of it's cache, but not really loading it?
posted by Mr. Gunn at 8:02 AM on November 17, 2006


Best answer: Amazon use a lot of prefetching - sometimes you need to clear the locally cached files.

These are in Tools > network > clear cache
Or just force reload the page with CTRL+F5, or hold down the SHIFT key and left-click on the Reload icon.
or on a Mac its Command-Shift-R
posted by Lanark at 8:04 AM on November 17, 2006


Oh, I just thought of one thing it may be. I'm pretty sure that Firefox 2.0 uses pipelining by default, unlike earlier versions. There are a few networks left that don't like it for crazy reasons.

Try typing "about:config" in the address bar of Firefox. Type "pipelining"in the Filter box and wait for the options to display. Double click on "network.http.pipelining" so it says False. Restart Firefox to make sure it'll take effect and see if Amazon works. This is something of a long shot, but, it doesn't take too long to try. (If that's not it, you should probably reenable pipelining.)

It may be that IE cached it for you. You didn't mention Safari... does Amazon work with it?
posted by skynxnex at 9:00 AM on November 17, 2006


I can't believe this is the post that finally made me pay my $5 to post!

Anyways, I spent hours on the phone with my mother in law trying to figure out the exact same thing and it was because she was running Norton Utilities. I can't remember what the feature is called, but it was blocking sites that use tracking cookies, like most e-commerce sites. Thanks a lot Norton...
posted by advicepig at 9:20 AM on November 17, 2006


Response by poster: AH well now. The cache was set to keep only up to 0.01MB. Turning off images and then turning them on again seems to work for a while, but not permanently.

I recently purchased Norton Antivirus, which honestly I have no idea if that is related to Norton Utilities, but, you know "Norton". (I realize that Macs do not have viruses, largely, but I've had to look at porn for my job. No this job is not immoral, nor is it supermoral.)

AND in trying to find out the connection between Norton Utilities and Norton Antivirus, I have realized/remembered that the browser hates individual Wikipedia pages also. The main wiki homepage is fine, but any search or link to a page within it does the same effing thing as Amazon.

I just find the whole thing curious.
posted by unknowncommand at 9:52 AM on November 17, 2006


Best answer: Wikipedia also use prefetching, try making the cache a bit larger, like 10 Mb
posted by Lanark at 10:00 AM on November 17, 2006


Best answer: Ah, yes. Prefetching. Maybe you should try turning off prefetching by setting network.prefetch-next to false in about:config? I mean, it's worth a try... I always have it off.
posted by skynxnex at 10:47 AM on November 17, 2006


Response by poster: PREFETCHING. LARGER CACHE. Thanks so much!
posted by unknowncommand at 5:07 PM on November 17, 2006


« Older I LOVE UR CHILDREN WHEN U CANNOT: UR PERFECT NANNY...   |   How many more buttons are there in the US than... Newer »
This thread is closed to new comments.