How do I view a PDF in Firefox 2.0 on Mac OS 10.4.8?
November 1, 2006 6:17 PM   Subscribe

Trying to view a PDF in Firefox 2.0 on an Intel iMac is even more of a pain in the butt that it was in Fx What am I doing wrong?

In Fx, when I clicked a PDF link the file would at least download automatically (sometimes) so I could view it in Preview. Now, however, clicking the link just opens a empty browser window, with the URL of the PDF in the address box.

I am aware that the Adobe PDF plugin won't work, but Schubert's PDF plugin doesn't work either. I have that plugin in both ~/Library/Internet Plug-Ins and ~/Users/me/Library/Internet Plug-Ins. I'm on an Intel iMac running OS 10.4.8. Help!
posted by DakotaPaul to Computers & Internet (5 answers total) 2 users marked this as a favorite
Best answer: Have you tried simply losing the plugins and have the PDF pop up in its own window? Even on system where embedding the reader in a browser technically works, I don't recommend it.
posted by krisjohn at 6:27 PM on November 1, 2006

That's quite odd because I have pretty much the same setup (OSX 10.4.8, FF 2.0 minus the plugins) & don't have any problem with PDFs.

If you don't get any love here, try over in the Mozilla Firefox forum. I had my own issue with FF 2.0, posted it there & got a quick response that solved my problem.
posted by scalefree at 7:05 PM on November 1, 2006

Best answer: The Schubert plugin won't work with a Universal build of Firefox on an Intel Mac, because it's compiled for PowerPC. The only way to get it to work is to force Firefox to run in Rosetta, which, of course, causes Firefox to run much more slowly.

It's really annoying, but the least bad solution I've found is to just tell Firefox to open PDFs externally in
posted by myeviltwin at 7:32 PM on November 1, 2006

Yeah, there's officially no PDF plugin that works in the Intel layer of Intel Macs. So your options are to use Safari's built-in rendering of PDFs (using Preview, really), or to have Firefox open them externally. Bleah.
posted by delfuego at 7:54 PM on November 1, 2006

Response by poster: I removed the Schubert PDF plugin, and now Fx does ask me whether to save or view the PDF. Preview it is for now. Thanks, all.
posted by DakotaPaul at 7:06 AM on November 2, 2006

« Older I'm a health hazard to my new cubicle-mate.   |   Getting Started in Investing Newer »
This thread is closed to new comments.