Help me keep the tubes unclogged
October 19, 2006 5:48 PM   Subscribe

It seems like when someone is doing file sharing on the network everything else slows to a crawl. Besides setting a limit on the bandwidth in the file sharing program, can I set it on the router? Lets say the bandwidth hog was a roommate who I didnt want to have to police. Could I just do something on my end?

There is no specific situation, this is more of a general hypothetical.
posted by GleepGlop to Computers & Internet (9 answers total) 1 user marked this as a favorite
This all depends on the capabilities of your router. Like odinsdream said, if you have Quality of Service (QoS) functions you can throttle the bandwidth this person has, or even the type of bandwidth he is using.

Depending on your router, you may be able to deprioritize his packets by IP address, MAC address, or Ethernet port. Also based on what TCP/UDP ports are hogging bandwidth, etc.
posted by doomtop at 5:58 PM on October 19, 2006

If you have a WRT54-based router, look into third party firmware like DD-WRT. That will give you much better QoS options than what you might have in the stock firmware, and you can prioritize based on IP, MAC, port, type of traffic (via deep packet inspection), and so on. It's great, you can just set the p2p stuff to the lowest setting and now everybody can just sit back and relax without having to worry about futzing with bandwidth limits.
posted by Rhomboid at 6:17 PM on October 19, 2006

Most cable modems don't like to have their upstream bandwidth completely hammered by file sharing. Let's say I'm running bittorrent and only seeding a file, not downloading anything. If someone pulls that file from me at my full 42K upstream limit, my downloads will all slow to a crawl. If, on the other hand, I limit upstream bandwidth to even 35 or 40K, everything else will seem fine and speedy as usual. Look into that, if possible.

Otherwise, as people have mentioned, either an open source firmware for your router if possible, or something like Smoothwall, would allow you some more control for this situation.
posted by autojack at 7:24 PM on October 19, 2006

Seconding DDR-WRT and its kin, if your router supports it, and you don't mind voiding your warranty by flashing an unsupported firmware. Check out the list of supported devices (note: they're not all linksys WRT54-based. I'm running it on a Buffalo Airstation).

Follow the instructions in the above-linked wiki to set up QoS, crank up the maximum port number to 4096. I've got a roommate who is constantly running unthrottled bittorrent. We've got no more slowdown, the router is more stable than it was with the original firmware, and I've even moved our VOIP box to run behind the router. It's great.
posted by drumcorpse at 8:09 PM on October 19, 2006

I'll share a personal experience.

I was running a P2P program on my computer. It was destablizing the network to the point where you couldn't even load a single webpage without a timeout. It was awful.

The solution? I tweaked some settings on my router so that the max number of connections to the router was 4000 (instead of the 200 or something that it was set at) and I changed the time out from 30 minutes to 30 seconds. What had been happening was that my P2P software was opening up -tons- of connections and then being lazy about closing them. The software was choking the router to death.

Once the setting was resolved I could be downloading at 90 percent of my maximum download bandwidth and still be browsing the web without any lag at all.
posted by JFitzpatrick at 9:11 PM on October 19, 2006

As a more detailed followup, qos may not help: the problem may be that the p2p program's large number or connections is swamping the consumer router's /NAT table/ and there may not be any good way to fix that. Not sure how the WRT images cope with that...
posted by baylink at 10:27 PM on October 19, 2006

You could always rat the roommate out to the RIAA. That will solve the problem at its source.
posted by fourcheesemac at 6:38 AM on October 20, 2006

I had a similar problem. It turns out many routers aren't really built to deal with filesharing problems. They build up a cache of connection addresses to speed up communications. This isn't normally a problem with regular Internet use; however, file sharing programs can fill that cache up to the point that it makes your Internet connection hang.

The easy solution is to turn your router off, wait a few seconds, and then turn it on again. That will clear the cache.

The harder solution is to upgrade your router's firmware, mess with settings, or replace it entirely with a newer, better router.
posted by fcain at 8:50 AM on October 20, 2006

Response by poster: Interesting stuff here people, thanks! Sounds like when we are all getting our TV, phone internet and everything in our house on a network, this is going to be something people are going to have to figure out!
posted by GleepGlop at 10:51 AM on October 20, 2006

« Older you can't share your genes and you can't touch...   |   Help me become an X-men comic book geek! Newer »
This thread is closed to new comments.