No IP assignment using WPA
October 1, 2006 7:01 PM   Subscribe

Why can't my new macbook get an IP address from my D-Link router when WPA is enabled?

Just got home with a new macbook, and tried to connect wirelessly to the same network my Windows XP tablet has no problems with. I use a D-Link DI-624 router. The macbook can see the network, and I get the prompt for the WPA password just like expected. But after connection, I can't access the net or the router (192.168.1.1). The macbook tells me airport is connected with a self-assigned IP address and cannot connect to the internet. The self-assigned IP address started with a 64, but I can't recall the exact one now. It should start with 192, of course.

I turned off my wireless security, and the macbook gets an IP just fine and connects to the internet as well.

If you have any thoughts, please let me know. I can't leave the network unsecured indefinitely. Thanks in advance.
posted by chudmonkey to Technology (5 answers total) 1 user marked this as a favorite
 
Stay connected for a couple of minutes. It'll correct itself. My Netgear and D-Link routers do the same thing to me on occasion.
posted by SeizeTheDay at 7:03 PM on October 1, 2006


I had a similar problem. I had the WEP password, but didn't know which access point to connect to. I found that when I connected to one of the wrong ones (and so had the wrong password), they would not tell me that I had the wrong password, but simply not provide me with an IP, leaving me confused. Irritating design.

Also, while I was troubleshooting I remember reading that macintoshes require a $ at the beginning of a hex password (i.e. one with 0-9 and A-F). I'm not sure if the same applies to WPA. Perhaps these two tips together form the answer to your question.
posted by alexei at 7:37 PM on October 1, 2006


Try assigning your Mac a Manual IP address in the 192.168.1.* range. Go to the network prefs pane, select the Airport card, and then choose Manually instead of Using DHCP. Set the IP to 192.168.1.4, for example, with a subnet mask of 255.255.255.0, and a default gateway of 192.168.1.1 (your wireless router).

If you can then access the router in a web browser from the mac, there may be something wrong with the DHCP settings in the router.
posted by odinsdream at 7:14 AM on October 2, 2006


odinsdream: I actually tried your suggestion very early-on in my troubleshooting. I could access the router at that point, but still no 'net access. Time to focus on the router, I guess.
posted by chudmonkey at 10:18 AM on October 2, 2006


It sounds, then, like a DNS problem. If you look in your router's configuration page, you should be able to find your ISP's DNS servers. There can be one or more. These will be IP addresses. The router itself is supposed to act as a DNS server by taking requests from your computers and relaying them to these addresses.

The DNS servers answer questions like "What's the IP address of www.google.com?" so that your computer can talk to that site. You can bypass your router by setting your computer's DNS server settings directly to the ones shown on the router's configuration page.

Set the DNS servers in the same place that you set the IP address of your machine. To test, Verizon has a DNS server at 4.2.2.1
posted by odinsdream at 7:33 PM on October 3, 2006


« Older How can I output unrecompressed DV from iMovie?   |   If you pick up a piece of trash and put it back... Newer »
This thread is closed to new comments.