VoIP kills my Bittorrent ability. Help!
September 22, 2006 8:20 AM   Subscribe

Bittorrent worked fine till I got VoIP (Vonage). Now, no worky. Can anyone help? I'm on OSX.

My modem is a Webstar DPC2100 and my Vonage modem is a Motorola VT-2442-VC.

My Bittorrent software keeps telling me "Could not open a listening Port! Check your port range settings."

However, if I pull the Vonage modem out of the equation, Bittorrent works fine.

I'm using Tomato for BT but can switch to something else if anyone can give precise step by step instructions for setting it up. I've tried setting up Azureus and other programs pre-vonage with no luck. Tomato's the only one I've gotten to work (and yes, I've cleared some ports for it in the Sharing menu).

I've called Vonage and asked 3 reps about this and only one of them knew what BT was and said he wasn't aware of anything that would affect it.

Suggestions?
posted by Manhasset to Computers & Internet (18 answers total)
 
Do you have a router in there? How are things connected (modem->Vonage box->Router->computer, or whatever)?

You have to make sure the ports are routed from box to box to box properly--have you already done some port forwarding at some point in the hardware chain, not just in the OS X software firewall?
posted by bcwinters at 8:39 AM on September 22, 2006




FYI, what you are refering to as the Vonage modem is actually a router.

Questions that will help diagnose:

1.) Where do you get your Internet from (cable, FIOS, DSL, etc.)?
2.) Before you got Vonage what did your computer plug into? Was it directly into a modem or a router?
3.) Vonage should have given you some software and instructions for how to admin your router. Can you access this?

The most likely problem is that the Vonage router isn't allowing traffic on ports BT needs.
posted by justkevin at 8:55 AM on September 22, 2006


Thanks for the answers so far. I'm a total noob when it comes to these things so heres more info:

- yes, the vonage modem is a router
- pre-vonage, i plugged my computer directly into my modem
- my internet is cable (rogers)
- the rogers modem has no router built into it
- yes, i am able to access the admin area of the router, though i don't know what to do once i'm in there (there are a lot of options)

bcwinters, I don't really understand your comment so it's safe to say i have not done any of that stuff and don't know how.

in the modem admin, under advanced, i have these options:

UPnP
Configure Universal Plug and Play.

IP QoS
Configure IP Quality of Service for different connections.

Port Forwarding
Configure Firewall and NAT pass-through to your hosted applications.

IP Filters
Configure firewall, port filters, and IP filters.

LAN Clients
Status and configuration of LAN clients.

Web Filters
Select to setup Web Filters.

Dynamic DNS Client
Configure Dynamic DNS Client.

Multicast Configure
Multicast pass-through for different connections.

Static Routing
Configure Static routes.

Dynamic Routing
Configure RIP.

Remote Web Access
Configure access control list for remote Web access.

Remote SSH Access
Configure access control list for remote SSH access.

Ethernet Switch
Configure ethernet switch settings.
posted by Manhasset at 9:24 AM on September 22, 2006


Port forwarding is the option you want. You want to forward the listening port you are using for BT to the IP address of your computer on the network. Usually, this is 6881 but it can be set to other ports depending on the client you are using.
posted by chrisroberts at 9:33 AM on September 22, 2006


Thanks chrisrobers.When I click Port Forwarding I get a form asking for these variables:

Application:
Protocol: (options are TCP, UDP, and UDP AND TCP)
Source IP Address:
Source Netmask:
Destination IP Address:
Destination Netmask: (filled in as 255.255.255.255)
Destination Port Start:
Destination Port End:
Destination Port Map:

There's also a checkbox that says "allow incoming ping"

In OSX, in my firewall, I've specified the tomato bittorrent program to be 6881-6889.

How should I fill in the form?
posted by Manhasset at 9:56 AM on September 22, 2006


oops, sorry, chrisroberts.
posted by Manhasset at 10:02 AM on September 22, 2006


Application: BT
Protocol: TCP
Source IP Address: 0.0.0.0
Source Netmask: 0.0.0.0
Destination IP Address: *Your IP address* (Probably something like 192.168.0.x)
Destination Netmask: 255.255.255.255
Destination Port Start: 6881
Destination Port End: 6889

Once you apply that, it looks like you need to go into the main Port Forwarding section and enable the rule. I have not used the router you have, but this looks like a match that can help to guide you along.
posted by chrisroberts at 10:13 AM on September 22, 2006


If the Vonage router has a DMZ setting, you may want to just put your computer's IP address there. That'll make it more or less as though your machine is connected directly to the Internet again, as far as incoming connections go. This will make a wide variety of apps just magically work without having to set up virtual servers for each of them.

(I suggest Transmission as a client, BTW; it's much nicer than Tomato. This has nothing to do with this issue, just thought I'd throw it out.)
posted by kindall at 10:20 AM on September 22, 2006


One thing to note about port forwarding. If your router is using DHCP to assign addresses, there is a good chance your computer will not always have the same address. In most cases, the address stays the same for very long periods of time but they can and do change.

There are several ways to rectify this. Most DHCP servers can be set to reserve an IP address to requests from a specific MAC address. Also, you can set most DHCP servers to only hand out addresses in a specific range, say 192.168.0.2 - 192.168.0.99. In this case, you can manually set the address on your computer to an address not in this range, say 192.168.0.100.

And, if worse comes to worse, you can always just manually change your port forwarding rule when your IP changes.
posted by chrisroberts at 10:24 AM on September 22, 2006


Okay, I filled in all that stuff and it still didn't work. Same error. Do I have to reboot or anything like that?

Also, there was an enable checkbox which I checked.

You didn't specify a number for "Destination Port Map" so I left it empty. Shoud it be something?

Also, on the default page for Port fowarding it says:

LAN IP: and then has an IP address, which is not my ip address. My own IP starts 74.98..., which seems a little weird to me but what do I know.

Next to the Lan IP thing is a "new ip" button. When I click that I see

Enter IP Address
Hostname
MAC Address

with empty fields. Under that is

Dynamic Addresses

and under that is the 192 address that isn't mine, my own name as the hostname, a MAC address, and the type is listed as dynamic. There's a "reserve" checkbox, which is unchecked.

Also, in the Port Forwarding section is a "enable DMZ" checkbox which is unchecked. Next to it it says "select a lan ip address" and a drop down box with only the 192... address listed.

Actually, after typing that, I think that the 192 address listed has soomething to do with my router. It's the number I punch into the web browser to access the router setup info, different by a single digit (it's a 2 instead of a 1).
posted by Manhasset at 10:43 AM on September 22, 2006


I think what might be happening here is that you have TWO routers, instead of one. It sounds like you're going:

Internet -> old cable modem -> Vonage box -> Mac

With two layers of NAT, the BT client wouldn't be able to successfully send an order to open ports all the way to the outside. The Vonage box would open ports, but the existing modem would never see the request and wouldn't do anything.

One way you can prove this is by plugging in the old way. When do you that, what IP address does your computer get? (open a command prompt and type "ipconfig" for a printout of your IP.) If it's in the 192.168.X, 10.X, or 172.16 - 172.24 ranges, you're already being firewalled/NATted.

If so, and if you have more than one port on the existing modem/router device, you can plug them in next to each other, as peers. I can't line this up well in MeFi, but basically:

Internet -> Modem -> OSX
->Vonage

(the vonage and the osx should be next to each other, both plugging into the modem.)
posted by Malor at 12:35 PM on September 22, 2006


You could try using Azureus and turn on the UPnP option in your vonage router. Azureus theoretically will use UPnP to set the forwarding ports as necessary.
posted by phearlez at 1:21 PM on September 22, 2006


You didn't specify a number for "Destination Port Map" so I left it empty. Shoud it be something?

Should be the same as the source port normally.

Also, in the Port Forwarding section is a "enable DMZ" checkbox which is unchecked. Next to it it says "select a lan ip address" and a drop down box with only the 192... address listed.

Yeah, if you want to take my advice about the DMZ, check that and make sure the IP address is the address of your Mac. (The 192.168.x.x address is indeed yours.)
posted by kindall at 1:44 PM on September 22, 2006


malor, I don't really understand your comments.

I found my IP by going to this site (all the sites that come up in google tell me the same ip, which starts 74.198, etc.) Those are also the numbers in my Tomato client in the "bind to ip#" field and it's always worked till I got the Vonage router.

This number does not change when I pull the vonage router out of the equation.

Internet -> old cable modem -> Vonage box -> Mac

Yes, that's correct. Those are the instructions that came with the vonage box.

I think what might be happening here is that you have TWO routers, instead of one.

Not sure why you think that. My Webstar modem definitely doesn't have a router in it. It's only got 1 ethernet port on it.

You could try using Azureus and turn on the UPnP option in your vonage router.

I've never been able to get Azureus working--even before Vonage.

Should be the same as the source port normally.

I don't know what that is. Is that the same as the Destination Port Start?

Yeah, if you want to take my advice about the DMZ, check that and make sure the IP address is the address of your Mac. (The 192.168.x.x address is indeed yours.)

I checked the box and it doesn't make any difference (while leaving the 192 address selected).
posted by Manhasset at 2:09 PM on September 22, 2006


They meant your local ip, not external ip, which is what you're getting from the google results.

To get your local ip in OSX- Click the apple logo in the top left corner and select system preferences. Then select network. It may tell you your ip (should begin with 192.168). If it doesn't say anything like that there, select the option with the green light (likely to be built in ethernet, given what I've read in this thread) and click configure. On the tcp/ip tab, your ip address is labeled.
posted by jcruden at 3:56 PM on September 22, 2006


Thanks, jcruden, but I did this:

- chose network from system preferences
- clicked configure to see my variables
- selected the TCP/IP tab

It lists my IP Address as 74.98... etc. Same as the google'd pages do.

It also lists a number for my router and subnet mask, which instead of all 255s, ends in 128.

Ugh. Why is BT so difficult?
posted by Manhasset at 4:24 PM on September 22, 2006


Okay, let's see if this can help:

http://www.portforward.com/english/routers/port_forwarding/Motorola/VT2442/BitTorrent.htm

As for the port, it should be 6881 by default. I don't think you can change that with Tomato. They have a walk through for the static ip stuff on the above site, as well, so hopefully there's all the information you need there to get you through this.
posted by jcruden at 4:46 PM on September 22, 2006


« Older a trained monkey, Tutankhamun's mummy, and a...   |   How do i find an icon in Microsoft Word (which I... Newer »
This thread is closed to new comments.