Thunderbird + Firefox
September 10, 2006 8:14 PM   Subscribe

Can I set up Thunderbird email so that the links in email messages open up my FireFox browser instead of IE? Everyone else in the family uses Outlook Express and IE.
posted by sandra194 to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
I don't know if you can do that or not, but why not set up separate profiles in Windows? (I'm assuming you're using Windows)
posted by FlamingBore at 8:45 PM on September 10, 2006


I think you would have to set Firefox to be your default browser for links in external programs (like Thunderbird) to open in Firefox. Which wouldn't work if other people use IE in the same profile. So I echo FlamingBore's suggestion: try setting up your own profile.
posted by rhapsodie at 8:50 PM on September 10, 2006


Actually, it's possible to alter settings within Thunderbird to get it to open up Firefox as the default browser. At least, I know for sure that it's possible in Linux, and I therefore strongly suspect it works in Windows too. Anyway, it shouldn't take more than a couple seconds to try it out.

Look in:
Edit » Preferences » Advanced » Config Editor.

Alter the following settings:
network.protocol-handler.app.ftp firefox
network.protocol-handler.app.http firefox
network.protocol-handler.app.https firefox

Sometimes (for absolutely no good reason) the menu trees are different under windows and linux (i.e. instead of Edit >> Preferences >> yada, you might have Tools >> Preferences >> yada). Just check around.
posted by Humanzee at 9:23 PM on September 10, 2006


Eventually, they'll all switch to using Firefox, too. Just give 'em time.
posted by Mr. Gunn at 9:51 PM on September 10, 2006


Look in:
Edit » Preferences » Advanced » Config Editor.


Neat! In Windows it's Tools » Options » Advanced » Config Editor.
posted by rhapsodie at 11:35 PM on September 10, 2006


Humanzee said to alter those settings--I don't even see those settings on my list when I look at the config file in Windows Thunderbird
posted by sandra194 at 5:07 PM on September 11, 2006


Yeah, I'm sorry. I finally got a chance to install Thunderbird on my windows machine and they're not there, and adding in the settings doesn't seem to help either. I thought for sure that it would work because commercial apps usually seem to make sure that windows works more easily than linux. After messing around, I haven't found anything similar on the windows side ---sorry, I'm no help at all.
posted by Humanzee at 7:55 PM on September 12, 2006


I know it's been a while since the last post on this, but I've been agonizing over it a while and finally came up with the answer for Windows. First, make sure both TBird and FFox are set as default. Then add the three settings indicated above. Alone, that won't make the difference. Lastly, make the following two changes:

Change network.protocol-handler.external-default to "true"
Change network.protocol-handler.warn-external-default to "false"

I was just making educated guesses - and grasping at straws - but it worked.
posted by dfr1 at 1:04 PM on August 3, 2007


« Older Calculus resources for the curious?   |   How do I best combine running and leg lifts like... Newer »
This thread is closed to new comments.