Turn html into a readable web page
August 29, 2006 9:39 AM   Subscribe

I have some html files with all the <> and </> etc. etc. (ie, these are basically text files with all the html in them.) What is the easiest way to see each file as an actual web page so I can read the text in them without all the code stuff making my eyes hurt?

I am hoping I can see them without downloading any software. But if I have to download something, what is free, and free of spyware, malware? I know little about html, or other computer stuff, so the answer needs to be simple enough for a novice to grasp! Thanks for the help.
posted by wtfwjd? to Computers & Internet (28 answers total) 1 user marked this as a favorite
 
You can simply open them up in any web browser.
posted by luriete at 9:42 AM on August 29, 2006


Why not just open them in a web browser?
posted by kcm at 9:42 AM on August 29, 2006


can you open the files in a web browser?
File > Open File?
posted by mattbucher at 9:42 AM on August 29, 2006


You can use... internet explorer. Unless I'm missing something, it's as easy as "File" -> "Open..." -> "Browse..."
posted by sbutler at 9:43 AM on August 29, 2006


If you like, you can even drag and drop the file on a browser.
posted by utsutsu at 9:44 AM on August 29, 2006


Make sure that the files end in an .thm extension. You'll be able to open them in any browser by going to "File" and "Open."
posted by Iridic at 9:44 AM on August 29, 2006


Excuse me. .Htm extension.
posted by Iridic at 9:45 AM on August 29, 2006


You can also open them up in MS Word and see them as web files sans code
posted by TheRaven at 9:45 AM on August 29, 2006


OK. This sounds easy, but I am still having problems! They have been sent to me in this html format in email. So, I copied them into notepad and tried to open them from firefox. But the error message I am getting implies I must rename them. (It is showing the name as: 'myname.html.txt") I tried right clicking "properties" and all I see is the name I gave them: "myname.html" so now how do I change that .txt extension so I am able to follow your advice and open them with my web browser?
posted by wtfwjd? at 10:04 AM on August 29, 2006


Paste text into Notepad. Then go to Save As and make sure the File Type box is set to "All Files". Now name the file "filename.html" without quotes. Open your newly saved file in a browser.
posted by roomwithaview at 10:09 AM on August 29, 2006


From email, save attachments to desktop. Go to desktop, click on icon representing the file, and hey presto, it'll open in the browser.
posted by cosmicbandito at 10:09 AM on August 29, 2006


There are two ways.

1) If you can use either Windows Explorer or My Computer to browse to the file location, then you can just right click on the file name there and rename it to exclude the .txt extension.

2) Within Notepad you can open the file and do a Save As. Choose a new filename, like nowitworks.html and then in the box below that, called "Save as Type", select All Files. Now when you save it the .txt will not be added to the name of the file.

After that you can open it in a browser in three ways:

1) Just double-click the file name and it will open in a Web browser automatically

2) Open your browser and do a File, Open, Browser

3) Drag and drop the file into your web browser window.

Regards
posted by lockedroomguy at 10:11 AM on August 29, 2006


roomwithaview's solution should work.

As an aside, if you file is showing up as myfile.html but is actually myfile.html.txt, you can fix this by doing the following:
Go into Tools>File Options in Explorer (the window you view your computer files in,not Internet Explorer), and click the View tab. Make sure "Hide extensions for known file types" is not checked. Click OK. This will mean you can always see the file extensions for all file types and it will be obvious in future if you have accidentally saved something with two file extensions.
posted by EndsOfInvention at 10:13 AM on August 29, 2006


But the error message I am getting implies I must rename them. (It is showing the name as: 'myname.html.txt") I tried right clicking "properties" and all I see is the name I gave them: "myname.html"

For future reference, that sort of thing happens because of the default settings in Windows Explorer (NOT Internet Explorer, though they are almost the same thing these days). Open up Windows Explorer or My Computer, hit the Tools menu, Folder Options, the View tab. Under the Advanced Options, look for "Hide extensions for known file types" and turn it off. Presto8212;now you can see the REAL filenames of everything on the system, extensions and all. You will then see that your file only appeared to be called "myname.html" because Windows was hiding the extra ".txt" from you.

Any time I do a clean Windows install, stupid stuff like this are the first things I turn off.
posted by chrominance at 10:14 AM on August 29, 2006


this is why file extensions suck dick
posted by bonaldi at 10:25 AM on August 29, 2006


Go to My Computer -> Tools -> Folder Options -> View, uncheck the box that says "Hide extensions for known file types" and click the "Apply to All Folders" button. Then navigate to the folder that contains your files, rename them to delete the ".txt" extension that you can now see and click on the renamed files to open them in your default browser..
posted by timeistight at 10:26 AM on August 29, 2006


When you save the file in notepad (File->Save As), you can quote it - "myfile.htm" and notepad wont append the .txt extension to the file name.
posted by jikel_morten at 10:37 AM on August 29, 2006


Bonaldi: no, this is why hiding basic information from the user sucks dick (I'm a Mac/Linux user, so I don't deal with file extensions all that much, but I stand by my statement anyway).
posted by spaceman_spiff at 10:37 AM on August 29, 2006


this is why file extensions suck dick
posted by bonaldi at 1:25 PM EST on August 29 [+fave] [!]


Why, because windows does some shitty things with displaying files/hiding extensions? Come on...
posted by jikel_morten at 10:38 AM on August 29, 2006


It's okay. Everyone can can just start parsing for mime-type every time they want to know what kind of file they have might be. Only sure way anyway. I agree!! DOWN WITH EXTENSIONS. GL everybody =p....
posted by judge.mentok.the.mindtaker at 10:44 AM on August 29, 2006


Ooh, sorry, I didn't realise this was controversial. People like file extensions?

If something changeable and so fundamental to the operation of the computer is simultaneously so clunky that it has to be hidden from the user, it's broken.

spaceman_spiff: OS X also has a broken implementation of file extensions. Hell, you can set up the GUI so that it won't launch applications, thanks to file extensions.

jikel_morten: Yes, it's mostly an interface thing. But explaining the difference between "All files" and "Any files" is like explaining the difference betwen Abort, Retry and Fail. There are better ways to link files to apps, ones that don't end in the user having to post here to try to work out how to open an HTML file in their browser..
posted by bonaldi at 10:47 AM on August 29, 2006


There are better ways to link files to apps, ones that don't end in the user having to post here to try to work out how to open an HTML file in their browser..

Well, no offence to the op but I think his/her problem was OS and extension handling independent - he was just unsure how to work with html files. I don't think any other OS could have made it easier for him.
posted by jikel_morten at 11:09 AM on August 29, 2006


Not to derail, but what *is* the difference between "abort" and "fail"?
posted by TonyRobots at 11:32 AM on August 29, 2006


bonaldl: extensions are hidden by default from the user (in *some* OS's) to keep users from confusing themselves when they save a file and then go to look for it and wonder "what is this crap after the period in my file?!". They're also there for convenience for users who would like to have a little metadata about their files right in the name.

Your OS doesn't give half a damn about what the extension really is, it has nothing to do with how the OS handles the file except for windows, which gives type-ing priority to the association of the extension over the name.

As jikel_morten mentioned Windows impl is poor; I was just making a joke you totally didn't get. =)
posted by judge.mentok.the.mindtaker at 11:59 AM on August 29, 2006


Abort just dies while fail quits and feeds an error code back to the original (usually DOS) app.
posted by jikel_morten at 11:59 AM on August 29, 2006


Trying to get the train back on the rails here...

jikel_morten's comment bears repeating. Regardless of how your view settings are set (to view filename extensions or not), and regardless of the "Save as Type" setting in the "Save As" dialog--if you enclose a filename in double quotes (e.g "myfile.htm"), then it will save as that filename exactly, without any appended name extensions the application would normally add.
posted by RikiTikiTavi at 1:39 PM on August 29, 2006


With all the great help here, it works now. Thanks!
posted by wtfwjd? at 2:00 PM on August 29, 2006


Cool tip RikiTikiTavi; I'll have to remember that when I'm working on friends' systems.
posted by odinsdream at 4:12 PM on August 29, 2006


« Older Short film from Resfest 2004?   |   Hunting Newer »
This thread is closed to new comments.