Help mebuntu!
August 27, 2006 9:47 AM   Subscribe

Can I access (hax0r!) my now screen-less xubuntu laptop over my home network?

I've been setting up my 7-year-old laptop with xubuntu the past week, and turning on remote desktop was my next step. Then a 20 pound speaker fell on top of it and the screen is now demolished. The computer is working fine, I can see it on my network, but I don't have a monitor to plug in. Is there a way I can access this thing from another computer to turn on remote desktop or, at the very least, tell it to mount my Windows partition into a directory (that I've already shared) so I can get my files off of it? I know the username/password that has admin privileges, and I know its IP address. I have a computer running XP and another running OS X. Is there any way I can do this? Thanks!
posted by one_bean to Computers & Internet (16 answers total)
 
Obvious question, perhaps, but does the laptop have an external VGA port? If so, you could just plug in a monitor, fire it up and start remote desktop and then disconenct the monitor...
posted by baggers at 9:54 AM on August 27, 2006


Oh, stupid me. I see you don't have a monitor to plug in. Does it by any chance have a composite or S-Video output? If so , yuo coudl connect it to a TV and start remote desktop that way.
posted by baggers at 9:55 AM on August 27, 2006


If sshd is running, you could log in remotely with ssh.

I beleive ssh is installed by default on OS X, so from the Mac:
ssh username@ip.address.of.xubuntu

After that, it should be easy to mount your windows partition (at least, read-only -- read-write NTFS is problematic).
posted by fings at 10:10 AM on August 27, 2006


I get "port 22: connection refused," which I assume means it's not running? Sorry, most of my computer experience stalled about ten years ago, so my skills are broader than my knowledge.
posted by one_bean at 10:24 AM on August 27, 2006


If all else fails, you can always pull the hard drive out of the laptop, and use a 2.5" to 3.5" adapter to hook it up on your desktop machine.
posted by odinsdream at 10:27 AM on August 27, 2006


You can try blindly installing openssh-server by starting up the laptop, then hitting Ctrl-Alt-F1 to switch to the first virtual terminal. Then type your user name, enter, your password, enter, then 'sudo apt-get install openssh-server', enter, your password, enter, then hit enter a few more times..

Then try ssh'ing into the box. Never understood why Ubuntu shipped with SSH disabled... it's so useful :(
posted by SemiSophos at 10:32 AM on August 27, 2006


You could get a monitor for probably less then 10 dollars on craigslist.
posted by bigmusic at 10:39 AM on August 27, 2006


Telnet?

I use Ext2ifs so look on my Linux-formatted disks when I am using Windows. Don't know if it'll work over a network.
posted by ijsbrand at 10:41 AM on August 27, 2006


Okay cool, I got ssh to work. Thanks, SemiSophos! Any tips on starting remote desktop using the terminal?
posted by one_bean at 11:24 AM on August 27, 2006


This thread shows you how to set up VNC using the command line. You should then be able to use TightVNC viewer from your windows box.

Since you can't get to the desktop right now, you'll have to enable XDMCP (the first step in that tutorial) by doing the following:

1. Edit /etc/gdm/gdm.conf
2. Uncomment RemoteGreeter in the daemon section.
3. Under the xdmcp section, change Enable to true.
4. Save that file, then restart GDM so the changes take effect:
"sudo /etc/init.d/gdm restart"
posted by chrisamiller at 11:38 AM on August 27, 2006


IANACE (computer expert) by any stretch (I have no idea what ssh is), but I access my other machines on my home network by typing in \\ip.address.of.xubunto\drive.looking.to.access$ in the field that comes up after going to "start", then "run"or, for example, \\192.168.5.104\c$

As long as I can ping it through the router, I can access it that way.
posted by JohnnyGunn at 12:01 PM on August 27, 2006


Or you could use the monitor you were looking at while typing this post to set up SSH/VNC/whatever.

I mean, you at least have the one monitor, or at least access to it right? I'd done this with public computers in times of desperation, people might think you're weird but eh.
posted by Matt Oneiros at 12:33 PM on August 27, 2006


Great, got remote desktop (mostly working). Thanks everyone.
posted by one_bean at 1:10 PM on August 27, 2006


The other computers I have are a laptop and a new lcd monitor with a digital input cable that my old laptop doesn't support. Anyway, thanks everyone.
posted by one_bean at 1:12 PM on August 27, 2006


Glad to hear you're up and running. By the way, if you're using Ubuntu, the Ubuntu forums are a GREAT place to get help. 95% of questions can be answered with a quick search through the site.
posted by chrisamiller at 2:25 PM on August 27, 2006


SemiSophos: Never understood why Ubuntu shipped with SSH disabled... it's so useful :(

Purely out of security. I HOPE they will never ship it out of the box. Only geeks such as us need it, my auntie out there does not need a ssh daemon taking ressources and being a potential security risk running. Currently, ubuntu has NO (if I'm not mistaken) open ports by default, which is an excellent thing!

And yes, I'm that paranoid. I put a firewall on top of my aunt's ubuntu box, even if there are no daemons listening.
posted by a007r at 3:05 PM on August 27, 2006


« Older Font where M=W?   |   Can you name this Merengue song? Newer »
This thread is closed to new comments.