Mouse dying or software setting gone bad?
August 26, 2006 5:14 PM   Subscribe

Mouse sometimes double-clicks on a single click

WinXP, Logitech Mx700 wireless mouse (several [4?] years old). Recently upgraded to NVIDIA Foreware 91.33 (whereupon the problem started cropping up).

Sometimes (but not always) when I single left click the mouse, WinXP interprets it as a double click.

I recall playing around with a setting along the lines of "prevent accidental double click" but can't find the setting again (it might have been a Forceware option [I'm not a fan of the new interface]).

Is my mouse dying or a software problem?

Also, occasionally my wireless Logitech keyboard stops responding and refuses to connect again (when I manually push the button to reestablish a wireless connection). This only happens in the evening about 7pm (after dinner?). Moving the keyboard really close to the base-station helps increase the odds of reestablishing a connection.

Could this be EM interferrence from neighbour's electronics (this problem first started after neighbours returned from China - unshielded/non-spec wireless electronics?)? Could this also be affecting my mouse?

Can anyone think of a way to test, definitively, whether there's a mechanical problem with my mouse?
posted by porpoise to Computers & Internet (6 answers total)
 
Interesting, my MX700 started doing the same thing a few months ago. I've just been putting up with it instead of getting an RMA like I should. The wheel on mine is doing it too, sometimes (annoying, because I use it to close tabs in Firefox, and sometimes end up closing multiple tabs with one click).

Mine did it without any coincidental software upgrade or other changes, too. I doubit it's any sort of wireless interference or anything, it's most likely just the switches getting old.
posted by CrayDrygu at 5:20 PM on August 26, 2006


"Prevent accidental double click" only stops click events that were more than few pixels apart from each other. You can try re-syncing your mouse, which might switch it to a different channel. I doubt Windows or the mouse drivers have this bug. It's either the circuitry in your mouse or errors in the EM transmission.
posted by aye at 5:21 PM on August 26, 2006


Borrow someone else's (wired, optical) mouse, and see if it does the same thing?
posted by Dub at 6:02 PM on August 26, 2006


I've been having similar problems with my MX610 mouse under Linux. As I note on my Linux page, I've seen mentions on the Web that it might have something to do with the Legacy Mode in BIOS. When your computer boots up, use whatever its usual method is to get into the BIOS settings (usually something like holding down F1 or the Escape key), then change the legacy mode setting to Off. Reboot and see if this changes anything. If not, try other settings for the legacy mode.

Doing this helped me get rid of annoying random clicks. It didn't solve other problems I'm having with the mouse (poor tracking), but it did get rid of that problem, anyway.
posted by jiawen at 5:26 AM on August 27, 2006


Thanks guys.

I checked the BIOS thing, unfortunately not the culprit.

aye - learn something new every day. Thanks.

I guess the contact is on the fritz. It's very annoying. Too bad WinXP doesn't have a "minimum time between clicks." They have that option under accessibility for the keyboard but alas, not for the mouse. I wonder how people with Parkinsons mouse?

Man, it's been an expensive month.
posted by porpoise at 10:58 AM on August 27, 2006


Well, I got a new mouse, then I started fiddling with the broken double-clickey mouse.

Two screws on the MX700 - one covered by a sticker (but with a cross cut over the hole) and in the battery compartment.

The switch was fine, but the knob at the bottom of the button was worn down.

A dab of crazy glue, let dry, and now the mouse is fine.
posted by porpoise at 10:15 AM on August 28, 2006


« Older What's this urge to shake when the trimmer gets...   |   What's the purpose of a certain fan in my house? Newer »
This thread is closed to new comments.