KeithNet on my Mac!
August 25, 2006 1:29 PM   Subscribe

Help me log on to this website using my mac!

http://commerce.amphire.net/benekeith refuses to work on Firefox (current and beta!), Camino, Safari, or Netscape. I can't get past the page where it tells me I am using a "bad browser". Other than using IE on my windows box, what can I do?

I am running OS X Tiger on a Powerbook G4, all the latest updates...
posted by sindas to Computers & Internet (7 answers total)
 
Seems to work fine if I make Safari pretend it's Windows IE.

1) open a Terminal window
2) type this (without the quotes): "defaults write com.apple.safari IncludeDebugMenu 1"
3) quit and restart Safari
4) in the menu Debug ->User Agent, choose "Windows MSIE 6.0"
5) go to the page

I'm sure there are more user-friendly ways to do steps 1-4, but this works.
posted by xil at 1:33 PM on August 25, 2006


Also, if it turns out to work fine after you log in, you should contact them and complain about their broken browser sniffing code. Squeaky wheel gets the grease, etc.
posted by xil at 1:35 PM on August 25, 2006


Awesome. Thats what I thought you could do xil, I just didn't know how... is there any other way to go about this that anyone knows of?
posted by sindas at 1:42 PM on August 25, 2006


If you use Camino, CamiTools lets you choose which browser to spoof from a drop-down list.
posted by Armitage Shanks at 1:53 PM on August 25, 2006


You can use TinkerTool.
posted by mikel at 1:54 PM on August 25, 2006


You could also install User Agent Switcher in FireFox.

And yes, tell them their browser sniffing code is stupid.
posted by AmbroseChapel at 3:59 PM on August 25, 2006


Camino's User Agent preference pane works also, if you dont want to install the whole CamiTools bundle.
posted by hardcoreUFO at 6:37 AM on August 26, 2006


« Older Is magnetism magic or what?   |   How scared should we be? Newer »
This thread is closed to new comments.