It's hard to ask a question without a question mark
August 24, 2006 3:08 PM   Subscribe

What is wrong with my keyboard (Why canèt I type properlyÉ)

For some reason I can't type question marks or apostrophes. Instead, I get É and è respectively. Other symbol keys give me weird symbols as well. These are the ones I notice the most.

I have had this happen in Firefox, MSN, and OneNote all today, but never at the same time. Previously, I have had it happen in MSN on different computers.

I know it is possible to fix by restarting my programs. Is there a way to fix this without turning everything off? And how do I stop this from happening anymore?
posted by cathoo to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Mac? PC?
posted by k8t at 3:19 PM on August 24, 2006


I expect it's a PC, since she said OneNote. Check your language settings by going to the Control Panel and 'Regional and Language Options'.
posted by matthewr at 3:23 PM on August 24, 2006


Argh

k8t: PC Windows XP

Mathewr: Under Regional and Language options, I'm set to US for everything.

It isn't happening in every program, just in one. (e.g. I'll have Word open and typing fine, but Firefox will work fine, then act up. I shut Firefox down and restart it, and everything is fine again. Replace Word and Firefox with any programs you can think of)
posted by cathoo at 3:44 PM on August 24, 2006


Did it use to not happen? Why not restore to a previous point?
posted by k8t at 3:51 PM on August 24, 2006


Is it a fancy-pants keyboard with fancy-pants drivers (wireless, multimedia keys, blah blah blah) or plain old Jane old, P/S-2 type boring? As in, I'm sure it's not a hardware issue, but you might have borked (insert Flash and Dazzle brand name here) drivers. Worth a shot...
posted by ZakDaddy at 4:16 PM on August 24, 2006


Sheesh, thought of this and forgot to type it. Dig up an old plain $5.00 keyboard and try it. Note - if it's a P/S-2 keyboard, make sure you power down the computer first. P/S-2 is not hot-pluggable the way USB is, and you could fry your motherboard.
posted by ZakDaddy at 4:17 PM on August 24, 2006


It's currently a problem on my school laptop, but it's happened before on my old desktop. The only thing the same about the two machines is that they are

Did virus scans, malware scans and everything is the most up-to-date version.

Some more key problems: ctrl-, gives me ', and the left-squigly bracket key does the hats and dots over the previously typed character. It does seem like a language problem, but everything is set to US.
posted by cathoo at 4:28 PM on August 24, 2006


In regional and language options, make sure that your standards and formats are "English (Canada)" (since you live there). Your location can be Canada as well.

On the Advanced tab, use English (United States) for language for non-Unicode programs.

On the languages tab, click the details button for text services and input languages and make sure that English (United States) - US is the default input language and that you only have English (United States) -> Keyboard -> US in the installed services section. Remove any entries for Canada (if upon removal you get an error message, simply close the error and then try again. It's a strange bug in Windows).

The characters you've mentioned are from the French language definitions in the English (Canada) input language. If you have both the US and Canadian services installed, Windows seems to flip between the two of them on occasion.
posted by purephase at 4:31 PM on August 24, 2006


Brilliant. Thank you, Purephase! Here's a question mark just for you: ?
posted by cathoo at 4:49 PM on August 24, 2006


You have a warm laptop and a cat, and work outside the home, right?

I came home regularly to this specific problem until I started turning it off.
posted by Sallyfur at 2:36 AM on August 25, 2006


« Older Advice on Xcountry trip thru Canada   |   Clips prep and storage for freelancer Newer »
This thread is closed to new comments.