How to get a mac to use wireless and ethernet at the same time?
August 19, 2006 5:16 PM   Subscribe

Mac networking filter: I want my Mac to be connected to a wireless network while at the same time serving music to a SlimDevices SqueezeBox (networked media player) over Ethernet. How?

The problem is that the Squeezebox seems to have some problems using its wireless network connection, perhaps not playing nice with the Apple Airport (resetting this will improve things for a while). Plays well when connected directly to the G3 iMac server through ethernet, but this connection seems to go dead when the Airport card on the Mac is turned on. The Slimserver running on the mac has a web interface, and plays internet streams, so this is why it needs to be on the wireless network. I realize that this could all be addressed with an ethernet router, but because of the physical location of various machines on the network, I would like to avoid this. And it seems like something the Mac should be able to do, only that I'm likely missing some crucial setting.

I read this earlier thread and I have it set up so that the Airport port is first in the list of port configurations, but still, the Squeezebox can't see the sever when the server's Airport card is turned on. What to do? Ask metafiter, of course.
posted by bephillips to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
does your software have a preference setting which specifies which interface to use? you want to force it to use the wired ethernet, perhaps called en0.
posted by paradroid at 5:57 PM on August 19, 2006


Part of the problem is that the SlimServer software needs to both serve music over ethernet, but be connected to the wireless network for access to internet streams and to be controlled from the network web based interface. I don't think there is any such setting in the SlimServer settings. I was hoping that the Mac OS would be able to sort all this out. I think it can, and I can't figure it out.
posted by bephillips at 6:11 PM on August 19, 2006


What you might be able to do is give the Ethernet adapter an address on a different subnet (for example, if your internal network is 192.168.0.X try putting it on 192.168.1.X. Then put the slimbox on 192.168.1.X as well.)

Then turn on Internet Sharing (in System preferences) to share the AirPort to people on ethernet.

You might have to configure SilmServer to listen on the ethernet port instead of the airport. I assume this is doable.

YMMV, I'm away from my home and don't have a squeezebox to test this with.

Good Luck!
posted by mge at 6:20 PM on August 19, 2006


I'm not clear on what you're suggesting. There is no Ethernet adapter. The Squeezebox is connected directly to the Mac with a crossover ethernet cable. I'm fairly ignorant about networking issues, I don't know about subnet, or how I might change this. There are Mac network settings for ethernet where one specifies a "subnet mask", but not when using DHCP.
posted by bephillips at 6:33 PM on August 19, 2006


Problem seems resolved. Thanks mge, though I didn't understand your suggestion, it made some sense to my friend here, and we were then able adjust network settings and everything seems to be working well now.
posted by bephillips at 7:18 PM on August 19, 2006


"ethernet adapter" in this case just means the ethernet port built in to your mac.
posted by hattifattener at 7:46 PM on August 19, 2006


bephillips: I generally find that, when setting up small home networks for things like this, that staticly assigning IPs generally works much better than trying to do the whole DHCP fandango.

Your ethernet connection ("ethernet adapter") on the Mac should not be using DHCP. DHCP is for clients to discover networking information from an upstream machine (e.g. you get your public internet IP from your ISP via DHCP).

What you're trying to do is set up your Mac as the "upstream machine" for your SqueezeBox. Thus, you should either manually assign an IP (the easiest) or run DHCP on your Mac (the slightly harder).

Your Airport is likely using the network 192.168.1.0, which means that it assigns its clients IPs of the form 192.168.1.X, where X is unique for each of its clients. You should modify your ethernet settings so that it uses the IP 192.168.2.1 (nothing magic, just an IP in a different network than the Airport is trying to use).

Then, tell the SqueezeBox that its IP is 192.168.2.2 (again no magic, just an IP on the same network that the ethernet card is on). If you can't assign it a manual address, look into what it takes to run a DHCP server on your Mac--it's Mac, so I can't imagine that it's difficult. You can then set up internet connection sharing for whatever connection actually goes out to the internet.

I strongly recommend that you read some basic tutorials on networking. This looks pretty good, just from a quick skim. It's really not that terribly difficult, but it really helps to know what's going on.
posted by Netzapper at 11:02 AM on August 20, 2006


« Older Dan Gets the Blues   |   Microsoft's taste in music Newer »
This thread is closed to new comments.