Two identical laptops: one connects, one doesn't.
July 21, 2006 6:29 AM   Subscribe

Yes, it's time for yet another tiresome wireless connection conundrum. If you're brave and true, come take my hand and follow me into the

Does anyone have any theories as to why two identical PC laptops (one beloved but dying, and its brand spanking-new replacement) would exhibit different connection behaviour? My old laptop connects perfectly to a strong unsecured wireless network in my apartment building, but the new one is recalcitrant and obstinantly refuses to connect.
It has grudgingly connected to the network a few times, so I know it can, but it generally won't. I haven't been able to figure out what was different about the times when it did connect - it seems entirely arbitrary. And I've tried to ensure that all the settings are identical, but I'm not terribly sure about what's important and what isn't, or what exactly to look for. Any thoughts?
posted by CunningLinguist to Computers & Internet (20 answers total)
 
Some important points are what version of 802.11 each laptop is using, how the wireless cards are being powered, possible interference from other devices like cordless phones, microwave ovens, and other devices like wireless keyboards and mice that may be using the same frequency. This can include other wireless networks and network cards. Also, the maker of the laptops, the wireless cards, and the software/firmware used could all be factors.

More details would probably help.
posted by ChazB at 6:36 AM on July 21, 2006


Response by poster: Well, both are 802.11 g (is that what you meant?)

No cordless phones in my house, I'm a cooking snob so no microwave, and no wireless gizmos. Plus, they are both sitting here next to each other on the coffee table, so any interference should affect both, right?

The cards do seem to be slightly different. One says:
Intel(R) PRO/Wireless 2200BG Network Connection (this is the one that works)
the other says:
Intel(R) PRO/Wireless 2915ABG Network Connection

Is that significant?
posted by CunningLinguist at 6:41 AM on July 21, 2006


From the names, the first one supports 802.11a/b/g, and the second only b and g. Here, if you scroll down to Features, is a comparison of the two cards. I don't actually know what the functional difference is, but this might help someone else figure it out.

Is there a reason you can't just swap the old card into the new laptop?
posted by jacalata at 7:07 AM on July 21, 2006


When the reluctant one connects, what speed is it getting? I ask because that one is also 802.11a compliant and it may be locked to the lower speed, and perhaps the router on the other end isn't good with .11a speeds.
posted by Dipsomaniac at 7:08 AM on July 21, 2006


Response by poster: Hey, I never thought of that. How hard would that be for someone who's never opened a laptop?
posted by CunningLinguist at 7:09 AM on July 21, 2006


Response by poster: The speeds are very high on both when they connect.
posted by CunningLinguist at 7:09 AM on July 21, 2006


Starting from the principle of eliminating the simple solutions first... is it turned on?
posted by Leon at 7:11 AM on July 21, 2006


Response by poster: Another data point, dunno if it's important. A third latop, this one a cheapo Acer, also won't connect to the signal, though it did once or twice, just like my new Fujitsu.
But the old Fujitsu connects perfectly every time.
posted by CunningLinguist at 7:11 AM on July 21, 2006


Try these ideas in any order. Any one of them may fix the problem.

1. Open internet explorer, go to the tool -> internet options menu. Click on the connections tab then the setup button to run the network setup wizard. Most answers should be the default ones.

2. unplug the power from the router briefly.

3. Remove the wireless card drivers and reboot.

4. Open the network connections window, right click on the wireless connection and select repair. I would unplug the router briefly before I repaired the connection.
posted by rsclark at 7:23 AM on July 21, 2006


Possibly the wireless router you are connecting to has a limited number of DHCP addresses and has reached its limit. Try doing an ipconfig /release on the laptop that works reliably then shut it down. Then power up the other one. After powering up if it still can't connect try #4 from rsclark's post.
posted by banshee at 7:53 AM on July 21, 2006


Response by poster: banshee, I'm a little leery of doing anything to mess with the one connection that *does* work.

(I've also already hit "repair" numerous times, and turned on and off the card both manually and through the program.)
posted by CunningLinguist at 9:02 AM on July 21, 2006


See if you can get into the properties for the problem card, Control Panel > System> Device Manager, right click on the card, and see if there's a tab called "advanced." Disable any power saving features, and max out the card's signal output.
posted by Brian James at 9:37 AM on July 21, 2006


Several things might be a problem here.

1) Try one machine at a time, with the others shut down; reset the router in between.

2) Make sure that encryption is disabled on all machines and the router.

3) Make note of the MAC address on the wrouter, and make sure that's the AP you're associating with. Check whether the signal levels look similar.

4) Check with ipconfig to make sure you're receiving a valid IP address (169.254.x.x is not usable for a wireless network). If you reset the router each time, you should get the *same* IP address on each laptop, but as long as you get one, you're ok.

5) There is no number 5.

6) You don't mention what make and model router you're using, or whether you've factory-reset it. We're also only assuming that the laptops both have internal wireless adapters. Does the new one link to any *other* AP's?
posted by baylink at 10:44 AM on July 21, 2006


What Brian James said.

I have an Intel(R) PRO/Wireless 2915ABG on my laptop and the Properties box has an Advanced tab with a scroll box of choices. One of them is Power management, which came set at about half way, to balance performance against battery life. I cranked mine right up, and then disable wireless when not using it, to save the battery. There is also a Transmit power selection, but I think mine was maxed by default.
posted by Idcoytco at 11:00 AM on July 21, 2006


Best answer: write down the ip, mask, gateway and dns from the one laptop that is working and then configure the laptop that is not working to use a static ip with those same settings except for the last octet of the ip address

ie: working laptop ip addr: a.b.c.101
set the non-working laptop to a.b.c.250 (all other ip settings the same as the working laptop) and test. If no go, then decrement the value up by one and test again.

Or ... you could try setting the non-working laptop to use the same MAC address as the working one. Don't use both at the same time though.
posted by banshee at 11:26 AM on July 21, 2006


Are there any other networks you can try to connect to (a friend's house, coffee shop, etc)? If you can do that, you can rule out the card itself being faulty.

Also, you can try bringing in a friend's laptop to see if it connects to the network in your building. This may help with diagnosing the DHCP problem suggested by Banshee.
posted by concrete at 12:51 PM on July 21, 2006


Response by poster: banshee's solution sounds good - I'm just not sure I'm up to handling that. (Mask? DNS? whuh?) I can give it a shot though!
(A third laptop, the Acer, also will only sometimes connect to that network, so I think maybe there's something magical about the settings on the old laptop.)

Thanks for the suggestions, people. (And can you believe how fast questions scroll off the page these days?)
posted by CunningLinguist at 1:52 PM on July 21, 2006


Response by poster: Oh my goodness. Banshee - I think it worked!
posted by CunningLinguist at 2:26 PM on July 22, 2006


Response by poster: Let it be known: Banshee is a freaking genius! Changing the mask and whatever settings totally worked, and I know it was that, because when I changed them on the third computer, that one connected immediately too!
Woo-hoo! AskMe to the rescue!
posted by CunningLinguist at 3:23 PM on July 22, 2006


Response by poster: Aw crap. I spoke too soon. It connects more frequently, but still only occasionally. Something is still wrong. Phooey.
posted by CunningLinguist at 8:14 AM on July 23, 2006


« Older Thanks for the tug   |   Help! My diamond ring is missing! Newer »
This thread is closed to new comments.