Help! It's dark! I can't VNC!
July 18, 2006 11:51 AM   Subscribe

VNC gets me a black screen. Help me connect !

I have several computers in another office which is under construction. I've got the server and the desktops set up in a safe location there so I can do whatever software and configuration tweaks remotely while the office is being set up, rather than as a crash project right before they open.

I installed most of the software, etc. and the computers and the server all run fine at the remote site, connect to our network, etc. Remote access to the server works fine.

I installed VNC on the desktops in order to do my remote access. But I must have missed a setting or something somewhere when setting up the PCs (power management?), because I can access them through VNC, but all I get is a black screen. I think I've seen this before - a machine had gone into hibernate? standby? mode and all someone had to do was press a key on the actual machine to "wake" it so that I could log in.

Sound familiar?

Since it would take 3 hours to go there and hit the spacebar then come back, is there another way to wake these PCs remotely? And if/when I do have to go down there, what's the proper setting so I never get this can-access-but-not-wake-PC problem again?
posted by bartleby to Computers & Internet (7 answers total)
Usually this is down to one of two things: either the VNC server is set up to require the user to manually grant permission for the client to take over (see the options for Xvnc for turning off authentication), or the user has enabled a password-protected screensaver.
posted by Blazecock Pileon at 12:02 PM on July 18, 2006

Also check the Energy Saver settings: you can turn off the display without sleep-ing the computer.
posted by Blazecock Pileon at 12:04 PM on July 18, 2006

If memory serves me correctly, that is/was an issue with XP and 'fast user switching' enabled. Is the vnc server on XP?
posted by whatisish at 1:18 PM on July 18, 2006

Response by poster: Yes, sorry, should have said. UltraVNC on XP sp2 boxes.

Worked last night after I set it up, but no go now w/the black screen. Locked? Asleep?

How about someone maybe walk me through enabling Remote Desktop (for our subnet only) also/instead?
posted by bartleby at 1:40 PM on July 18, 2006

Have you tried disabling 'fast user switching' so that only one profile is logged in at a time on the server machine?
posted by whatisish at 1:48 PM on July 18, 2006

posted by whatisish at 1:51 PM on July 18, 2006

I've also seen the black screen when connecting to 2003 server/XP boxen when the network bandwidth is a little choked. Not saturated, but just.. busy. Web traffic, for instance, flows fine.

Just not VNC (or RDP).

It's a right bastard, I can tell ya.
posted by coriolisdave at 2:27 PM on July 18, 2006

« Older good morning, good morning - it's great to stay up...   | legit? Newer »
This thread is closed to new comments.