Solving IRQ conflicts?
December 22, 2003 8:59 PM   Subscribe

What do you do when two devices want the same IRQ and are unwilling to share? (more inside)

On the advice of one or two Ask contributors, I picked up a Panasonic LC33 digital camera (I'm pleased, so far). After much troubleshooting, I determined that I had to install a new (2.0) USB card. Except, when I started my machine, I lost the printer. Seems the USB card wants to hang out at IRQ #7, where LPT1 used to live. IRQ #3 is available, but the BIOS won't let me put the parallel port there. I'd like to know what I need to do to have both devices available at the same time.

I realize that "Buy a USB Printer" and "Buy a new computer" are both good answers, but I'd like to avoid those steps. Running a Gateway box with a P200 and W2K Pro.
posted by trharlan to Computers & Internet (14 answers total)
 
If you're not using your serial ports, try setting one or both of them to "disabled" in the BIOS, that may free up a usable IRQ for your USB card.
posted by mr_crash_davis at 9:34 PM on December 22, 2003


Well, if you can't change either IRQ, you're a bit SOL --keep in mind that some IRQs are "linked", but it's been too long since I played with them to remember which with which. OTOH, there are such things as USB-to-parallel adapters (a Google search says ~$5/ea) so there is a work-around...
posted by costas at 9:47 PM on December 22, 2003


Pulling out all of the cards and putting them in different slots will sometimes fix this problem. Hopefully once the IRQs are reset the computer will drop them into unused numbers. Try and free up IRQs and then swap some cards.
posted by y6y6y6 at 9:57 PM on December 22, 2003


See if there are jumpers on the cards to change the IRQ + COM it wants to use.
posted by holloway at 10:06 PM on December 22, 2003


I second y6's notion, only I'd recommend not going hogwild, and simply try swapping the usb or shifting it to an empty slot. Also some BIOS's (mine does, but I don't have a clue which ones) have a way to manually assign IRQs to certain slots. Sometimes this helps, sometimes it doesn't. Might need to update your bios, or go with one of the other suggestions. Good luck
posted by woil at 10:36 PM on December 22, 2003


You may also try the following:

1. Opening Device Manager (Control Panel > System > Hardware tab > Device Manager)

2. Bring up the properties for LPT1 (Double-click on Ports, right-click on LPT1, and select Properties)

3. Inspect the options within. Via the Port Settings tab, I can switch between "Try not to use an interrupt", "Never use an interrupt" and "Use any interrupt assigned to the port". (The middle is currently enabled.)

4. Similarly, you could uncheck "Use automatic settings" via the Resources tab and attempt to manually set the IRQ if your machine allows you to do so.

Every machine and piece of hardware can behave differently, however, so apply these changes with due caution.
posted by Danelope at 10:41 PM on December 22, 2003


You should be able to downgrade your printer port from ECP mode to EPP or bi-directional mode in your BIOS, which will make it not use an IRQ at all. Note that some BIOSs require you to first change the mode and then change the IRQ to none separately to get the desired effect, and some just let you manually tell it not to use an IRQ and selects the right mode behind the scenes. Whatever the specific steps, you should be able to set your printer port not to use an IRQ in the BIOS at the expense of somewhat slower data transfer speeds.
posted by boaz at 12:28 AM on December 23, 2003


If you don't mind reinstalling your OS, you may be able to enable APIC mode in your BIOS. I am, however, unsure whether a machine so old would even have the option. It will help you out on the IRQ front though, but usually requires an OS reinstall.
posted by wackybrit at 1:53 AM on December 23, 2003


I assume you currently have a USB port on your PC, and the problem is your camera won't work with it for some reason. If this is the case, abandon the idea of direct connecting your camera, and get a USB reader for the built in SD memory cards. You shouldn't even need Windows drivers to do this, and they cost less than $20.

It's my understanding that doing memory card transfers is generally faster than connecting a camera to your PC.
posted by SteveInMaine at 3:02 AM on December 23, 2003


Depending on the vintage and make of your machine, you ought to be able to pop into the BIOS configuration screens and select a list of IRQ lines which are reserved for ISA devices and won't be offered to PCI devices. Your printer port is an ISA device (even if you don't have ISA slots), so reserving its interrupt isn't a bad idea at all.

If you strike out with that, you should be able to reconfigure the printer port to be an "SPP:" a standard printer port, which doesn't require the interrupt to be available.
posted by majick at 4:41 AM on December 23, 2003


Keep in mind that some printers need an ECP or EPP port to enable 2-way communication features: error reporting and diagnostics, ink level monitoring, and so on.

And I second the suggestion that you buy a card reader instead - they're getting ridiculously cheap.
posted by mmoncur at 7:17 AM on December 23, 2003


Remember that even if your computer is running fine, if you are serious at all about sound you should make sure its IRQ isn't shared. There are a few reasons for this; if both devices are in use at the same time (NIC and Soundcard is a popular shared setup.
posted by Keyser Soze at 4:42 PM on December 23, 2003


), you may hear sound glitches as the data is being requested at the same time by both devices. I remember fondly helping a client with a video card and sound shared. During games, the computer would lock up.
posted by Keyser Soze at 4:44 PM on December 23, 2003


Dunno if any eyes are peeping around here anymore, but, problem solved, thanks exclusively to Ask.

I am grateful.
posted by trharlan at 11:28 PM on December 27, 2003


« Older Why was Catcher in the Rye banned?   |   What are some good world-band radio stations and... Newer »
This thread is closed to new comments.