Help me set Firefox as the default browser. No, really.
April 24, 2006 8:28 PM   Subscribe

I installed MS Excel after Firefox and now Excel is convinced that URLs need to open in Internet Explorer. I tried the suggestions in Excel's help file to change it back. They didn't work.

I tried setting IE as the default browser (from within IE), restarting, then setting Firefox as the default browser (from within Firefox). That didn't work.

I tried uninstalling FF, restarting, then reinstalling and telling it that it should be the default. That didn't work.

I tried Start --> Settings --> Control Panel --> Add/Remove Programs --> Set Program Access and Defaults, and setting the default browser to "Mozilla Firefox." That didn't work.

I tried Folder Options -- File Types and then changing URL: File Protocol and Internet Shortcut to point to Firefox. That didn't work.

I changed every URL: * to point to Firefox. That didn't work.

I tried downloading this program Setbrowser. And yes, it didn't work.

So: how is this done?

win2000, SP3, Office 2003.
posted by Tuwa to Computers & Internet (9 answers total)
 
Looks like you need SP4:

Bug.

SP4 (net Install).

SP4 (Express Install).

And this is in German, but has a big list of bugs (in English) that this should fix.
posted by dsword at 8:52 PM on April 24, 2006


Direct bug fix here.
posted by dsword at 8:58 PM on April 24, 2006


Well, I didn't know about that bug. I installed SP4. It did not work. Excel still opens IE.
posted by Tuwa at 9:47 PM on April 24, 2006


I had a similar problem, where IE remained convinced that it was the default browser in certain situations.

Eventually I realised that there are at least 4 file types associated with IE in the folder options -- file types menu.

as well as url and internet shortcut, I also changed HTM and HTML to be associated with FF. That did the trick for me.
posted by Touchstone at 3:20 AM on April 25, 2006


Thanks, Touchstone. I checked and those are set to Firefox too. It's like there's some super-secret setting that you have to kidnap Bill Gates to find out.
posted by Tuwa at 7:53 AM on April 25, 2006


A user of mine has the same problem, except it's Excel and Thunderbird (Email spreadsheet function). I "solved" it by telling him to just save it and send as usual. I guess in this case it'd be "Copy Link to Clipboard", "Paste into FF".

Sorry. If you ever do kidnap BG, I'd be up for that.
posted by hoborg at 7:25 PM on April 25, 2006


I thought of that, hoborg. Unfortunately it's not a workable solution in this case because someone has taken the time (how much? a lot, I think) to embed links in the text in every field of a ~2500 row column. So I'd have to hover over the text until the URL shows up, repeat it a few times, switch to the browser, type it in, make a mistake every now and then, switch back to Excel to see what it was....

For now I'm using OpenOffice, which is perfectly content to let the links open in Firefox as instructed. It takes a hell of a long time to save this spreadsheet after any changes, though.
posted by Tuwa at 8:16 AM on April 29, 2006


Try this:

Go to Control Panel - Add/Remove Programs -Set Program Access and Defaults (bottom button on the left). Click Custom. Change the web browser from 'my current..' to Firefox. Click OK. You'll see a funny little graphic, and then it's set.

I just found out about the "stumped" tag today. It's fun. I did not kidnap Bill Gates.
posted by donnagirl at 8:17 PM on October 2, 2006


Thanks for the suggestion. I tried that; it didn't work. Excell still wants to open the links in IE.

I don't know whether to thank you for not kidnapping Bill Gates. I'm sure he appreciates it, though.
posted by Tuwa at 8:39 PM on October 2, 2006


« Older The impossible dream of sharing my Canon printer...   |   Day of Marathon Planning Newer »
This thread is closed to new comments.