Help! My iPhone keeps hijacking my Bluetooth headphones.
August 5, 2022 1:49 PM   Subscribe

I have a pair of Jabra earbuds that I have paired with both my iPhone and my MacBook Pro. If I'm using them with the MacBook, and the iPhone makes any kind of noise, it "helpfully" cuts off the MacBook audio and switches to the phone. This is frustrating when I'm on a videoconference on the Mac. Can you help me make this stop?

I realize I can do this by unpairing the earbuds from the phone. That wouldn't be a major hassle, since I rarely use the earbuds while actually making a phone call, but I like to listen to music from the phone when exercising. Still, I might need to do that; it's increasingly frustrated when my phone plays a sound (such as a Dark Sky weather alert) and I miss a sentence or two of the videoconference.

I've found instructions on how to do this with AirPods, but that doesn't work with my Jabra earbuds.

Any solutions, short of unpairing the earbuds and phone and repairing when needed?
posted by brianogilvie to Computers & Internet (12 answers total)
 
I just turn Bluetooth off on my phone when this happens.
posted by maleficent at 1:53 PM on August 5 [4 favorites]


Yes, the easiest way to do this is to just turn off your phone's bluetooth when you're going to be on a videoconference. The fastest way to do this is to swipe diagonally downwards from the upper right corner of your iPhone's screen and toggle the bluetooth icon (in the same little box as the "airplane mode" icon).
posted by heatherlogan at 1:54 PM on August 5 [1 favorite]


you don't mention the Jabra Direct software. i would start by installing that on the computer to see what addition control options are available.

i'm on Windows so idk what the Mac version can do, but if you're not familiar with it Jabra Direct is kinda their catch-all software that adds support and controls for almost all of Jabra's stuff. it was essential when i was doing a classroom AV install in order to configure and drive their conference-room-style cameras, for example.
posted by glonous keming at 1:56 PM on August 5


Response by poster: Forgot to mention: iOS 15.5, MacOS Monterey 12.2.1 (to be upgraded when I'm back home).

Not to threadsit, but I'd like a solution, if possible, that didn't rely on my remembering to turn off Bluetooth before each videoconference, because odds are that I would either forget to turn it off until the first interruption or forget to turn it on and then discover hours later that my Garmin watch isn't syncing.

glonous keming, the Jabra Direct software works on MacOS only if the headphones are connected using Jabra's Bluetooth adapter. It doesn't recognize headphones connected to the Mac's Bluetooth adapter. I checked the Sound+ Jabra app on my phone, but it doesn't have any controls that look relevant.

No more threadsitting....
posted by brianogilvie at 2:19 PM on August 5


Have you considered turning off all alert sounds on your phone? Or even turning it on silent mode?

You mentioned you have a Garmin watch, and that notifies you without requiring sound.

(My phone has been turned to silent for years. Random phone noises are great for interrupting your concentration without providing any actual information.)
posted by meowzilla at 2:39 PM on August 5 [1 favorite]


You may be able to use automation to automatically turn off Bluetooth upon connecting to home WiFi

https://discussions.apple.com/thread/253616891


Else, if your videoconf is scheduled, you may be able to use the Calendar to turn Bluetooth on/off.
posted by kschang at 3:42 PM on August 5


In all honesty, this reason was exactly why I gave up trying to pair any single bluetooth device with both my phone and macbook simultaneously. Airpods work best here, but even they screw it up on occasion. It should be possible, this should be something we’ve solved by now, but the hassle became more trouble than it was worth.
posted by cgg at 4:37 PM on August 5 [2 favorites]


You could also create a new Focus mode for meetings, that would silence all notifications other than ones that you actually want to emit sound. Unlike turning off bluetooth, if a Focus mode is on, it's very visible. When you turn off Focus mode, I think it displays all the notifications that happened during that time.
posted by meowzilla at 6:11 PM on August 5 [1 favorite]


Have you tried manually disconnecting the headset from the Bluetooth settings menu from your phone? It shouldn't automatically take control if it's not connected.
posted by dobi at 6:32 PM on August 5


I think what OP described is default behavior for a "multipoint" bluetooth headset that is simultaneously connected to BOTH the phone and the PC. However, the phone was connected first and is considered "primary" connection, and thus, overrides the sound for PC while it has a sound to play.

The only true way to negate this is to either silence the phone or disconnect Bluetooth while meeting is on.
posted by kschang at 10:35 PM on August 5


Actually, reverse the pairing order may do it as well. Reset the headset, pair PC first, phone second. So PC is the primary, and phone will not interrupt the PC connection. MAYBE.
posted by kschang at 12:40 AM on August 6 [1 favorite]


Perhaps buy a second pair of headphones to dedicate one to each device?
posted by conrad53 at 6:51 AM on August 6 [1 favorite]


« Older Impromptu late August Maine or ?? vacay?   |   IAH outdoor hangouts? Newer »

You are not logged in, either login or create an account to post comments