How to stop address bar disappearing in Firefox full screen on Mac?
February 3, 2022 7:06 AM   Subscribe

Not too long ago, Firefox started hiding everything except the main window when in full screen - no bookmarks, no tabs, no address bar, no title, no menu. When I go to use the back button in Firefox on my Mac, I bring the cursor up to the top of the screen and everything pops back into view. But when I bring my cursor over the back button, the title and menu bars hide again, thus sliding the back button out from underneath my cursor. This drives me crazy.

Searching general troubleshooting tips only brings up people who are having the opposite problem, wanting the address bar to disappear instead of stay on screen. Trying to follow those instructions in reverse has not fixed anything. I also haven't been able to find a browser extension that fixes this. Nothing in settings is an obvious fix for this. Thanks.
posted by HeroZero to Computers & Internet (6 answers total) 7 users marked this as a favorite
Have you tried all of your F keys in turn? On Windows it's F11 to turn that feature on and off.
posted by DarlingBri at 7:45 AM on February 3, 2022 [1 favorite]

Response by poster: Bless you. F6 on Mac.
posted by HeroZero at 7:48 AM on February 3, 2022 [2 favorites]

Best answer: F11 on Windows fullscreens the webpage you're looking at, but this is something else.

HeroZero, try typing "about:config" into the address bar and accept the warning, then type "hide" into the search bar you're given at the top of this list. Be delicate in here, this is working-under-the-hood, you-can-break-things territory, but if you select the preference called "browser.fullscreen.autohide" and click that two-arrows button to the right of it until it says "false", then close the about:config tab, that should sort you out.
posted by mhoye at 7:51 AM on February 3, 2022 [3 favorites]

Response by poster: mhoye -- that seems to have done it , that you.

F6 on Mac switched focus to the address bar, but did not make it permanently sticky. I have now bookmarked the mozilla Firefox keyboard shortcuts list and should hopefully be less grumpy in the future.
posted by HeroZero at 7:56 AM on February 3, 2022

Best answer: Also, I have found that almost always with Mac apps I don't want full-screen, I want the window to occupy the region of the screen below the menu bar. Option+Click on the maximize button does this without fiddly resizing.
posted by straw at 8:48 AM on February 3, 2022 [5 favorites]

straw says what I was going to say. Note that option-zoom doesn't always fill the screen (though it does in Firefox): with a lot of apps, it just makes the window "big enough."

Just clicking the zoom button will make the content of that window take over the screen, including the dock, menubar, and window chrome. That's the expected behavior. I'm not sure how you got it to not do that.
posted by adamrice at 8:56 AM on February 3, 2022

« Older New watch - stops working often   |   Recommend project management training for the... Newer »
This thread is closed to new comments.