My internet doesn't work
April 8, 2006 12:00 AM   Subscribe

Linuxfilter: why doesn't the internet work?

So, let me preface this real quick. I'm fairly a experienced Windows guy, and my google/network fu is strong. However, this is my first real Linux attempt. I'm not afraid of the terminal, or writing any code, though, so please don't feel the need to dumb down anything.

Anyhow, here's my problem. I installed Suse 10.0 on my Asus Z9000 (1.7Ghz dothan, intel 2200 wifi card, Ati IGP9100 + whatever northbridge Ati supplies with that) laptop today. The install went fine, and everything was very shiny. But I'm having trouble with my network connection.

My router is using WPA encryption, but I don't that's the trouble. The laptop is able to connect to the router, and is assigned an IP, so that's alright. I can ping the router, other clients, and localhost, so that's alright too. What I can't do, is browse the web! When I try and ping google.com, host can't be resolved. If I put in the IP for google, it says network unreachable. But, I'm definitely connected to my router, so I'm a little confused. I thought it might be blocking DNS, so I've turned the Suse firewall off, but that didn't do anything.

What's the deal?
posted by Drunken_munky to Computers & Internet (10 answers total)
 
(Also, I should probably mention, both wired and wireless connections exhibit the same behavior)
posted by Drunken_munky at 12:08 AM on April 8, 2006


Ok, sounds like it might be two problems. First, check to be sure that the DHCP program (usually dhclient) is updating your /etc/resolv.conf correctly. It should look something like:

search example.com
nameserver 192.168.0.1
nameserver 1.2.3.4


The 'search' line isn't necessary, that just sets the default domain for single-name hosts. But you need at least one nameserver.

If that's not right, try manually putting your DNS servers there. (Be aware that dhclient may overwrite that file, so this is just a temporary fix.)

Then try a lookup. (ping www.google.com). If that fails, try nslookup... run that command by itself, and it will show you what nameserver it's trying to use. Type in 'www.google.com' at that prompt and see what you get.

I think one of those steps should show you where the DNS problem is.

For the 'can't reach outside hosts' problam, when do you see when you run a traceroute?

Also: check to be sure you have a default route... if your DHCP client isn't talking right with the server, it may not be adding a default route. Try:

route add default gw 192.168.0.1

substituting your gateway address for 192.168.0.1, of course. And you have to run that command as root.
posted by Malor at 12:13 AM on April 8, 2006


Another thing to check is whether you've set up some policies or restrictions on the router. It happened to me, I played around with the settings when the router was new and then forgot about it until a year later, when weird things started to happen with a new client.
posted by dhoe at 12:32 AM on April 8, 2006


odd. how did you install (via network or disk)?

the firewall is a red herring, as you've seen - as long as "protect firewall fom internal zone" is not selected in "allowed services" (yast firewall) then you should have no problems for connections in conversations initiated from your own computer).

in yast's "network devices" does "network card" show the information you expect? it should be "dhcp" next to the card name and "edit" should give you a page showing "automatic addresss setup" selected; check the "detailed settings" there.

that's the easy (gui) way to check the settings related to dhcp, routing etc. sorry if this is obvious - not sure how far you've got. also disclaimer - i'm using suse 9 so some details may have changed.
posted by andrew cooke at 5:29 AM on April 8, 2006


Who is the ISP you are trying to connect to? Comcast, perhaps? If so, be aware that Comcast recently changed their DNS server setup. Essentially requiring everyone to use dynamic DNS settings.
If not, nevermind.
posted by Thorzdad at 7:14 AM on April 8, 2006


Get the gateway setting fixed first. You should be able to ping the nameserver(s). THEN work on the DNS resolution issue, if there is any after fixing the gateway.
posted by intermod at 9:20 AM on April 8, 2006


I was assuming he'd be running an internal nameserver... oops!

Intermod is right... if you're running an outside nameserver (one past your router), you have to get the default gateway working FIRST, then DNS.

Sorry.
posted by Malor at 12:32 PM on April 8, 2006


Thanks for all your advice guys, I managed to get it working! (I'm posting from Konqueror... but it's kind of bleh, I think I'll stick with Firefox).

However, rather than procede in calm, logical manner, I instead opted for the more classic "fiddle with stuff until it works" approach. So I don't really know what exactly it is that I've done.

After a series of edits to various things, I've found that if I have a host name, I run into issues. But once I remove that, it works fine. I don't really know why that is, though, and it definitely wasn't always the case. My router is a Linksys wrt54g, running the latest hyperwrt +thibor, if anybody still wants to donate some brainpower.

I think Yast might be having trouble with dhcpcd, but what kind of trouble I don't know. Also, I've managed to completley break my wifi. The settings are all still there, but it wont associate. But that's another can of worms, altogether.

On a rather inflamatory note, I'll say this: I've never, ever had this much trouble with any post 9x version of Windows. And I work at an ISP! But, then again, I might just be kind of soured on the whole experience. I'll stick with it, and see how it goes. Thanks again!
posted by Drunken_munky at 2:14 PM on April 8, 2006


Drunken... these days, when something is that hard in Linux, it's usually because you're looking in the wrong place. There's almost always something reasonably easy to tweak to get things going. Unfortunately, all the old layers of complexity are still down there, so if you start digging in the wrong place, you can very rapidly end up in a very, very deep holes. And there aren't any warning fences to keep you out of the stuff you shouldn't need to touch anymore.

Unix, in general, will let you do whatever the hell you want to do, even if it's completely wrong and will launch nukes at Russia. Once you really understand what you're doing, there's just no substitute for the kind of power you have at the Unix command line. Getting to that point, however, takes quite a while. Remember you've been training yourself with Windows for years... you've been working on Linux, an OS from a totally different background, for just a ocuple of days. Be patient... it'll likely grow on you.

Also, don't give up on Linux because the SUSE tools were confusing. Each distro has its own. Try Ubuntu. It's _really_ nice.

Finally: remember that laptops are almost always the worst thing to try Linux on... of all possible hardware, you picked the hardest. :) It's just not there yet for portable usage, and I have been wondering lately if it ever will be... progress in that area has been glacial.

If you really want a portable Unix, the overall geek choice seems to be OSX, particularly the new Macbook Pros.
posted by Malor at 5:53 PM on April 8, 2006


Dammit with me and the typos recently, argh! 'hole' and 'couple'. Grrr.
posted by Malor at 5:54 PM on April 8, 2006


« Older Is it possible to share network/internet...   |   How to put together the ultimate Computer security... Newer »
This thread is closed to new comments.