Email web page function in Firefox is broken
September 13, 2021 4:04 PM   Subscribe

I'm using Firefox 92.0 on a Mac version 11.5.2. This is a recent update of the browser. In the last version the drop menu under file had a selection share page which would open my Gmail with a message form to send a web page to recipients. This has changed in the new version share now has several options by which a page can be shared including mail, text, and air drop.

My problem is that when I select mail it doesn't open Gmail anymore. It opens the Apple email app, which I do not use and don't want to use. Not only so, it doesn't work to mail web pages. I've checked preferences and cannot find where to set or reset the preferred email app.

Any suggestions on how I can bring back Gmail to this function?
posted by partner to Computers & Internet (6 answers total) 1 user marked this as a favorite
 
On my Mac 92.0 version I can go to the preferences in Firefox (Firefox menu > Preferences) and search for "applications". That gives me a list of "Content Type" on the left and the app that handles the content type on the right. I can choose "Gmail" from there … however it doesn't work to change the actual result of clicking the share button!

Instead, at the top of that dropdown list of applications I have it set to the first option (ends with "(default)", which looks like it uses the Mac's default mail application, which is (somewhat paradoxically) set within macOS's Mail app.

Open the Mail app and go to the preferences there. At the top of the "General" tab is the setting "Default mail reader". If you set that to Firefox I think your Share flow should work again.
posted by wemayfreeze at 4:56 PM on September 13


Response by poster: @wemayfreeze — On the Mail app Preferences/General/Default Mail Reader there is no Gmail option. That was a hopeful solution, but no dice.
posted by partner at 5:17 PM on September 13


If I right click on my Firefox toolbar and select Customize Toolbar... there's an icon for Email Link that can be dragged up to the toolbar. Clicking this unfortunately only switches to Chrome for me (Chrome is my default browser), but it might be worth a shot?

I also have an option for Gmail in Firefox's application settings for handling "mailto" like wemayfreeze mentioned - you may be able to set that to Gmail instead of Mail. (screenshot)
posted by enigmango at 5:35 PM on September 13


Response by poster: @enigmango — I do have "mail to" set to Gmail. Still no luck.
posted by partner at 6:45 PM on September 13


To clarify, for my instructions the "Default email reader" needs to be set to Firefox, not Gmail. If you don't see Firefox in the dropdown, choose "Select…" at the bottom and navigate to your Applications folder (if it doesn't automatically open to that folder) and select Firefox there.
posted by wemayfreeze at 7:14 PM on September 13


Response by poster: I figured it out:
At the far right of the tool bar that includes the URL address field is a drop-down list of various functions and tools. At the bottom of that list is More Tools. This opens a list of options. At the top of this is Customize toolbar. This opens a page of icons of various options that can be dragged to the toolbars. There is a Email Link icon. I dragged it and now there is a envelope icon on the left side of the tabs tool bar right next to the Home Page icon which, when clicked, opens the Gmail message form with the title in the subject field and and the page's URL in message area. So, there you go.
posted by partner at 7:30 PM on September 13


« Older Translation help, please   |   Alternative to Mailchimp? Newer »

You are not logged in, either login or create an account to post comments