Why is optical digital audio locked at full on a Mac?
April 2, 2006 4:37 AM   Subscribe

What prevents the volume control working on a Mac when the optical digital audio output is being used?

I've just bought an Intel Mac Mini... ostensibly for use as a media centre, but am annoyed to discover that when I have a optical digital audio cable plugged in, the system volume control doesn't work at all (it's locked at full volume all the time).

Is there a technological limitation with optical digital audio that prevents volume adjustment? (I have a cheapish digital TV tuner box that suffers from a similar problem)

If so, is there any possibility that this problem might be fixed in the future... either by Apple or a third party hack? it's an annoying down-side to an otherwise great media centre machine.
posted by bruceyeah to Computers & Internet (10 answers total)
Are you sure it's a problem? Sounds to me like a feature.

If the volume isn't at 'full', then you lose resolution on the sound signal being (digitally) transmitted from the Mini to the other device. I'm guessing you don't want to reduce the quality of your audio.

The only device that should be deciding 'volume' is the device that performs the analog conversion (i.e. is connected to the speakers).
posted by lowlife at 5:15 AM on April 2, 2006

Yeah, shouldn't your receiver be the volume control device, and not the mini?
posted by antifuse at 5:33 AM on April 2, 2006

A similar thing happens to my PC when its connected to the amplifier via SPDIF or TOSLink.

Is there a technological limitation with optical digital audio that prevents volume adjustment?

I believe so. I overcame the problem by writing an little (Windows) service to lock the WAVE volume to whatever the master volume was changed to. There maybe a similar solution for the Mac somewhere but I wouldn't know where.
posted by ed\26h at 5:33 AM on April 2, 2006

The rational explanation would be the optical output is meant to be a raw output, and doing processing (even adjusting the volume) would mess that up.

Possibly the real reason is that it's genuinely impossible (or at least impractical) to adjust the volume of a Dolby Digital signal from a DVD, so they disable it all the time for consistency.

The AirPort Express has an optical out with an adjustable volume control.
posted by cillit bang at 5:49 AM on April 2, 2006

Response by poster: Interesting... so how is the AirPort Express volume adjusted by the user? Deosn't that imply some level of audio processing?

I suspected there was some technical reasoning behind this. It just seems like an annoying thing to leave out... as the consistent volume up/down keys are one of the nicest things about switching to a Mac keyboard!
posted by bruceyeah at 6:06 AM on April 2, 2006

Best answer: If you mess with the outbound volume at all, it changes the bitstream. If Apple isn't differntiating between 'computer sound' and 'DVD sound', as Windows does, it would damage digitally-compressed bitstreams, like Dolby Digital. It would turn them into a long hiss. Apple is probably making sure the music is truly lossless to your receiver, which normally would control the volume. However, it's possible that you're getting the worst of both worlds... it may be resampling up to 48Khz (very common on Intel-based hardware) and then refusing to do volume control on top of that.

To find out if you're really running true lossless sound (which is good), you can download this 44.1khz DTS-encoded WAV file [self-link, 55 megs]. Set all your computer volumes to max, but turn your receiver volume WAY DOWN (you don't want to damage your speakers if it's not working) and play it back. If you get multichannel classical music, you have true lossless sound. If you get only a hiss, then hit stop, powercycle your receiver, and immediately hit play again. If you still get only static, then most likely Apple is just lazy, not lossless. :)

if it turns out you're truly lossless, then a digital volume control would probably degrade your sound a bit. If you're not lossless, then you should be jumping down Apple's throat for not including it. :)
posted by Malor at 8:51 AM on April 2, 2006

Let me reiterate... all the volumes on the computer need to be maxed. If anything is trying to change volume on the computer, it'll break the encoding and will give you only a hiss.
posted by Malor at 8:52 AM on April 2, 2006

Interesting... so how is the AirPort Express volume adjusted by the user? Deosn't that imply some level of audio processing?

The audio processing required to do it with ordinary stereo sound is trivial and they could do it on the Mac mini if they wanted to.
posted by cillit bang at 9:22 AM on April 2, 2006

Response by poster: Wow... thanks Malor!

The WAV sound plays perfectly. In fact, the receiver flips to DTS mode if I play that wav, then back to normal if I play anything else.

(btw. the volume on the computer is maxed.. as I said in the question, there's no other setting for it if I use the optical output!)

Looks like I'll just have put up with having an extra remote lying around just for volume control.
posted by bruceyeah at 3:00 AM on April 3, 2006

Well, you could still ask Apple for a volume control on the digital out. It CAN be done. But there's obviously a reason they did it this way.

If you play back the music with iTunes, try turning down the volume on your stereo and then dropping the volume on iTunes. You'll probably have to stop, lower the volume, and hit start again. The hiss you should hear is the sound of the actual compressed bitstream, which I find interesting. (play it very quietly, as it can damage your speakers.) Once the hiss is playing, you should be able to drag the volume slider up and hear it transform into classical music again.

Overall, it's good that this plays... it means Apple's doing a good job as a digital source. Your lack of volume control isn't a bug... it'a a feature! :)

FWIW, this is hard to do with Windows, and flat-out impossible with most PC soundcards. It takes real effort to get lossless audio under Windows. Lots of PC sound geeks would be jealous if they knew how easy it was for you. :)
posted by Malor at 12:46 PM on April 3, 2006

« Older Yellow scale in toilet pan   |   Blow Up Newer »
This thread is closed to new comments.