HDMI Why?! laptop to TV resolution problems
April 6, 2021 5:39 AM   Subscribe

I have a new laptop which can finally play newish games. I'd like to hook it up to my TV, but when I do (via HDMI) the display options (Windows 10) sees the TV screen (screen 2 in windows) as 800 x 600 and the resolution is terrible. The same happens whether I duplicate or extend screen, and when it is connected, the option to change the display resolution is greyed out for screen 2 (my TV). Any ideas?

I have used 2 HDMI cables and both work with my old work laptop, and with XBOX 360, PS 4 and switch. All display well on the TV using either HDMI in socket. I don't need 4k quality (which TV wouldn't support anyway).

The TV is an off-brand one (Luxor) and otherwise working well - it's not high-definition but it is flat screen. There don't appear to be any options on the TV menu to change resolution - only screen ratio and colour/brightness. As above, it works fine with HDMI input from a variety of other devices and chromecast.

My new laptop is an ASUS ROG Zephyrus G Series 14 (link to costco.co.uk where I bought it). It works via HDMI when hooked up to a Dell monitor which is newer than my TV. I have updated both display adaptors (AMD Radeon and NVIDIA GTX 1650 Ti) and tried a couple of the solutions suggested from google searches - but when the laptop is connected to the TV all the display options in Windows are greyed out. I also cannot change the frequency - it stays at 60Hz.

I really wanted to be able to play some of my shiny new games on the big screen. Any ideas very much appreciated.
posted by sedimentary_deer to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
What model luxor is it? It will be useful to look it up to determine what resolutions it actually supports.
posted by TheAdamist at 5:52 AM on April 6 [1 favorite]


Response by poster: Ah, good point. It's a LUX-40-914-TVB 40″ Full HD 1080p Freeview LCD TV

This is the one: link - bought in 2011

I can't find a manual for it or further specs...
posted by sedimentary_deer at 6:02 AM on April 6


Sometimes, the input type setting on the TV can make a difference. Is there a game mode, or a way to say the HdMI setting is a "game mode" or "computer passthrough" or anything like that?
posted by bbqturtle at 6:41 AM on April 6


Response by poster: Thanks - I tried 'game' mode on the TV but I think that just adjusts the brightness/black levels. Nothing I can find on the TV which affects HDMI and it works with other devices, so my feeling is that it is related to the laptop?

Will stop threadsitting now!
posted by sedimentary_deer at 7:06 AM on April 6


I don't have an NVIDIA card, but there's a chance this TV isn't reporting display information correctly to your video card. There may be an option to override this in the NVIDIA control panel (not the Windows display options page), assuming you know what your TV supports.
posted by dobi at 7:18 AM on April 6


Yeah, like dobi says, it sounds like the computer is unable to determine the TV's capabilities and so is defaulting to fallback resolutions. With the TV connected, either in the Nvidia control panel or in the WIndows control panel, find the properties for that second display and see if you can change it to 1920x1080.
posted by xedrik at 7:28 AM on April 6


Interesting. Given that HDMI is supposed to be fully backward compatible, the problem seems to be more likely to be on the PC end than the TV end.
posted by kschang at 8:31 AM on April 6


If you close the laptop, does that fix the greyed out status of the display option on the tv? On some Chromebooks, you can't change the external monitor settings until the cover is closed, so you need an external mouse. You can open the laptop again after you get the display set the way you want it.
posted by soelo at 10:16 AM on April 6


Response by poster: Much appreciated all. Unfortunately, none of the above suggestions have worked. Whether connected to the TV or not, the only options I have through NVIDA control panel are 3D settings. Googling suggests disabling the native graphics, but that results in no signal to the TV at all. Windows display options greyed out for all.

Trying with the lid closed doesn't seem to work either.

I think the suggestion that the laptop automatically detects the TV as lowest res may be correct, but I'm still not finding any solutions. Any other ideas very much appreciated - this is so frustrating given everything else seems to connect fine!
posted by sedimentary_deer at 10:52 AM on April 6


I think this is a driver problem. You might be able to get drivers from this download site. All caveats apply as I have no way to test it.

Once you have drivers, go into your Device Manager > Monitors and see if there is an entry for an 'Unknown Monitor' or 'Generic' or something like that, update the drivers on that entry with the ones you downloaded.
posted by banshee at 11:44 AM on April 6


Response by poster: Thanks banshee. Unfortunately, there are no downloads available on the page you linked. Have searched elsewhere also to no avail... Thanks all for the suggestions so far.

Monitors in device manager show up as "Generic PnP monitor" and "Generic non-PnP monitor". updating, disabling, reinstalling those makes no difference.
posted by sedimentary_deer at 1:39 AM on April 7


If you haven't given up yet, you can try using one of the windows standard drivers.

- In Device Manager, right-click the Generic Monitor entry, select Update Driver
- Choose 'Browse my computer...'
- Choose 'Let me pick from a list...'
- Uncheck the 'Show compatible hardware' box
- Select 'Standard Monitor Types' on the left
- On the right, scroll down to find the 'Digital Flat Panel (1920X1080 60Hz)'
- Proceed with driver install
posted by banshee at 8:58 AM on April 7


« Older Let's see some tracker apps!   |   Taught not Learned: Correcting Someone Else's Word... Newer »

You are not logged in, either login or create an account to post comments