Wireless Mac ADSL hell
March 18, 2006 1:23 PM   Subscribe

Setting up a Mac wirelessly on ADSL. Help!

I have just got ADSL broadband installed at my new house. The problem is I cannot connect to the net wirelessly. Its fine when the ethernet cable is connected but otherwise wont connect. What am I doing wrong?


A few things. I am in the UK and the DSL is through BT. I have an imac G5 running OSX. The router is a BT Voyager 2500. As I said above, I can connect with an ethernet connection direct from the router and surf the net etc. but when I try to use it wirelessly it wont connect. It shows in the top right hand corner of the screen that I have Airport access to the network (I.e. it isnt greyed out) and it is obviously picking up the signal from the router but it wont translate this to web-browsing. Any ideas?

I previously used a Belkin wireless router with Cable broadband and it worked fine. This is so annoying.

Thanks
posted by ClanvidHorse to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
Go to Network Preferences > AirPort and make sure "Use DHCP" is turned on. Also, check the Network Status section and see what it says about your connection.
posted by cillit bang at 1:34 PM on March 18, 2006


tried as above. It is set to Use DHCP. connection ostensibly appears to be ok. it still wont work though.
posted by ClanvidHorse at 1:53 PM on March 18, 2006


My guess is that your router's misconfigured, or it's using some kind of wireless security that your iMac hasn't been configured to recognize. Can you access it to configure it?
posted by ikkyu2 at 1:57 PM on March 18, 2006


Try loading this address (it's Google):

http://64.233.187.99/

If it works, you need to copy your DNS info from your ethernet settings to the wireless settings in your Network Preferences.
posted by scottreynen at 2:01 PM on March 18, 2006


i can access configuration through a desktop launched router manager. anything i should pay particular attention to?
posted by ClanvidHorse at 2:04 PM on March 18, 2006


i tried IP Address as above. it just timed out.
posted by ClanvidHorse at 2:06 PM on March 18, 2006


Well, look at the router's security settings. Is it using WAP, WPA, or other kinds of wireless security?

These sorts of security are password based, so if the router uses one of them, you'll have to change the password on the router and then put the type of wireless security and its password into your Airport settings.

Look at every pane of the router's settings, and turn off anything that you don't know what it is. Failing that, call your ISP's tech support line.
posted by ikkyu2 at 2:13 PM on March 18, 2006


log into your router with your desktop. you should be able to find a list of connected computers. one of them should be your mac. if not, the wireless connection is not really being made.

one other thing to check is to go to your network preferences and go to "network port configurations". drag airport to the top of the list; that way it'll try to make a network connection via the airport first.

if it IS there, make sure it's getting an IP address. (go to your network preferences -> TCP/IP pane and see what your IP address is. should be something like xxx.xxx.xxx.2 . compare this to your desktop, which should be getting something like xxx.xxx.xxx.1 . make sure they jive)

if all this stuff checks out, try going to your utilities folder and open up Network Diagnostics. do a traceroute to that google address and see how many hops it makes. could tell you where your packets are dying.

gluck!
posted by sergeant sandwich at 3:56 PM on March 18, 2006


Agreeing with above: it's probably a WEP issue. A common problem is that a machine will list as 'connected' even when it can't transfer data. This is because it is talking to the router, it's just not giving it the password it needs to actually make use of the connection.

One thing i would suggest is try turning all forms of security off. See if you can connect, assuming that works, work backwards and apply the WEP and whatever else you want to make yourself feel secure.

[disclaimer, i provide support for wireless networking with cable modems. WEP being misconfigured accounts for about 95% of the calls i take.]
posted by quin at 3:57 PM on March 18, 2006


i agree with everything sergeant sandwich said except for this 'xxx.xxx.xxx.1'. In my experience the router will almost always claim x.x.x.1 as it's own IP address and start assigning DHCP IP addys after that.

One thing to look for: if your IP address is 169.254.x.x it means your machine is not getting a real IP and it's providing you with a placeholder. A real IP from your router will probably be 192.168.0.x or 192.168.1.x. Though i have dealt with some routers that assign 10.x.x.x.
posted by quin at 4:02 PM on March 18, 2006


What quin said is worth re-reading.

Go to network prefs.

Your IP addresss should be a 192.168.x.x number (or a 10.1.1.x number)...

but absolute not a self generated/referencing IP of 169.254.x.x

If you get that, it means that your router isn't handing out an IP address (or not fast enough.)

Now, let's say you're DHCP and a 192.168.x.x or a 10.1.1.x number.

network prefs will have under the TCP/IP settings the number of the router. Type this into your address bar of safari and you should be able to login to the router, just as if you were hard wired.

If not, something else is wrong.
If so, there's likely a DNS or a MAC addressing problem.
posted by filmgeek at 5:06 PM on March 18, 2006


Bt is perhaps just providing you with a fairly badly configured router. (not uncommon for ISP's) My take would be to add your old Belkin to the router again using the ethernet cable and just use that (or get an Airport express for that purpose)
posted by KimG at 4:51 PM on March 19, 2006


« Older Where's my mail?   |   Bands Oasis has hyped or dissed? Newer »
This thread is closed to new comments.