iTunes file dupes and bad tag reads.
March 18, 2006 5:36 AM   Subscribe

iTunes is creating duplicate copies of everything - and isn't faring too well with the id3 tags, either.

I apologize in advance for yet another iTunes (PC) question.

I have my Windows iTunes (v6.0.1.3) set up to auto-organize my music into the standard iTunes folder configuration [iTunes Music > Artist > Album > Songs]. However, there seem to be a few bugs that I can't quite work out.

1. When using the "Add Folder to Library" function or when dragging files into iTunes, it creates TWO copies of each album in the iTunes directory. I then have to manually select one set and delete them. It isn't simply adding the files from the source directory as well - it's actually just double-importing them into the iTunes folders. (For what it's worth, it doesn't have this problem when I add music with the Add File(s) To Library function.)

2. Once imported, when I look in the Name (song title) field, it will list both "Artist - Song Title"instead of just "Song Title." The only way I can get it to list just the song title is by actually cueing up each song one by one, as if previewing every song in a given directory/album. I can't seem to find a universal command which will fix them in bulk when this happens.

For what it's worth, 95% of the albums in question were originally ripped in iTunes, so it's not like it has to figure out another program's id3-tags; I'm just reorganizing my file structure, and this is adding twice the necessary work.

Any thoughts? I could just tell iTunes to search for duplicates and nuke them all later on, but it seems like there should be a way to do this right the first time.
posted by mykescipark to Computers & Internet (4 answers total)
 
Try this and see if it helps: select Edit from the iTunes menu. Click the Advanced tab and deselect the option "Copy Files to iTunes Music Library When Adding to Library".

(If you have many music files on your computer that you want to organize into the iTunes folder, use the option "consolidate library" from the Advanced menu, instead of importing each file manually.)
posted by iviken at 8:28 AM on March 18, 2006


Try this and see if it helps: select Edit from the iTunes menu. Click the Advanced tab and deselect the option "Copy Files to iTunes Music Library When Adding to Library".

Right. Well, I want it to do that. I like the auto-organization that this provides.

I think my question is easily misinterpreted. It is not that iTunes is simply adding both my original source files and the new copies into the iTunes listing.

It is creating TWO ENTIRELY NEW copies of the source files in iTunes, instead of just one. Imagine a Xerox machine that makes two copies for every one copy you ask for.

Hence, I am ending up with three copies of each album total.

(I'm not actually manually consolidating a pre-existing library, I'm incrementally adding new material from third-party sources each day.)
posted by mykescipark at 8:49 AM on March 18, 2006


I problem that I've been having adding songs to iTunes is if there is a .m3u playlist in the folder that I'm adding. iTunes then adds all the files directly, and then the playlist... that means duplicate copies of all the songs.

It's sure annoying...
posted by BlzOfGlry at 9:14 AM on March 18, 2006


Yeah. I'm not using any playlists, alas, just the "raw" files.
posted by mykescipark at 9:44 AM on March 18, 2006


« Older Splitting hairs   |   What did I just do in OpenOffice!? Newer »
This thread is closed to new comments.