Windows using a Mac Printer
March 16, 2006 10:43 PM   Subscribe

I have a printer on my MacMini and I want to be able to use it for print requests from my Windows XP laptop. I was able to get it working using CUPS and the MacMini's IP address, but the problem is that since the Mac is on a DHCP wireless network, the IP address can (and has) changed. Now printing from the laptop won't work. How do I identify the Mac from the laptop without using an IP address?

I installed the CUPS drivers on my MacMini to get the XP laptop to be able to use the Mac's printer (Instructions can be found here).

On the laptop, I was able to connect to the printer using the Mac's IP address.

But now, the Mac's IP address has changed (the Mac is on the same wireless network as the laptop. I have a Linksys wireless router).

In order for the laptop to find the Mac regardless of its IP address, the Mac has to have a name that is resolved to the Mac's current IP address.

Things I have done so far on the Mac based on some web searching:
- Under Preferences/Sharing the computer name is "MacMini"
- Under Preferences/Network/TCPIP DHCP is selected and the DHCP client name is "MacMini"
- In /etc/hostconfig I have "HOSTNAME=MacMini"

The laptop hasn't been able to find the Mac with the name "MacMini" or "MacMini.local". The name doesn't resolve on the laptop.

Now on the Mac, the laptop's name doesn't resolve either, but the Mac is able to find the laptop by its name on the network in the Finder and I've been able to mount shared folders from the laptop to the Mac.

What do I need to do to be able to use the Mac printer from the laptop, regardless of the Mac's assigned IP address?

Thanks.
posted by ShooBoo to Computers & Internet (8 answers total)
 
Don't know if this will help, but there is a Bonjour for Windows that may allow your printer to be seen by your PC. I've used it on a Mac network with a PC added and it worked fine. This was using an Airport with a USB Printer port, however. Should be similar on the Mini.
posted by qwip at 11:46 PM on March 16, 2006


This is much simpler than all that, just configure your mac as if it's on a static network, tell it to use an ip that's higher than anything that dhcp could inadvertantly assign to something else on your network if the mac were to drop offline temporarily.

So, if you have typically 4 machines on your network, I'd tell the mac to use *.*.*.105

DHCP has no problem with giving computers requested addresses.
posted by Matt Oneiros at 11:57 PM on March 16, 2006


Oneiros is onto something, but there's one problem with it - that address might already be taken by another computer.

The real way to solve this problem is to go into your router's configuration and set up a "static DHCP" address tied to the MAC address of your .. well .. your Mac.

Basically, your Mac network interface should have a hexadecimal address formatted like:

08:00:69:02:01:FC

You just need to set up your router to bind the mac address of your macmini's interface to a single ip address (i.e. 192.168.1.101) - then your macmini can be configured to use regular DHCP, and your router will never hand out 192.168.1.101.

Note: Replace 192.168.1 with whatever the beginning of your LAN IP address is - could be 192.168.0, etc...
posted by twiggy at 12:12 AM on March 17, 2006


The problem with changing away from DHCP is that it becomes a pain in the butt to roam networks. If your DHCP server has the ability to set reservations, that would be one way to solve it. (A reservation means, "give the machine with this MAC address the same IP every time.") Most of the simpler DHCP solutions can't do that, though.

The more complex way to do this is to connect via Samba sharing. The Mac's GUI doesn't seem to have a method to join workgroups, so I do it manually.

First, go into Sharing and turn on Windows Sharing and Printer Sharing. Make sure those services are allowed through the firewall. (the second tab).

Next, find your /etc/smb.conf file. Make a copy of it. It may a link to /private/etc/smb.conf. That's how it once was on my computer. It isn't now, but I might have screwed something up. (oops!). If it's a link, go to the target file and copy THAT instead... copying a link won't preserve anything.

After making a copy and saving it with a name you'll remember, open the file in Text Editor. Look for a line that says:

workgroup = something

Change the something to be the same as your workgroup setting on the XP machine.

Then make sure you have these lines... I think turning on printer sharing will have added them automatically:

[printers]
path = /tmp
printable = yes


That should allow you to see and connect to the printer from Windows using Windows-style network browsing. You can attach to/share the Mac printers just like they were on a Windows machine. Because you're attaching by name, if the Mac moves IPs, it shouldn't break.

You'll have to install drivers locally, but that's usually pretty easy.

I don't know if this is the _right_ way to do this, but it works well for me.
posted by Malor at 12:12 AM on March 17, 2006


Oh.... after changing the workgroup line, go back into Sharing and turn off and turn back on Windows and Printer sharing. That should restart Samba so it reloads the configuration quickly.
posted by Malor at 12:14 AM on March 17, 2006


It sounds like you are overcomplicating this. Have you tried simply sharing the printer in OS X (use the 'sharing' tab) on the Printers & Faxes preference pane, then downloading the Bonjour/Rendezvous client for Windows? This should then see the printer on the local network wherever it is, and allow you to print. It may also allow you to address it as MacMini.local.

Bonjour for Windows
posted by unSane at 5:11 AM on March 17, 2006


Bonjour for Windows is the best suggestion. It works like cake (assuming you use Windows XP).
posted by Mo Nickels at 10:34 AM on March 17, 2006


Yeah, Bonjour for Windows!
posted by qwip at 9:40 PM on March 17, 2006


« Older When is it time to call the exterminator?   |   Looking for coffee shops in the greater los... Newer »
This thread is closed to new comments.