How do I reset the settings on Terminal for OS X?
March 15, 2006 3:05 AM   Subscribe

I've managed to screw up Terminal on OS X. I chose File | New Command and checked Run command inside a shell, then with the window active I went to Terminal | Window Settings... and then clicked on Use Settings as Defaults. Ever since then, a File | New Shell will just open a window running the same command as the one that I did the Use Settings as Defaults on. How can I fix this and reset Terminal's configuration? I'm using OS X 10.4.5 on an Intel Mac mini, if it makes a difference.
posted by EatenByAGrue to Computers & Internet (6 answers total)
Response by poster: I would prefer a solution that can be accomplished through the OS X interface, but if you can tell me where Terminal stores its configuration files, that'd be useful as well. As long as they're stored as text, I can make whatever edits are necessary if that's what's required.
posted by EatenByAGrue at 3:16 AM on March 15, 2006

Best answer: Look in your Home folder -> Library -> Preferences, and delete the file:

Next time you run Terminal, it will create the default preferences again.
posted by gaby at 3:21 AM on March 15, 2006

I suspect you'll be able to fix this if you open a Terminal, go to Terminal -> Preferences and make sure the top radio button is selected ("Execute the default login shell[...]").

Then go back to Terminal -> Window Settings and click on "Use Settings as Defaults" again.
posted by Olli at 7:09 AM on March 15, 2006 [1 favorite]

Response by poster: Olli, I tried that and it didn't work. All that does is run the command script in the default shell.
posted by EatenByAGrue at 9:30 AM on March 15, 2006

Response by poster: gaby, that worked! Thanks.
posted by EatenByAGrue at 9:32 AM on March 15, 2006

Thanks for asking this! I've run into this problem multiple times on different OS X installs and never got around to fixing it, because I normally use iTerm. Now that I've gotten hooked on GNU Screen, iTerm's tabs seem unnecessary, given it's occasionally buggy behavior.

What would usually happen to me is that after using the GNU debugger in Xcode, would try to run gdb on a non-existent process, and be very annoying. Now it is gone!
posted by blasdelf at 10:03 PM on March 16, 2006

« Older I need help keeping my transdermal patch from...   |   Why can't I find a job in LA? Newer »
This thread is closed to new comments.