Broken Audio in Flash Movies
March 12, 2006 2:33 PM   Subscribe

Help me un-break Flash movie browser audio under OSX.

OSX 10.4.5. Latest Safari and Firefox. MOVs play audio, WMVs play audio, AVIs play audio. Every other program I have plays audio. Open a flash movie in either Safari or Firefox - no audio. This really sucks because 99% of internet videos nowadays seem to be on youtube or google video.

Already tried uninstalling/reinstalling Flash Player, to no effect.

It's a fairly new system so I'm not sure if it ever has worked. I think it did. I don't know what I did to mess it up that uninstalling and reinstalling wouldn't fix.
posted by nathancaswell to Computers & Internet (10 answers total)
Wow, so I'm not the only one with that problem.

* It's only affecting my PowerBook.
* Updating Flash didn't help.
* It's not flip4mac.
* It's not 10.4.5

(I have several Macs in my cube, and only the PowerBook is having the problem.)

* It's affecting both Safari and Firefox.
* I have not tried repairing permissions, but I'm going to do that right now and report back.
posted by drstein at 4:05 PM on March 12, 2006

Response by poster: I suspected Flip4Mac too, but it isn't it! Let me know if you have any luck...
posted by nathancaswell at 4:09 PM on March 12, 2006

Best answer: I've seen people in several Mac forums recommend starting up Garage Band and then quitting it, to solve the no flash audio problem. Worked for me.
posted by jaimev at 4:11 PM on March 12, 2006

* Repairing permissions did not resolve it.
* I logged in as a new user and tried both and and the problem persists.

Ugh. The problem is that it's quite difficult to successfully recreate. Like I said, I couldn't do it on the Macs in my cube, and my Mac Mini at home doesn't exhibit this behavior.

I can grab a lab PowerBook at work and see what happens.

Oh, dude, what kind of hardware are you having this problem on? :)
posted by drstein at 4:14 PM on March 12, 2006

Response by poster: Good god, that fixed it.
posted by nathancaswell at 4:14 PM on March 12, 2006

You're fucking kidding me. Starting up GarageBand?!

Well, the affected PowerBook is sitting right here with me.

Oh. My. God.

That worked. What the hell? WHY did that work? WHY GOD WHY?!

That is the LAST THING that I ever would have thought of.

I guess those virgins I sacrificed are gonna be really pissed off. ;)
posted by drstein at 4:18 PM on March 12, 2006

Response by poster: It was happening on my Quad-core G5 2.5 GHz. But jamiev's Garageband solution worked for me... I'm off to catch up on my internet phenomenomitry.

PS - I surrender to the hive.
posted by nathancaswell at 4:19 PM on March 12, 2006

Previously on Ask MeFi, but not explained in any reasonable way.

Have you launched Audacity? It has a habit of setting your audio output settings to the highest supported rate without realizing that some hardware can't actually play audio at that rate.

For the actual explanation, see this page from Ambrosia Software and this knowledgebase article. The fix is in Audio MIDI Setup; it just so happens that GarageBand resets the settings to what your hardware actually supports.

If this is in fact the problem, you can leave Audio MIDI Setup open and actually see Audacity muck up the settings and GarageBand put them back.
posted by mdeatherage at 4:41 PM on March 12, 2006

This loss of audio has been reported to affect several embedded media players in Safari, including Flash and Real Player. It is my understanding that it can be triggered by upgrading to 10.4.5.

The actually problem is that the Audio Output format setting gets set to a value that Flash or Real Player do not support (usually 96000 Hz). When launched, GarageBand changes this value to a value it supports, usually 44100 Hz (the sampling rate adopted for CDs).

If you find the idea of fixing this problem by launching GarageBand too weird, it can also be fixed with Apple's application called Audio MIDI Setup (probably found in your Utilities folder). Launch Audio MIDI and change the Audio Output Format pop-up menu (in the lower right) to a reasonable value, I suggest 48000 Hz.
posted by RichardP at 4:50 PM on March 12, 2006

Clearly I shouldn't have answered a phone call, and then posted with previewing again. Sorry mdeatherage.
posted by RichardP at 4:51 PM on March 12, 2006

« Older How to keep the peace with sex-fiends?   |   How to access locked files via target mode. Newer »
This thread is closed to new comments.