Tell iTunes to choose folder on external drive for iTunes library
December 26, 2019 3:49 PM   Subscribe

I have a newish Macbook Pro (2016), but am only just now trying to direct iTunes to my iTunes library that lives on an external drive that I backed up from my old laptop. I want to use that location as my default iTunes library instead of putting it all on my laptop (not enough room anyway), but none of the procedures for pointing iTunes at an external drive is working. Help! (Running Mojave 10.14.6)
posted by tzikeh to Computers & Internet (4 answers total) 3 users marked this as a favorite
 
To be clear: you've tried holding the option key as you launch iTunes to pick the active iTunes library?
posted by mce at 4:21 PM on December 26, 2019 [1 favorite]


Yes.
posted by tzikeh at 7:01 PM on December 26, 2019


Ah ok so it’s tech support territory. I can imagine you’re frustrated. A couple “did you try turning it off and on again” questions:
  • do you get any error messages?
  • does iTunes start with an empty library?
  • do you get the option to choose a library or does that dialog fail to appear?
  • do you know what version of iTunes was used to create the library? Does it match what’s on the “new” laptop?
  • do you have access to another Mac to try the external drive with?
  • can you create a new user and try the iTunes library with that?

posted by mce at 10:53 AM on December 27, 2019


There's metadata about (among other things) what music files are located where which is not stored in the Media Folder you set in preferences, but in your home directory, which is why this type of thing doesn't work the way you'd expect. Also most guides you'll find will assume you're moving from an internal extant/populated library to an external drive which is not what you're doing so most guides are going to give you bad advice for your situation.

My recommendation would be to do the following. Note this will not retain your playlists or other organizational metadata but instead add all the files to a fresh library without moving them from the external drive.

You should also know before doing this that iTunes is extremely bratty about finding its files when you open it. This is why I used to really push people toward just sticking a bigger drive inside their computer rather than what you're trying to do. If you open iTunes without that external drive attached it might do something irritating that is a hassle to revert. Try not to do this. Also always back up everything before doing anything on a computer ever. Then:

- Starting with iTunes open to the empty library
- iTunes Preferences > Advanced > iTunes Media folder location > Change
- Select the directory on the external drive that has the media you want. Importantly this isn't the "iTunes" folder that includes the XML/ITDB/ITL files etc but one inside of that folder that's reserved for the audio (/video) files themselves. On my old machine it's at /Users/{name}/Music/iTunes/iTunes Media/ but that can vary depending on iTunes version / previous versions/organization settings/etc (it might be "iTunes Music" or similar too)
- You'll probably also want to disable "Copy files to iTunes Music folder when adding to library" here before the next step, in case the iTunes versions mismatch and organize the folder hierarchies differently, or you accidentally choose the wrong folder, so you don't end up duplicating every single file
- Close the Preferences and go to File > Add to Library (or "Add Folder to Library" depending on iTunes version)
- Select the directory on the external drive that has the media you want. Same one you picked before.
- iTunes should comb through the folder and populate the library. Depending on the drive and interface and library size this might take a while
- Assuming you plan on adding more music to iTunes in the future, you'll now want to re-enable "Copy files to iTunes Music folder when adding to library"
posted by churl at 4:30 PM on December 27, 2019


« Older Can you explain these random shopping sites?   |   Making lasagna for the first time, looking for a... Newer »

You are not logged in, either login or create an account to post comments