Messages and iCloud in iOS 13.x
December 2, 2019 1:18 PM   Subscribe

Messages has stopped working the way that I want it to in iOS 13. How can I make it work the way I want it to?

In iOS 13 (or maybe earlier, I do not know) in order to allow all one's Apple ID devices to act as messaging platforms for one's Apple ID, one must activate iCloud for Messages. This causes Messages to instantiate a universal iCloud backup of all the Message stores on all the devices. I have no desire for this backup to exist, because I have no desire to fill up my iCloud account. I do keep a from-day-zero archive of my Messages on my iPhone. I very much wish to be able to use any arbitrary Apple ID associated device to generate and reply to Messages.

In what I take to be a related issue, as my iCloud account does not have sufficient storage space available to keep the entire Message archive, Messages is no longer reliably acting as a Message relay system, which is most irritating.

How can I accomplish my desired use case, more clearly enumerated below?

What I want:
No iCloud backup or device syncing of that backup for Messages
Each Apple ID associated device can receive and send Messages via my primary cell or directly as the case is appropriate

(a footnote: I last asked about Apple device limits here with regard to the newly-enforced non-iOS Apple ID sign-in limits. I have and use six discrete non-iOS Apple computing devices, two of which have four to five separate boot drives - and yes, each bootable drive is seen under the new device limitation policy as a separate device. I am pretty sure that this current iCloud policy with regard to Messages is another annoying encumbrance that I cannot resolve to my satisfaction, but felt I should look into it here.)
posted by mwhybark to Technology (3 answers total) 1 user marked this as a favorite
 
I can use Messages from either my phone or laptop but without using iCloud storage. Looking at my phone settings (under the Settings app/my name [account]/iCloud/Manage Storage), it's set with Messages turned off. Elsewhere in phone settings, Messages is set to use iMessage. Try those settings maybe?
posted by exogenous at 2:14 PM on December 2


Can confirm exogenous's comment - my iPhone (13.2.3) has literally everything turned off in iCloud settings; my laptop only has "Find My …" turned on; the desktop has nothing (though it's still on 10.14.something), and iMessage/Messages still work across all 3.
posted by Pinback at 3:43 PM on December 2


Yup. I've never activated iCloud and happily sync Messages between my iPad and iMac.
posted by Thorzdad at 4:09 PM on December 2


« Older Can you identify this resistor?   |   Where to go after the death of PS Vue? Newer »

You are not logged in, either login or create an account to post comments