I guess it just doesn't like to share.
September 6, 2019 3:46 AM   Subscribe

Why does my computer keep getting kicked off the wifi whenever another device starts using it?

I have noticed that my work computer (which, if it is relevant, has some software that allows it to connect to our internal networks when I am working remotely) seems to have its connection die whenever anyone else uses the same wifi connection. Initially I thought it was just a terrible router.

However, It soon became clear that the internet died e.g. when I would pick up my phone to do something, or if my wife or someone else started working as well. It took a while to connect the dots, but it seems pretty consistent that my connection dies essentially right when a new person connects.

What is going on here, and how can we fix it? For what it's worth, it only seems to affect my work computer, and not any other devices.

The make of the router is ZyXEL P-2601HN-F1.
posted by vernondalhart to Computers & Internet (15 answers total) 2 users marked this as a favorite
 
Is your computer mac or PC?

I'm no expert, but this could be a problem with your computer drivers. I would update those before you mess around with your router.

In Windows you can change a lot of detailed options for wifi drivers (search for device manager and your wifi then advanced) . Have a look and see what band is being prioritised (2.4 or 5). Have a look at 'roaming aggressiveness'. Changing these could help.
posted by 0bvious at 5:41 AM on September 6, 2019


Sounds like an IP address conflict. The router is assigning the same IP address as the work computer to whatever new device connects to the network. You may be able to verify this by going into your router settings and looking at the list of connected devices, if it has one. And you can fix it by giving your work computer a static IP address that’s out of the range of addresses that are dynamically assigned to new connections.
posted by rodlymight at 6:02 AM on September 6, 2019 [15 favorites]


The work computer is a PC, the rest of the devices around here are all mac/ios ones.
posted by vernondalhart at 6:17 AM on September 6, 2019


ftp://ftp.us.zyxel.com/P-2601HN-F1/user_guide/P-2601HN-F1_3.10_ed1.pdf

You want section 7.2 and/or 7.3
The example in 7.2 shows that the Dynamic Host Configuration Protocol (DHCP) range starts at 192.168.1.33 and is 32 addresses long. So 193.168.1.33 - 192.168.1.65 is the DHCP pool that gets managed by the router and handed out to devices that ask for an IP address.
It also shows that the IP address of the router/gateway itself is 192.168.1.1 (quite common).
And your subnet mask is 255.255.255.0 (also quite common).

Assuming your PC is a desktop type of thing that isn't portable...

Change your network config to be Manual/Static (instead of Automatic or DHCP) and pick something like:

IP: 192.168.1.10
Mask: 255.255.255.0
Gateway: 192.168.1.1

I does sound like IP conflict.

don't get me started on how awful Windows TCP stack used to be when it comes to DHCP. I thought they got a lot better over the years.

Set your PC to a static address.
posted by zengargoyle at 7:29 AM on September 6, 2019 [2 favorites]


Oh, section 7.3 is an alternative, or if your PC is a laptop and mobile. Here's where you lookup your PC's MAC address and tell the router's DHCP server to *always* give your machine the same address. You'd also probably tell it something like 192.168.1.10.

This allows you to leave your (laptop) PC configured to Automatic / DHCP and still always get the same address. Unless the router is really stupid. :) Going this way would let a laptop easily work out in the world without having two network profiles (one for the home-static and one for the DHCP) that you'd have to switch between depending on what you wanted.
posted by zengargoyle at 7:34 AM on September 6, 2019


Oh, and unless you've picked a different DNS server, set the DNS server to the IP in the DNS section. Again 192.168.1.1 is a pretty good bet.
posted by zengargoyle at 7:43 AM on September 6, 2019


Here's where you lookup your PC's MAC address and tell the router's DHCP server to *always* give your machine the same address.

Some years ago I started preferring this approach over static IP address assignment, and so far I've never found a good reason to change back.

The main advantage is that on connection, as well as the static IP address that's configured to match their MAC address, client machines also get all those other useful things that can be set up via DHCP - like DNS server addresses and NTP server addresses - and that all of those settings will update properly even for the fixed-address machines when I change them in the router.

You might find that you get better results from fixing the IP address for the interfering phone rather than the PC. Windows 10 has a MAC address randomization feature for Wifi adapters that's on by default, so unless you make sure that's been turned off, no IP address you fix for the PC in your DHCP server will stick. And if this is indeed an IP address conflict issue (which I agree it probably is, per your description) it's far more likely to be a mobile device's fault than a PC's. There are all kinds of horrible IP address assignment bogosity in the Android networking stack; it's several times worse than the already awful Windows one.

You might also consider increasing the size of your router's DHCP address pool. There is no earthly reason why it needs to be as small as 32 addresses; that's a very easy pool to use up as mobile devices come and go, especially in a business environment, and the consequence of using it up is that intermittently connected devices will end up with IP address conflicts. On IP subnets with a 255.255.255.0 mask, which yields 254 available IP host addresses from x.x.x.1 through x.x.x.254 inclusive, I will generally make DHCP give out addresses between x.x.x.50 and x.x.x.249 inclusive.
posted by flabdablet at 7:55 AM on September 6, 2019


you can fix it by giving your work computer a static IP address that’s out of the range of addresses that are dynamically assigned to new connections

If you're going to go the way of assigning fixed IP addresses to selected MAC addresses in your router's DHCP server, be aware that some routers will require you to assign IP addresses that do not fall within the range you've nominated as available for the DHCP address pool, much as you'd do for static IP addresses; other routers will require that all addresses ever handed out over DHCP fall within the pool regardless of whether they're fixed to specific MACs or not.

I like to start my fixed address assignments at the high end and work my way backward. So with my recommended DHCP address pool that runs from x.x.x.50 to x.x.x.249, the first fixed address I'd assign would be x.x.x.249; and if I'm working with one of the routers that requires fixed address mappings to go outside the normal pool, all I need to do to make this work is reduce the end of the pool by one.

This is generally less disruptive than starting the fixed addresses at the bottom of the pool range, because most routers will also start at the bottom of the range when looking for a free address to hand out, which means that dynamic addresses tend to cluster there; starting at the bottom makes it fairly likely that any IP address I'd like to use for a fixed one will already be in active use while I'm fiddling with the router. And the aim here is to fix the problem you're describing, not give it more opportunities to arise.
posted by flabdablet at 8:08 AM on September 6, 2019


Wow, random MAC is horrible. Random IPv6 is fine. Unless there's a protocol to determine if generated random MAC is unique on the M layer that's a whole can of "just randomly doesn't work for no reason" sort of thing. It also breaks MAC authentication and filtering. Sigh.
posted by zengargoyle at 8:11 AM on September 6, 2019


Unless there's a protocol to determine if generated random MAC is unique on the M layer

Fairly safe bet that some MS engineer has just looked at this and worked out that MAC addresses are 48 bits, birthday paradox means chance of a random conflict is 1 in 2(48/2) = sixteen million, so meh. Customer support can deal with it by telling people to turn it off and on again.

breaks MAC authentication and filtering

which nobody with a clue would ever rely on anyway, given how easy MACs have always been to spoof; but yes, automatically randomizing the bloody thing does take that to a whole new level of broken that turning it on by default just doubles down on.

Sigh.

Quite.
posted by flabdablet at 8:18 AM on September 6, 2019


I fear we're heading off into the wild. OP has a home DSL modem. We probably don't need to overthink a plate of beans beyond "try the static, it'll probably work".
posted by zengargoyle at 8:19 AM on September 6, 2019 [1 favorite]


I fear we're heading off into the wild

I agree. Unfortunately, though, that's where networking issues kind of live :-)
posted by flabdablet at 8:24 AM on September 6, 2019


Your work pc may have a static IP or other custom settings; call them before changing it. Check the DNS setting, as well, it's often custom, and I don't know why it would create conflict, it sometimes does.
posted by theora55 at 9:12 AM on September 6, 2019


Another possibility is that the work PC's VPN has been set up in a way that makes its IP subnet address range overlap with your home router's, confusing the audience.

Using 192.168.1.x for a VPN is just asking for trouble, but I've seen IT departments ask for trouble.
posted by flabdablet at 9:42 AM on September 6, 2019 [3 favorites]


I remember when one of the teachers at my school brought down the whole network because they had set up their laptop as a static IP as the same as the server!

nthing it's an IP address issue. Might be the mac's fault.
posted by freethefeet at 6:30 PM on September 6, 2019


« Older Is there a way to clear all star ratings in...   |   Name that dystopian (?) novel! Newer »

You are not logged in, either login or create an account to post comments