File extension change broke my songs?
February 26, 2006 10:43 PM   Subscribe

Accidentally renamed music files won't play.

I got some music off of a friend's hard drive in .m4a format. Wanting the file names to match up with my preferred naming system, I used a program to rename them according to the song info, but accidentally changed all the extensions to .mp3. Realizing that that was the reason that they wouldn't play in iTunes, I renamed them back to .m4a, but now only some of them play. iTunes refuses to play the others, showing an empty info screen up at the top and no speaker icon next to the song. Are they salvageable or do I have to get them again?
posted by invitapriore to Computers & Internet (11 answers total)
 
Can you play them in winamp?
posted by borkingchikapa at 10:44 PM on February 26, 2006


Unfortunately, I don't have access to a PC. This is on a Mac.
posted by invitapriore at 11:06 PM on February 26, 2006


It sounds like iTunes simply can't find the files. Try opening them with QuickTime player - if it can play it, you just need to remove the listings from iTunes, and then add them back in so iTunes fixes its database.
posted by nathan_teske at 11:47 PM on February 26, 2006


Are you sure that you were ever able to play them on your computer? It could be that some of the files weren't m4a files, but were actually DRM'ed m4p files. It could be that your player isn't authorized to play the others. What happens when you try to play them? Does it give some sort of error message?

You can also try to rename them to have an mp4 extension and see if quicktime can play them then, that should let you know if there is any sort of DRM on them.
posted by freshgroundpepper at 12:18 AM on February 27, 2006


If you're not frightened of a command line, fire up Terminal and do this:

cd /where/the/files/are
file thefilename.m4a


file is a command that will inspect the contents of the file and tell you a bunch of stuff about it. If they're in a bunch of nested directories, you can do it like this:

find . -name '*.m4a' -exec file {} \;

which will recursively browse through directories and run file on every .m4a file it finds. If you don't know where the files are, they're probably somewhere under your home directory. So just run that last command (with find in it) in a fresh Terminal window, which will start out in your home directory by default. So fire up the Terminal and copy & paste that line into it.
posted by polyglot at 3:28 AM on February 27, 2006


There are several ways to help iTunes find/import/consolidate your files.

Try this first: drag and drop one of the "lost" .m4a files (or a folder with files, or even several folders) into the iTunes window and see what happens. If it plays, you probably don't have to change the files names again. Instead, choose "consolidate library" from the Advanced meny in iTunes, and wait until the process is finished.

By the way, I find it much easier to use metadata and let iTunes to the searching, instead of searching through folders and/or renaming files. Why not try it, you might like it :)
posted by iviken at 4:19 AM on February 27, 2006


I think freshgroundpepper is on the right lines: DRM-ed iTunes songs taken from a friend's computer won't play on yours. That's what DRM is all about.

*cough* Jhymn *cough*
posted by blag at 4:53 AM on February 27, 2006


If some of them were bought from the iTunes music store, changing the file extension would help: DRM'd iTMS files are .m4p, not .m4a.

If it's a DRM'd file and you change the extension back to m4p and try to play it, iTunes should (emphasis: should) ask you to identify yourself to play it.

Good luck!
posted by philulrich at 5:58 AM on February 27, 2006


I'll echo the iTunes Music Store thing -- if these are DRM'ed files, they won't play.

However, I would bet that you tried opening some in iTunes after changing the extension when they hadn't yet been opened on your computer. I've seen iTunes (and other apps) change the filetype in the resource fork of the file. What you're going to have to do is find a way to clear or change the resource fork so that iTunes knows it's actually a M4A file. Unfortunately, I'm at work so I can't check my Mac to let you know how...
posted by mikeh at 6:36 AM on February 27, 2006


Is it possible that you have the "Hide File Extensions for Known File Types" on? This is an option in Windows. If you did have it on, it's possible you renamed the file from it's original name, mysong.m4a to mysong.m4a.mp3 which would make the file unplayable. You'd need to go to an exploer window and click Tools/Folder Options/View and uncheck "Hide Extensions for known file types".
posted by KevinSkomsvold at 6:52 AM on February 27, 2006


mikeh, I'm betting that your answer is correct. I thought initially that they might be DRMed but I know from previous experience that iTunes usually tells you as such when you try to play other people's .m4p files. Opening it in quicktime yielded an error, saying that it didn't recognize the contents of the file.
posted by invitapriore at 12:13 PM on February 27, 2006


« Older Tijuana Upholstery Recommendations?   |   What are the neighbors doing? Newer »
This thread is closed to new comments.