How do I get Microsoft Office to believe that I'm using English?
May 10, 2019 2:02 PM   Subscribe

My computer was in French at one time. Now it's in English, but Microsoft Office products (Word, Excel) object to this, and keep setting my text as being in French. It's annoying, and I can't figure out how to get it to stop.

I'm running MacOS Mojave and using Microsoft Word/Excel 16.22. As I said, I once had my computer set to French, but now it's back in English, and I do the majority of my writing in English.

In Word, what often happens is that at the start of a new paragraph, auto-correct will start to highlight every word as incorrect. When I go to Tools > Language, I see that it has set the paragraph to French. I have repeatedly set English (US) to be the default language, I have not used any French words, and "detect language automatically" is unchecked.

In Excel, it is a bigger issue. Excel expects decimals to be in the 0,0 format, rather than the 0.0 format, which means anything entered in the 0.0 format is not recognized as a number. It also messes up dates, as it is anyone's guess whether it going to interpreting 8/11 as the 8th of November or the 11th of August. This doesn't seem to be dependent on the language the cells are set to. I can't find any settings to put it back.

Help! What do I do to make it so Office believe that I'm not a French person?!
posted by Kutsuwamushi to Computers & Internet (8 answers total)
 
I have an older version of Office (12.3.6) on my Mac, Office 2008, and the Mac is running Mohave.

In the Word menu bar, select Tools/Language..., and select English from the drop-down menu.

That's how it's supposed to work, anyway.

Same in Excel.

I'm not sure if doing this once will fix it entirely, or if you'll have to redo this for every new document. In a rational world (what's that?) it would be the former.
posted by qurlyjoe at 3:57 PM on May 10


I've already followed your suggestion and it doesn't work:
When I go to Tools > Language, I see that it has set the paragraph to French. I have repeatedly set English (US) to be the default language, I have not used any French words, and "detect language automatically" is unchecked.
This does not keep it from switching to French again, either in future documents or the same document.
posted by Kutsuwamushi at 4:01 PM on May 10


For Word, try changing the language in the Normal.dotm file, then saving it. Here are instructions for editing that file. This file contains the defaults for new Word docs, and the language set in there can override the language settings in macOS System Preferences.

I believe there’s a similar file for Excel, but I’m less familiar with the process there.
posted by Banknote of the year at 5:50 PM on May 10 [2 favorites]


I thought i already posted this but it isn't showing up. I found this answer:

Changes to default language settings are not retained in Word
Symptoms
When you set a language as the default input language in Microsoft Office Word, and you then restart Word, the changes are not retained.
Cause
This behavior can occur when you have more than one input language configured on the computer.

When you have more than one input language configured, the language that is used when you start Word is based on the default input language that is selected in the Text Services dialog box.
Workaround
To work around this behavior, use one of the following methods.

Method 1: Remove All Additional Keyboard Layouts
This behavior does not occur when only one keyboard layout is present. To remove all additional keyboard layouts, follow these steps:

Click Start, point to Settings, and then click Control Panel.
In Control Panel, double-click Keyboard.
In the Keyboard Properties dialog box, click the Input Locales tab, and then click Change.
In the Select one of the installed input languages to use when you start your computer list, select the language that you want.
In the Installed Services list, click the Keyboard of the input language that you want to remove, and then click Remove.
Repeat step 5 for all languages except for the one that you selected in step 4, and then click OK two times.
Method 2: Install the Default Input Language
To specify the default input language that is used when Word starts, follow these steps:

Click Start, point to Settings, and then click Control Panel.
In Control Panel, double-click Keyboard.
In the Keyboard Properties dialog box, click the Input Locales tab, and then click Change.
On the Settings tab, click Add.
In the Add Input language dialog box, in the Input Language list, select the language that you want, and then click OK.
In the Select one of the installed input languages to use when you start your computer list, select the language that you want, and then click OK two times.
posted by TestamentToGrace at 5:52 PM on May 10 [1 favorite]


TestamentToGrace, your answer was removed because it is for Windows, and I stated in my question that I am using a Mac.
posted by Kutsuwamushi at 6:11 PM on May 10


I just tried the suggestion to edit the Normal.dotm file, but it is already in English.
posted by Kutsuwamushi at 6:13 PM on May 10


Ahh ok but the same principal should work, just a different method to implement it is necessary on a different OS.
posted by TestamentToGrace at 6:29 PM on May 10


Do you know if your Mac is set for English as the priority language?

Stop/quit MS Office

Preferences > Language & Text make sure English is at the top of the list. If it isn't, click and drag English to the top of the list or delete French and/or other languages from the list.

Select Region: United States (or wherever you are that uses English).

Next, go to the Input Sources and make it US.

Now log out of the Mac and log back in. Fire up Office and see if it stuck.
posted by bz at 11:07 AM on May 11


« Older How to bake sculpey mixed with fimo?   |   A thing happened. I'm wallowing. Please help me... Newer »

You are not logged in, either login or create an account to post comments