Is there a way to filter email messages in Outlook based on two letters
January 11, 2019 7:00 PM   Subscribe

Is there a way to filter (also known as Outlook rules) email messages in Outlook based on two letters (between hyphens) in the subject line?

I’m working on a project where I need to review all reports relating to a certain subject; let’s call them “Cat Reports”.

The subject line is something like: Happy Critters Meadowbrook Project: New Report 1115-CR-BLAH is ready. The attachment is titled 1115-CR-BLAH. The number is unique to each report, so I cannot filter on numbers.

The “CR” is the only indicator in the subject line or the body of the email that the attachment is a Cat Report.

Unfortunately for me, we also get Bunny Reports, and there are a lot of them. The subject line for Bunny Reports is “Happy Critters Meadowbrook Project: New Report 1120-BR-BLAH is ready.” The attachment is titled 1120-BR-BLAH.

My ideal solution would be to be able to automatically filter Cat Reports into one folder and Bunny Reports into another folder.

Things I have tried:

1. Filtering based on “-CR-“ and “-BR-“. Outlook seems to treat hyphens as if they don’t exist, so the CR filtering also captures the word “Critters” which is in both CR emails and BR emails, and the BR captures “Meadowbrook”, which is in both CR and BR emails. This does not help me.
2. Filtering for “Cat Report” or “Bunny Report” (Words which appear inside the attachment). Outlook doesn’t seem to filter based on words inside the attachment.

Answers that are unhelpful:

1. Telling me to ask the sender to change the subject lines. I have no input in the subject lines of the emails, or the naming structure of the reports. The sender is an entity that is stretched pretty thin and not open to making any changes in procedures, so asking them to change the subject line or the naming structure of the reports to make my job easier is a no go.

2. Anything that requires me to do actual coding. I’m not an IT person and I am not allowed to install or modify software at work.

Answers that are helpful:

1. A technical solution that filters the BRs and the CRs into their respective folders.
2. A suggestion for something I could ask the IT person at work to do — like a plug in for Outlook that could help.
3. If it truly can’t be done, “it can’t be done and here’s why.”
posted by SockISalmon to Technology (10 answers total) 2 users marked this as a favorite
 
What version of Office are you using? I just tried filtering on "-CR-" in Office 365 on Windows and it worked just the way you want it to, only matching if the hyphens are in the subject line.
posted by He Is Only The Imposter at 7:34 PM on January 11


It's Version 14.0.7214.5000 (32-bit), part of Microsoft Office Professional Plus 2010.

Other possibly relevant info:

The emails are delivered to an email alias (distribution list) that I am on.
posted by SockISalmon at 8:34 PM on January 11


Are the two words that are not CR and BR always "Critters" and "Meadowbrook"? Or are you using those as just examples?

In Outlook 16 (can't check your specific version), you can have a rule that says:

subject: contains "CR"
except if:
subject: contains "Critters"

Which would work only if the items used for "except if" are few and specific.
posted by meowzilla at 9:04 PM on January 11


When you are filling in the Subject contains field, which one are you typing:

-CR-
or
"-CR-"

Putting the search term in parentheses is supposed to allow special characters like hyphens to be used. Are you using parentheses as part of the search term?
posted by rakaidan at 2:39 AM on January 12 [2 favorites]


Could the emails be using em dashes instead of regular hyphens?

Sorry I can't check Outlook 2010, but in Outlook 2016, em dashes and hyphens are treated as different symbols in the subject line of an email. So maybe double-check that your rule is using the right one?
posted by SuperSquirrel at 4:57 AM on January 12 [3 favorites]


This should work. I have Office (Home and Business) 2010 with Outlook version 14.0.
I just set up a rule:
- Apply this rule after the message arrives with -CR- in the subject
- move it to the mefi-test folder
- and stop processing more rules.
I did not add " around the -CR- when entering it, but outlook added the quote marks for me.

I sent myself a message from another account with subject "test email for me with 340-CR-56 in subject line" and it went right into the mefi-test folder as instructed.

I sent myself a message from another account with subject "This is a test using CR without hyphens" and it went to my regular inbox.
posted by evilmomlady at 5:38 AM on January 12 [2 favorites]


If the -CR- is always preceded by a number, you could try setting up rule(s) to match 0-CR-, 1-CR-, 2-CR-, ..., 9-CR-.
posted by willnot at 8:18 AM on January 12


One other thing to try if you just want to find them and not move them, Advanced Search is supposed to handle special characters better than simple search (and possibly rules based searches), so go into advanced search and create a search folder. Anything that matches the advanced search condition will automatically be in the folder, but it also will leave the message in the inbox, so that might not be your preferred solution. You may be able to design a rule that moves all of these reports into a folder if there's something unique about all of them and also use the search folders to find just instances of the cat reports.
posted by willnot at 8:29 AM on January 12


Tested a bunch of these suggestions, and unfortunately none of them seem to work.

Rules for actual words in the subject line surrounded by quotes like "Cat Report" work fine.

But once the hyphen character comes in, everything falls apart. I get the same results with quotes as without. I've tried em-dashes, en-dashes, and copying and pasting the number from a Cat Report, and none of them work.

The end result was that I was getting the following things in my Cat Report Folder:

Subject: Crouton petting contest January 14th

Subject: Wallaby Data
From: Eleanor Crabtree

The rules to match 0-CR-, 1-CR-, 2-CR-, etc seemed like a great idea, but created the same result.

It's like the hyphen breaks the specificity of the search. I think something's not set up correctly, since this seems to work for everyone else's Outlook. Maybe it's the email alias throwing things off. I just don't know what else to try at this point. Thanks for trying, everyone.
posted by SockISalmon at 9:19 PM on January 13


This page, although old, suggests a technique that appears to still work for me in my Outlook: use angle brackets to wrap the search term. they suggest to do so within quotes, but I found that it worked without the quotes.

So try either <-CR-> or "<-CR->" and see if one of those works?
posted by misterbrandt at 9:05 AM on January 16


« Older Seeking sources of word search puzzles that go in...   |   Health Insurance & "Prior Authorization" Newer »

You are not logged in, either login or create an account to post comments