Flaky internet connection.
February 19, 2006 9:43 PM   Subscribe

My internet connection is flaky. When I load say MeFi, MeTa & Ask MeFi in three tabs together, only 2 of the 3 will load, the 3rd one will be a “Server not found” message. I’ll be able to download something or IM but be unable to load Google, etc. I don’t know what is wrong or how to fix it. Any ideas?
posted by riffola to Computers & Internet (15 answers total)
 
Response by poster: I don't have any background downloads going on. Nor is any resource intensive programming running.
posted by riffola at 9:44 PM on February 19, 2006


Is your one computer the only one connected? Are you behind a router? Are you on DSL, cable, or dialup?
posted by twiggy at 9:47 PM on February 19, 2006


Response by poster: Oh right sorry. PC > Router > Cable Modem. I have the same problem if I have it as PC > Cable Modem.
posted by riffola at 9:53 PM on February 19, 2006


This sounds like one of a few potential problems:

- Low memory -- Since your general description makes it sound like perhaps you can only open a limited number of connections at once, have you checked your memory usage on your PC?

- A boatload of connections you don't know about causing problems for you -- have you checked your PC for spyware / adware? Have you tried opening a dos window and typing "netstat" to see what all you're connected to? Might be informative.

- Lastly, it could be a problem with your ISP ... either a generally overloaded pool of bandwidth in your area, or perhaps a piece of hardware flaking out. I'd say there's also a remote possibility of your ISP's DNS servers being the problem, but I'm not so sure on that one.

I know that none of these various suggestions necessarily solves your problem, but there's pretty much no way for any of us to troubleshoot your problem 100% without the ability to really sit down and tinker with things, run tests, and see what's going on. Have you tried calling your cable modem provider?

One quick test: open a dos window, type ping -t yahoo.com ... let it go for a minute and see what your response timers are. They should be pretty consistent, and since you're on a cable modem, they should probably be below 100ms - maybe even well below (for me it's about 40ms).
posted by twiggy at 10:16 PM on February 19, 2006


MeFi actually in general has been flaky for me lately. Perhaps it's not your end at all?
posted by charmston at 10:20 PM on February 19, 2006


Agreed, MeFi is not a good test bed. It's the least dependable connection in my group of ten "News and Commentary" tabs.

riffola, next time this happens to you, please do this:

1. open a dos box
2. type "netstat -b"

Tell us, how many connections are listed when you do this? If there are a LOT of connections already made, perhaps you do have some malware tying up some of your TCP connections.

Also, look in the column on the right. Are there a LOT of connections who's STATE is TIME_WAIT?
posted by Dunwitty at 10:36 PM on February 19, 2006


My ISP (adelphia) has notoriously bad DNS service, and when I pointed my DNS somewhere else, a lot of similar problems went away. Perhaps you could try using a different DNS service?

(If by some chance you're on adelphia, suggested DNS alternatives can be found here)
posted by IvyMike at 10:39 PM on February 19, 2006


Response by poster: I'm on RoadRunner NYC. My PC has 512MB memory, and a 3200+ 64 bit procesor. Plenty of HD space too.

Now as for adware or spyware, I scanned the computer with AdAware, Spybot & Windows Defender. No virii either as per Symantec Antivirus.

Pinging Yahoo had an average time of 88ms. Google gives me an average time of 36ms.

Netstat says right now my only active connections are by Firefox, and they both are ESTABLISHED to local ports 1038 & 1039.

I called my ISP they blamed it on my router or a bad network card. But I'm having the same problem with the laptop too. To which they said they'll send a guy to my place in a week's time. They weren't much help.

I'll try out the DNS trick.

Thanks for all your suggestions so far. I know this is not quite an easy problem to troubleshoot even from here in front of the computer, let alone from a distance. So thanks for trying.
posted by riffola at 6:09 AM on February 20, 2006


We have a similar problem on our home network. 4 computers connected to a router connected to a cable modem. What we do is reset the router and cable modem (just unplug them for 5 seconds). DHCP refreshes, and voila, much better service. It's not a real fix, just a band-aid, but it has worked for us.
posted by gilgul at 6:49 AM on February 20, 2006


Response by poster: Yes, rebooting the modem helps temporarily, but not for long.
posted by riffola at 8:25 AM on February 20, 2006


Your ISP could well be right about your router being the problem. Many SOHO routers such as Linksys and DLink need firmware updates to resolve problems with the on board code they initially shipped with. If you haven't done so, check your router manufacturer's site for current firmware, and upgrade, before you do anything else. This is usually a free download, but you need to do this from a wired, not a wireless connection to your router.

Be sure you are matching the labels and other identifying info for your router to the firmware version you are getting for upgrade, as a wrong version will turn some routers into a "brick," and again, only perform the update from wired connections.
posted by paulsc at 8:55 AM on February 20, 2006


I'm on Roadrunner NYC as well and had a similar problem a year or two back. They eventually replaced my modem, and it's been pretty smooth ever since. Of course, they'll probably blame it on many things before they actually come out and replace the modem, so you'll just have to go along with them until it works. I had to have a guy come out twice before they tried replacing the modem.
posted by bgale at 9:03 AM on February 20, 2006


I was having similar problem for a long time. I thought it might be my wireless router, my cable wiring, my isp's dns server, etc. After going nearly insane, i turned off my software firewall package for a minute - and everything loaded fine.
My chief symptom was: I was able to load sites by IP address but not by domain name. I guess the firewall package provided by my ISP (charter) would think longer about those and die.
Switching to a hardware based firewall fixed all that.
posted by muddylemon at 9:13 AM on February 20, 2006


Response by poster: The router firmware is the most recent one available. The thing is I have the same problem even when I don't have the router connected. I guess it might be the Windows XP firewall. I'll try disabling it & using only the router's hardware firewall and see if that helps.
posted by riffola at 10:29 AM on February 20, 2006


I believe you're running into a problem with how your browser handles network connections. I think that they're doing this to be compliant to the HTTP spec.

Try this. If you're using Firefox, go to the address bar, and type 'about:config' , click Go.
You're now looking at a list of internal Firefox configuration variables. Find the following:
network.http.max-persistent-connections-per-server
Set this to something higher than 2. I think I have mine set to 30 or so.

There's a similar registry key that you can change if your browser of choice comes from Redmond... searching for wininet.dll and max connections should turn up useful information.

Good luck!
posted by machinecraig at 1:21 PM on March 1, 2006


« Older Dog training   |   Pregnancy and Genetic Disease Newer »
This thread is closed to new comments.