Help Me Fix an Incorrect Saved Username on an Okta Login Page in Chrome
November 11, 2018 12:59 PM   Subscribe

This is a small problem, but I've run into it every time I log in to any system at work for the past 18 months, and at this point it threatens to last for all eternity. When the Okta login screen appears, the username field is pre-populated with an incorrect email. How do I fix or remove the pre-populated value outline in red on the screencap? Worth noting Chrome does have the correct autofill value saved (with associated password.)
posted by boghead to Computers & Internet (7 answers total)
 
sorry if this has already been attempted, but does it appear in the list of saved logins/passwords in chrome settings? if yes, click on the vertical line of 3 dots and choose "remove" from that tiny menu. if not, you need to select it in the email field of the login page itself and use shift+delete.
posted by poffin boffin at 1:08 PM on November 11, 2018 [1 favorite]


when you say an incorrect email- is it another one of your own email addresses, another email address from your company or a completely random email address?

for information purposes it'd be seeing what happens in an incognito window (control-shift-n). that should at least remove your chrome profile as a factor.

if it happens in incognito mode it could be an issue with group policies- in which case it's really on your office's IT sysadmins to fix.
posted by noloveforned at 1:38 PM on November 11, 2018 [1 favorite]


@poffin boffin - it doesn't appear in the list of saved logins and passwords, but highlighting the incorrect username and hitting shift + delete seems to have no permanent effect. That is, when I reload the login screen, the incorrect username returns.

@noloveforned - the username is an old company email of mine. We switched domains.

In an incognito window, no username populates.

In Firefox, the correct username and password populates!

This makes me think it's a function of the browser, not a group policy.
posted by boghead at 3:13 PM on November 11, 2018


hmm. you might be able to force it to appear in saved passwords by putting a password into the pw field when the wrong address comes up, letting that get saved by the browser, and then deleting from settings. but if that doesn't work then you run the risk of having this incorrect email with a completed password field masquerading as the correct login info when you open the page and clicking it accidentally only to be further annoyed every time.
posted by poffin boffin at 3:46 PM on November 11, 2018 [1 favorite]


Are you handy with dev tools? Check the cookies. Or just try clearing them
posted by pyro979 at 3:52 PM on November 11, 2018 [1 favorite]


Agree with pyro979 – you probably have the incorrect email stored in the browser's local storage (and/or cookies). And when you visit mycompany.okta.com, the Okta website is reading that email address from the browser itself.

To fix this with a big and easy hammer, you can clear your browsing data from all time in Chrome. This of course would result in all websites "forgetting" you and could be inconvenient.

You can also clear the local storage for just the Okta site, which should remove your stored email address without affecting the data stored from other sites. Do do this, start by loading up the Okta page. If you're on a Mac, from the menu bar you can navigate to View > Developer > Developer tools, where you'll have access to the Manage Application section. That's where you'll be able to use these steps to Clear Storage.
posted by reeddavid at 4:54 PM on November 11, 2018 [1 favorite]


Thank you internet friends.
posted by boghead at 9:19 PM on November 12, 2018


« Older Meal planning for a toddler with allergies   |   Coping when your spouse has a pain in the neck,NHS... Newer »

You are not logged in, either login or create an account to post comments