Getting email at a domain that uses third party hosting for dns...
June 12, 2018 2:55 PM   Subscribe

As a follow-up to this question, about a .TO domain (hosting a DNS) -- how do get email at this new domain?

The domain was purchased from tonic.to

The DNS is hosted by ZoneEdit (which seems to have email options, though enabling them did nothing).

The site is hosted by Squarespace.

How can I create .to email addresses that I can check with the Gmail app like I do all my other domains that don't utilize a third-party DNS?

Thank you.
posted by dobbs to Computers & Internet (16 answers total)
 
No time right now, but basically you need an MX record that points to an SMTP server

IN MX 10 my.mail.server.

That server could then alias all email to a gmail account. Your DNS host may provide such an alias service- no idea.

If you're asking about taking *all* email to your domain.to and sending it to something like Google- that I'm not positive about. Google does site verification with a domain key that might work, but I think you'd then be paying for that.
posted by mrzz at 3:21 PM on June 12


Couldn’t tell you the cost but a simple Aws instance could handle the MTA- postfix was my go to after Solaris sendmail.
That’s not really answering your Q, but if your DNS proclaims to have email services I bet they can be aliased/forwarded after the MX record is in place. Just a guess- I got out of the email server business 6 years ago.
posted by mrzz at 4:39 PM on June 12


Did you set up their mailmaps settings? That looks like simple forwarding
posted by mrzz at 4:47 PM on June 12


Are you looking for email hosting, or are you planning to forward email for you@yourdomain.to to an existing email address (like you@gmail.com, for instance)? If you just want the latter, this support video should walk you through setting up email forwarding on ZoneEdit.
posted by Aleyn at 5:36 PM on June 12


mrzz, I did enter the stuff for mailmaps but it doens't seem to work. Not sure if there's something else I'm supposed to do somewhere else.

Aleyn, I need the emails to come to me@mydomains.to and respond from that address as well.
posted by dobbs at 5:52 PM on June 12


If you want to send, you need hosting of some sort, and you have two options: roll your own, or find a email provider. If you want to roll your own, there was a pretty good guide over at Ars Technica or you can do something like iRedMail on a Digital Ocean droplet/AWS/whatever. I've gone the iRedMail route a time or two and it works pretty well but it is something you have to keep up with. It does have the sort of ActiveSync stuff so it works a lot like an Exchange/Outlook.com account in Outlook. The problem with hosting is that there's a good amount of moving parts to compensate for email being absolutely terrible security-wise (as befits a set of protocols that are that ancient) and getting things like DKIM and all that set up can be a bit daunting while being absolutely essential.

If you want hands-off, there are a lot of options; most anyone that does basic site hosting also does email hosting (like GoDaddy). You can still sign up for the Google business stuff, though there is no longer a free tier, and Microsoft offers similar services through Outlook.com/Office365. None of these will be free, AFAIK, but they'll be pretty cheap to deal with, and any one of these worth their salt will give you the info to put into your DNS so you can keep them separated.

I am not entirely sure but I recall Squarespace having some sort of email stuff so it might also be worth looking through their support site.
posted by mrg at 6:43 PM on June 12


Following @mrg, you could also look at Mailinabox for self-hosting.

If you decide to go the hosted route, look at Zoho Mail, which has a free tier. It may not work for the gmail app, but would give you email forwarding or web access. If you're looking for a catch-all (where anything@yourdomain.to comes to your inbox), you can configure that as well. I use FastMail, which provides a similar service to G Suite or O365 at a similar price, and I've been happy with it.
posted by draw at 7:18 PM on June 12


You can do what you have in mind at no cost for the first 10,000 e-mails per month and 50 cents / 1000 e-mails after the first 10,000 using mailgun.com

I have a similar setup to yours. I'm using cloudns.org where you're using zoneedit.

To get incoming e-mail to go to your gmail address you need to :

- Create a mailgun account and add your domain to it. You will also need to create some DNS records in zoneedit.com - mailgun guides you through this. Among other things, these DNS records will direct e-mail to your custom domain to mailgun.com

- Inside mailgun add a "route" to forward e-mail to your gmail account.

Do the above steps first because you will need to have incoming e-mail working to configure outgoing e-mail.

To respond to e-mails (or initiate new outgoing e-mails) using your custom e-mail address :

- In gmail settings go to "Settings" / "Accounts and Import" / "Send Mail as" and add your custom e-mail address. You will enter some e-mail related settings which you need to get from mailgun. Then gmail will send a trial message to verify that you own the account. Having already set up incoming e-mail to the custom address, the trial message should appear in your e-mail inbox with a validation number.

Once you've done this you will be able to use your custom e-mail address with no hint that there's a gmail account behind it. This will work both from the gmail web page and the android gmail app.

Some of the above was from memory but it was not too long ago that I went through this song&dance so I probably got most if not all of the important details.

Feel free to let me know if you run into problems.

Have Fun.

- Dave
posted by metadave at 9:55 PM on June 12


Thanks for the answers thus far.

metadave, I am attempting the mailgun route.

However, in Mailgun's instructions for MX Records it has these two columns:

Priority / Value

However, on Zoneedit's site, there are four columns, none of which match:

Mail for Zone / Mail Server / Pref / TTL

The zone one is looking for a domain variable as it has a box followed by .mydomain and tells me that @ is for the root domain.

The first MX record there was pre-populated by @ and the LOCAL and then 0, with TTL left empty.

No idea if I'm supposed to put in the mailgun figures and where and leave or delete the Local.. ?

Thanks.
posted by dobbs at 8:57 AM on June 13


I wanted to make sure that mailgun would work with zoneedit so I created a zonedit account and set up a zonedit.com domain for custom e-mail using mailgun.com.

The following are some stream-of-thought notes that I took along the way that should help answer your questions.

------------------------------------------------------------------------------

INCOMING EMAIL

You can delete the pre-poplulated MX record that zoneedit.com gives you.

mailgun suggests adding a bunch of DNS records (TXT, MX, CNAME) . I added all of them.

For root DNS records I specified "@" as the HOST

For TTL I always specified 3600 (1 hour) because that was what cloudns.org gave me by default.

The "Check DNS Records Now" page in mailgun works well to verify that you have your DNS correctly configured. Leave this up as you configure DNS on zoneedit and watch the indicators turn green one by one.

you said:
However, in Mailgun's instructions for MX Records it has these two columns:
Priority / Value
However, on Zoneedit's site, there are four columns, none of which match:
Mail for Zone / Mail Server / Pref / TTL

in response:
Set "Mail for Zone" to "@" ( as mentioned before, this is the root domain )
Set "Pref" to "10" ( this is the "priority" of 10 that mailgun calls for )
Set "Mail Server" to whatever "Value" mailgun calls for ( probably "mxa.mailgun.org" and "mxb.mailgun.org" )
Set "TTL" to 3600 ( as mentioned before )


zonedit.com objected to the CNAME suggested by mailgun but let me confirm that I knew what I was doing.

Even after setting everything up correctly, it took a few minutes for incoming e-mail to work.

OUTGOING EMAIL

When you add your custom e-mail address in gmail using "Settings" / "Accounts and Import" / "Send mail as", keep "Treat as an alias" checked.

The configuration information you need to send mail as another user from gmail is the top of the mailgun "Domain Information" page for your domain.

From this page You will need :

-- "SMTP Hostname" ( use this for the "SMTP server" that gmail asks for ). This will probably be "smtp.mailgun.org"
-- "Default SMTP login" ( use this for the "Username" that gmail asks for ). This will probably be "postmaster@"
-- "Default Password" ( use this for the "Password" that gmail asks for ). This will be some long random string.

Leave "Secured connection using TLS" checked.

Once you accept the information in the form, you will recieve a confirmation e-mail .

After you've confirmed ownership of the custom e-mail address, both incoming and outgoing should work in the gmail web page and the gmail android app.

In the gmail "Settings" / "Accounts and Import" / "Send mail as" setting, you have the option of making the custom e-mail the default and "replying from the same address that an e-mail was sent to"

I've gone into some detail so this seems like a lot but it's not really too bad.

posted by metadave at 12:56 PM on June 13


Thanks again, metadave.

I am still not quite getting it, though.

Mailgun suggested using a subdomain (mail.mydomain.com), which I did. Was it a mistake to do that? Should I just use mydomain.com?

Everything is green except MX records which are yellow. I filled them in as you suggested and deleted the LOCAL line. (I'm supposed to put @ for both mxa.mailgun.org and mxb.mailgun.org, yes?)

When Gmail tries to send me the confirmation, I see:

Message not delivered. The response from the remote server was: 550 5.7.1 Relaying denied.
posted by dobbs at 2:04 PM on June 13


I don't think it was a "mistake" to use the sub-domain but what you really need is mydomain.com .

The first time I configured mailgun for a custom e-mail address they suggested the same thing "mx.mydomain.com" in my case. I configured "mx.mydomain.com" *and* "mydomain.com" I don't know why the subdomain was needed or what would have happened if I left it out.

The reason the mx records are yellow is that you are configuring the subdomain. For that you need to put "mail" - (or whatever your subdomain is ), not "@" .

At this point you probably should finish configuring the subdomain and then add the domain and configure it too. Just like configuring the subdomain but put "@" instead of "mail" .
posted by metadave at 2:53 PM on June 13


All green!

I deleted the mail.mydomain.com thing and created a mydomain.com one and everything is green.

However, now when I try to send the gmail test it tells me the address doesn't exist.
posted by dobbs at 2:55 PM on June 13


Have you set up a "route" in mailgun to forward your custom e-mail to gmail?
posted by metadave at 3:08 PM on June 13


It sounds like you may be trying to set up outgoing e-mail before you have incoming e-mail working. You need incoming e-mail working before you can set up outgoing e-mail and you can get incoming e-mail working completely before attempting the outgoing setup so you should get incoming working first.

To get incoming e-mail working you don't have to do anything with gmail settings.
posted by metadave at 3:33 PM on June 13


Thanks so much, metadave! Everything is working grand now. Used MailGun and ZoneEdit. Excellent!
posted by dobbs at 3:12 PM on June 14


« Older How to find-and-replace on a BIIIIIIG file?   |   Was there a power outage in Rio today? Newer »

You are not logged in, either login or create an account to post comments