iTunes: All the !'s
March 13, 2018 11:16 AM   Subscribe

I have a very large music library on an external drive. I'm running current version of iTunes and MacOS. For some reason, Every Single Track has the "!" next to it. Playing a song works; once I click it, iTunes finds the track with no problem. !'d tracks won't sync to other devices or play with Apple Music. How can I fix this without clicking on 20k items?
posted by bluejayway to Computers & Internet (1 answer total) 3 users marked this as a favorite
 
Most likely what happened is that you fired up iTunes at some time when the external drive was not connected, and iTunes "lost" the location of the music library folder. Grep around in the settings for something like "choose iTunes library" (or hold down "option" while starting up the program) and then navigate to your library's location and re-select it.
posted by slkinsey at 11:23 AM on March 13 [1 favorite]


« Older Explain Napa Valley to me   |   How to compel neighbor to unclog overflowing sewer... Newer »

You are not logged in, either login or create an account to post comments