Why is my smart thermostat so dumb?
February 1, 2018 8:25 PM   Subscribe

We got a Nest thermostat this Fall. While we were already using a programmable thermostat to good effect, I was looking forward to having a thermostat that was internet connected and better learned our habits. We have been underwhelmed to the point I think that maybe I’ve done something to screw it up.

The Nest works great in the morning: by the time we get up, the house is nicely warm and it turns the heat down when we leave. However, when we get home in the evenings, the Nest always appears to be in Eco mode and is set to a low temperature. As soon as it “sees” us, it raises the temperature, but the steam radiators take nearly 1.5 hours to warm the place up.

We have a very predictable schedule during the week, so I would hope that the system would have figured it out by now. I’ve even taken to manually scheduling the system to turn on ~1.5 hours before we get home, but it refuses to start heating until the motion detector sees us. The thing that’s confusing about this is that it works perfectly in the morning - even figuring out how early it needs to start “preheating” to reach the desired temperature by the time we get up.

What’s the answer? Turn off Eco mode? Change something about the schedule? Throw this very expensive hockey puck out the window and put the old one back?
posted by Betelgeuse to Technology (10 answers total) 2 users marked this as a favorite
 
Do you have Home/Away Assist on? Thats probably putting you into Eco mode all the time. It can sometimes be problematic if the Nest is in a weird location where it can't "see" you.

What about Early On? In theory that should be doing the "get it ready before you get home".
posted by thefoxgod at 8:53 PM on February 1, 2018 [2 favorites]


Turn off the self-learning stuff. It never worked well for us. Just set the schedule to be the temp you want at the time you get home*, and the Nest will learn how long it takes to heat the house and turn on early enough to be warm when you get home.

Check the history to see if it's actually turning on early but then turning off again when it can't see anyone. If you set it to be at temp the time you're home, then it won't expect to see anyone until the time you're home.

*so eg if you want it to be 20C and you get home at 6pm, set the schedule as 6pm/20C. If you're setting it for 4:30pm/20C, it's probably heating up then seeing no-one home and turning off at 5pm.
posted by EndsOfInvention at 2:42 AM on February 2, 2018


I had my Nest E set up with Home/Away Assist to use my phone to set it automatically to be away and had the same problem you’re describing. I came to the conclusion that the Early On feature that would ordinarily make it so your house was warm when you get home wasn’t compatible with Home/Away Assist. (If I’m wrong, I hope someone here will correct me!) I now just have a set schedule.

Note that you shouldn’t have to set the schedule for 1.5 hours before you come home if you use Early On. Set your target temperature and time and it will automatically calculate what time to turn on to hit your desired temperature at your scheduled time. THAT part works great.
posted by kittydelsol at 3:59 AM on February 2, 2018 [2 favorites]


The Nest should learn what times you're usually at home and have more leeway before it turns to Eco Mode if it doesn't detect anyone. If your schedule has changed (and you're arriving home at times when you used to still be out) then it still be using old data, but you can reset the Home/Away data it's learned via the thermostat.

Alternatively (and we had this issue), if you're setting to be warm for e.g. 6pm but you're usually home later than that (say 6:30pm), then during the period between 6 and 6:30, a) the Nest will learn no-one's usually home at this time, and b) it will turn to Eco Mode more readily since no-one's home and no-one's usually home. Even if it learns that people are usually home around 6:30pm, it won't pre-emptively turn on for 6:30pm if you've set it to be warm for 6pm. Basically Nest makes it hard to adjust for the situation of "no-one is home but I want the heating on anyway", since it's designed around saving money by turning off in this situation.

What you need to do in this case is move the schedule a bit later so it's warm for the time that you're realistically home - 6:30 in the above example. The Nest won't turn the heating off if it's in the pre-heat phase, it will only do so if it's reached the target temp and it's past the time you set (when it assumes you're going to be home). Hope that makes sense - short version is make sure the target temp is set for the time you'll actually be home, and not much earlier than that. Also, try resetting the Home/Away Assist data the thermostat has learned if your daily schedule has changed lately.
posted by EndsOfInvention at 4:21 AM on February 2, 2018


You just need to disable the Home/Away Assist. The entire point of that mode is to make sure the heating is turned off when there's nobody home. With Home/Away Assist off it will stick to the schedule even if nobody is home, i.e. turn on the heating at the correct time to be up to temperature when you arrive.

Yes this means you now have to actively set it to eco mode if you're away when you would normally be home.
posted by quacks like a duck at 5:38 AM on February 2, 2018


I'm going to nth "turn off home/away mode."

We used a Nest (2nd gen) at our old house, which was under 995sqf and had forced air heat in San Francisco. Home/Away always worked pretty well. However, at our new house in Milwaukee, which is almost 3000sqf, and uses radiators to battle the Wisconsin cold, Home/Away worked terribly, enough that I was sort of shocked.

The difference is that in our small forced air house, we could get things comfortable in 10-20 minutes, whereas getting the heat up in our current house takes, like yours, 1.5 hours. That's just not fast enough for the feature to work as it was designed.

So, yeah - with the radiators, it's probably best to turn off learning, turn off Home/Away, use manual schedules. Even without those features, the expensive hockey puck still has the benefit of remote control and looking good on the wall.
posted by eschatfische at 5:45 AM on February 2, 2018


To everyone who is suggesting I turn off Home/Away assist, I have a question: why does it work perfectly in the morning when it’s also not seeing anyone move around all night? Does it distinguish between night and day?

I’m going to try to reset the Home/Away assist data and set the evening temperature for the time I actually get home and see where that leaves me.
posted by Betelgeuse at 6:39 AM on February 2, 2018


Morning preheat does work differently in some ways, for example you can set a maximum preheat time in case your heating is noisy, but your can't do that for daytime preheating.
It could be that it also assumes that even if you get up late you don't want the heating turning off because you're still at home (albeit in bed).
posted by EndsOfInvention at 8:40 AM on February 2, 2018


You did nothing to screw it up; Nest is a bad product. Has been since the beginning. I have one and regret the waste of money. It works fine if you put it in dumb mode with a fixed programmed schedule and absolutely no learning / automatic anything. You'll have to manually set it into "Eco" mode when you leave; that's what everyone else calls "Away".
posted by Nelson at 10:14 AM on February 2, 2018 [1 favorite]


“Home/Away Assist won’t automatically put your home into Away during the night when Nest product sensors probably won’t detect any activity.” (more here)
posted by kittydelsol at 4:19 PM on February 2, 2018


« Older can't get Netgear wifi extender to forget its old...   |   Can I smoke it? Newer »
This thread is closed to new comments.