How do I get rid of these search suggestions?
December 31, 2017 9:59 AM   Subscribe

When I click on the address bar in Safari on my iPhone, I’m given suggested search terms based on the content of the page. I’m a recent survivor of sexual assault, and sometimes the suggested search terms are distressing to me, as in this example. How do I turn these suggestions off? I do not want to turn off typing suggestions in general, as I use those extensively.
posted by ocherdraco to Computers & Internet (13 answers total) 1 user marked this as a favorite
 
There’s a preference you can disable called “Include search engine suggestions.” My version of Safari has it in a slightly different place from the one in this guide, but it worked for me.
posted by migurski at 10:02 AM on December 31, 2017 [1 favorite]


Just noticed you specified iOS. The same setting can be found in the Settings app (silver gear icon) under “Safari”.
posted by migurski at 10:04 AM on December 31, 2017 [1 favorite]


I already have that turned off. It doesn’t seem to affect this behavior; I still get the suggestions.
posted by ocherdraco at 10:37 AM on December 31, 2017


Aren't the suggestions in that position on the screen the autocomplete word suggestions, not Siri search suggestions? General > Keyboard > Predictive.
posted by emelenjr at 10:51 AM on December 31, 2017 [1 favorite]


But I want predictive text in general; that’s primarily how I type on my phone. I just don’t want these search suggestions. Is there no way to get rid of one without getting rid of the other?
posted by ocherdraco at 10:56 AM on December 31, 2017


What I was saying is that I don't think those words in the screenshot that you're trying to avoid are search suggestions, but predictive text, because that's the spot on the screen where predictive text appears. I also can't replicate the screenshot, via going to the same Safari screen. No suggested words appear in that spot where they appear in your screenshot.

This might be inconvenient, but try clearing the Safari history and web site data. Settings > Safari > Clear History and Website Data near the bottom of the page.
posted by emelenjr at 11:07 AM on December 31, 2017


I don’t imagine that will change anything, as the suggestions seem to be created from the content of the page I’m currently on.
posted by ocherdraco at 11:13 AM on December 31, 2017


You might try temporarily turning off predictive text, just to test whether that's the source of the problem.
posted by jon1270 at 11:47 AM on December 31, 2017


They do seem to go away when I turn off predictive text. 😞
posted by ocherdraco at 12:10 PM on December 31, 2017


Found a thread on apple.com discussing the same problem a few months ago, and nobody had a solution other than switching browsers.
posted by jon1270 at 12:10 PM on December 31, 2017


I really wish I didn’t have to essentially break my phone to avoid this.
posted by ocherdraco at 12:11 PM on December 31, 2017


Looks like it's a Safari "feature" specifically. Yeah, try using a different browser like Firefox.
posted by floatboth at 4:09 PM on December 31, 2017


In a quick test, it looks like you can avoid this by switching to a third party keyboard. The one I use is Swiftkey.
posted by john hadron collider at 1:19 PM on January 1, 2018 [1 favorite]


« Older Looking for some happy creative projects   |   Thanks, but no thanks! Newer »
This thread is closed to new comments.