I Don't Understand iCloud, iContacts, iPhone, iPad and Syncing. HALP!
October 28, 2017 1:08 PM   Subscribe

For the life of me, I can't seem to get my iPhone to push contacts to my Mac and my iPad, and vice versa. I can visualize how I think it should work/how I want it to work, but I'm afraid I haven't turned on something.

I have a MacBook AIR, an iPhone and an iPad.
As my iPhone is with me always, I tend to use it as my primary contact source.
If I add/change/delete a contact, I want that to also happen in the Contacts on the other two devices. I also expect that if I add/delete/change a contact on one of the other devices, it will flow to the other two.
Everybody's talking to everyone else, happy world.

This doesn't seem to be happening. Sad world.
I add a contact on one of the three and it seems to be an island unto itself.
Am I delusional?
Am I correct?
I thought that this was what iCloud was FOR.

If I'm right, please lead me thru the steps to get these things talking to each other. Don't be afraid to talk to me as if I'm 5.
If I'm wrong, please break it to me gently, and I'll have to figure something out.
I'm running the most recent software versions on all three.

Thank you!
posted by Major Matt Mason Dixon to Computers & Internet (9 answers total) 4 users marked this as a favorite
 
Make sure you're logged-into (the same account) iCloud on each device, and make sure contact sharing is enabled/'checked' on each. That's really all that you need to do.
posted by destructive cactus at 1:10 PM on October 28, 2017


This is my setup. You are right that is really how it is supposed to work. However you do need to be signed in, with the same account (keep in mind that I have multiple accounts and the jessamyn account and the jessamyn@gmail.com account are different and not-combineable DAMNIT APPLE). Here are setup instuctions for your devices. Things to check

- how and when and how often syncing is set up - defaults should be that they all update everything but maybe you tweaked something? maybe something updates manually?
- making sure the syncing is happening on your phone whether you're on wifi or cellular. You may have turned that off w/r/t cellular then are wondering why it won't update when you're not at home/work
- make sure you have space on the cloud and it's not being taken up with photos and etc. First 5GB is free, then you pay.

If any of those devices is new, call Apple and make them talk you through it. They are surprisingly nice.
posted by jessamyn at 1:24 PM on October 28, 2017


I go into my iPad and iPhone Settings, click on my name, and I see all three devices under that iCloud ID. Under "Apps Using iCloud", I have "Contacts" slid to On. On my mac, I go into Settings, click on iCloud, and I have a checkmark under Contacts. Is there some place else I should be enabling contact sharing? Thanks for clarifying this.
posted by Major Matt Mason Dixon at 1:26 PM on October 28, 2017


Nope that is exactly correct. If, on my phone, I go under Accounts & Passwords - iCloud it will show the same thing and there is also a little option at the bottom which on mine says "Fetch New Data" You can check there to see how/when iCloud does its thing with options being Push|Fetch|Manual. On your laptop you can go to Contacts and then preferences and make sure the iCloud account is enabled under "Accounts" and you should also see a "fetch" option. Again, these are usually the defaults but it's possible you or someone else adjusted them.
posted by jessamyn at 1:35 PM on October 28, 2017


It's also worth checking to see if your Contacts are being added to the local storage or to the Cloud account. This used to be possible on the iPHone, and could be confusing. Your default should always be to add them to iCloud.
posted by Alensin at 1:47 PM on October 28, 2017 [1 favorite]


Even though apple seems to tell me that I can't make fetch happen, i've got everything set up to make fetch happen. I'm not sure if Automatically means now, or 5 hours from now, so I'll go make a cup of Rooibos and see if my test contact will migrate from my phone to the other two knuckleheads.
If yes, I will be streets ahead.
Thank you, Jessamy and Destructive Cactus!
posted by Major Matt Mason Dixon at 1:48 PM on October 28, 2017 [1 favorite]


One other test would be to go to iCloud.com and log in there and check if you see your contacts on the iCloud website -- it would sorta be like checking the middle-man.

Also, open the Contacts app on your Mac and go to Preferences > Accounts. Check to make sure there is a check mark there for "Enable this account".
posted by This_Will_Be_Good at 1:58 PM on October 28, 2017 [1 favorite]


It's possible you have your contacts in Contacts to save somewhere else. Open Contacts, then see what's in the upper left corner, tap if necessary, and you should see a list of places your contacts are saved at.
posted by dubious_dude at 2:19 PM on October 28, 2017 [1 favorite]


Marking all answers as Best Answers, because they all did contribute to my better understanding of this mess, and also led to (what I believe is) a solution.
Not sure exactly how I did it, but it involved checking and unchecking and itunes syncing and merging and whatnot. Groups was also an issue, I think, as I had one for gmail, and one for iCloud.
I seem to have contacts synced across devices - a test contact entered on my iphone was immediately synced to my MBA, but now I also have a shit ton of duplicates between "On my Mac" and "On iCloud"; so I'll work through them.
Thank you all!
posted by Major Matt Mason Dixon at 4:35 AM on October 29, 2017 [1 favorite]


« Older Novels or films that feature the creation of human...   |   Any Way To Remove Gross Stains On a Quilt? Newer »
This thread is closed to new comments.