Problem connecting to the internet
January 22, 2006 11:31 AM   Subscribe

I've been trying all weekend, and I can't connect my cable internet to my desktop PC.

My portable computer crashed, so I want to connect a desktop computer that I have to my cable internet service. I can see my ethernet card on the list of hardware, and I do get a connection icon, but it has a yellow triangle on it and it says "connection is limited or nonexistant." I'm unable to deactivate the connection or repair it.

When I look at my list of connections, I don't have a "1394" connection, only the one connection that I made when my internet provider walked me through the steps to get set up. Could this be the problem?

The internet provider gave up on me, telling me the problem is with my PC. Help?!
posted by hazyjane to Computers & Internet (22 answers total)
 
How are you hooking it up to your PC? From the cable modem to your computer, using an ethernet cable? A usb cable? To a router and then to your PC?
posted by Loto at 11:36 AM on January 22, 2006


Response by poster: From the cable modem to my computer, using an ethernet cable.
posted by hazyjane at 11:41 AM on January 22, 2006


1394 is firewire, so thats got nothing to do with it. Does your ISP require the MAC address of whatever you are connecting to the modem? If so, the MAC on your desktop will be different to the one on your laptop, and you will probably have to call up to change it.
posted by Orange Goblin at 11:48 AM on January 22, 2006


Have you checked the TCP/IP properties of the connection? It sounds like it could be mis-configured. Right-click on connection > Properties > Double click TCP/IP > see where the IP and DNS boxes are set. Put them both on automatic if they're not.

Don't worry about the 1394 connection, it's firewire and not relevant.
posted by Dipsomaniac at 11:49 AM on January 22, 2006


Response by poster: Thanks for the information on the 1394 connection.

Both TCP/IP and DNS are set to automatic already. The ISP doesn't require the MAC address - the support person told me I should be able to use the connection on any computer with a standard configuration, and without changing anything on their side.
posted by hazyjane at 11:53 AM on January 22, 2006


From a read over your symptoms, it sounds like Orange Goblin's diagnosis is spot on - your modem is probably MAC limited.
posted by jedrek at 11:57 AM on January 22, 2006


On posting I realized I should've used Preview.

Launch the command line (star menu => run => cmd) and type in ipconfig. What value do you have for your IP address?
posted by jedrek at 11:59 AM on January 22, 2006


I've run into cable ISPs (Comcast in Seattle, to be specific), that require the computer to have a specific hostname in order to get an IP address from the DHCP server. Try changing the name of your desktop computer to match that of your portable computer. Assuming you're using Windows XP, here are the instructions. This might be a long shot, but you never know...

Are you using the same cable that worked with your portable computer? If not, it's possible that you have a crossover cable instead of a straight-through ethernet cable.
posted by mr_roboto at 12:03 PM on January 22, 2006


Response by poster: I have 169.254.184.48 as my IP address.

If I try ipconfig /renew, the operation times out.
posted by hazyjane at 12:04 PM on January 22, 2006


Response by poster: I should also say that I've connected a different laptop to this connection than the one that I connected before.

I have 3 computers - one laptop is toast, one laptop (my work one) is currently connected (I just plugged in the ethernet cable and it worked), and one desktop is the computer in question.

I am using the same cable - just manually switching it from the desktop to the laptop.
posted by hazyjane at 12:07 PM on January 22, 2006


Have you tried resetting your modem? With my cable internet provider, I have to reset the modem each time the ethernet cable is unplugged and plugged back in, or plugged into a different source. According to my service provider, they can't see the signal otherwise.
posted by mewithoutyou at 12:12 PM on January 22, 2006


Yeah, definately try unplugging the power from the cable modem, waiting 30 seconds, and plugging it back in.
posted by reverendX at 12:15 PM on January 22, 2006


Response by poster: I reset the modem an estimated bazillion times over the past couple of days and nothing. Every time I plug the connection into the laptop, it works. Every time I plug it into the desktop, nothing.

A strange thing, to me, is that if I right-click on the yellow triangle and try to deactivate the connection, I get an error saying that it's not possible to deactivate the connection because the connection uses one or several protocols that don't handle plug and play, or that it could be initiated by another user or the system account (sorry this is inexact, my OS is in French and I'm translating).

There are no other users.
posted by hazyjane at 12:37 PM on January 22, 2006


what happens if you run a cable between the laptop & the desktop while the machine is plugged into the laptop? Enable connection sharing on the desktop and see what happens. That'll narrow it down to a problem on your end (maybe the desktop's network drivers are wrong?) or if Comcast is throwing a fit.
posted by devilsbrigade at 1:44 PM on January 22, 2006


Response by poster: devilsbrigade, I will look into trying that tomorrow (now I'm worn out with this stuff and going to bed). What kind of cable will I need to use to connect them?

Another thing about the desktop - it was built from components by a friend of mine and has never been connected to cable internet, only DSL. I called my friend who's overseas to try to figure out the problem, and he said "check the bios settings." I did, but don't see anything in there about ethernet.
posted by hazyjane at 1:54 PM on January 22, 2006


try removing and reinstalling the drivers for the network card.
posted by lester at 2:13 PM on January 22, 2006


BIOS shouldn't have much to do with it. You'll need a crossover cable, probably (I've heard bits and pieces about not needing one, but I know I've done it with a crossover patch cable).
posted by devilsbrigade at 2:33 PM on January 22, 2006


Go into the device manager (My Computer-Properties-HardwareTab-Device manager) and make sure that you don't have a yellow icon next to your ethernet adapter.
posted by Ferrari328 at 2:52 PM on January 22, 2006


169.254.184.48 is a fake IP Windows assigns when it can't get an IP through DHCP.

Plug the modem into the laptop and once the connection is up do an "ipconfig /all"; if your Ethernet adaptor says "DHCP enabled: yes", then the desktop isn't being assigned an IP by the cable provider, either because of MAC filtering or it doesn't have the proper hostname.

If DHCP is not enabled, configure the desktop with the same IP address, gateway, subnet mask and DNS server info as the laptop and it should work.
posted by bizwank at 8:55 PM on January 22, 2006


Response by poster: The network card is plug-and-play for Windows XP and so there are no drivers available on the Web site to download for my OS. I will try taking out the card and putting it back in tonight after work.

There's no yellow icon next to the ethernet card on the list of hardware.

DHCP is enabled on the laptop. I'll try changing the hostname to be the same as the laptop hostname after work today.

Thanks a lot for the ideas. I'll let you know what happens. If there's any other reason you can think of for why I can't reach the DHCP servers, please let me know.
posted by hazyjane at 11:19 PM on January 22, 2006


I've seen similar problems when the auto-negotiation (speed, duplex, etc) fails to work properly between PC and switch / DSL modem. It happens with one particular chipset (whose name escapes me - sorry) in HP and many el-cheapo motherboards.

Setting the adaptor to 10Mbps half-duplex usually (but not always) fixes it.
posted by Pinback at 2:19 AM on January 23, 2006


Response by poster: Thanks for the suggestions. I've tried everything and nothing works. I've now posted the question to google answers. Please wish me luck.
posted by hazyjane at 1:40 PM on January 25, 2006


« Older Do I have pink eye?   |   Roll, roll, roll your... window. Newer »
This thread is closed to new comments.