Ethernet Trouble on an iMac Running Sierra
July 11, 2017 9:46 AM   Subscribe

My two year old iMac, running Sierra, does not recognize that there is an ethernet cable plugged into the port. The cable is good, the originating port on the Airport is good. Is there any way to force the computer to check the port? I can deploy simple Terminal commands.
posted by OmieWise to Computers & Internet (5 answers total)
 
Are there any lights in the ethernet port of the iMac? How many and what color?
posted by Sunburnt at 10:37 AM on July 11, 2017


There are a few things that could be causing this ranging from cable issues to weird hardware/port issues. So just to isolate different things, can I ask a few questions...

1. How can you tell it's not recognizing it?
2. Have you tried a different cable just to rule that out (you said it's good but just checking anyhow)?
3. Did you recently have a lightning strike?

Also, on the off chance that this is you trying to use Migration Assistant... this is actually a fuckity thing WITH MIGRATION ASSISTANT and it's not you (I could have asked this question last week because that is what I was doing). If that's your situation try setting up the new computer via thunderbolt or via a Time Machine-ish backup and it will work better. If not, let us know about these questions and I'm sure we can help.

Here are a few "I Googled but I'm pretty good at Googling" suggestions. Apologies if you have tried them

1. Check under System Preferences:Network that you didn't delete or disable your Ethernet service. Next under Applications->Utilities->System Profiler:Hardware-Ethernet cards ensure your device shows up.
2. some blabity bla here about a security update (from last year) that has this as a side effect
posted by jessamyn at 11:31 AM on July 11, 2017


In your Terminal window, type in:

ifconfig

That will report (only report) the configurations of the various network adapters. There are many of them, including lo0, the "loopback" interface, IP address 127.0.0.1, which verifies that the machine can talk to itself through its networking stack.

The ones you'll care about are usually en0 and en1, one of which is the WiFi adapter and the other is the wired ethernet. Try turning WiFi on and off to see which is which.

You can also get most of this info in more human-friendly form from System Preferences -> Network, by scrolling through each entry.
posted by RedOrGreen at 1:52 PM on July 11, 2017


My older, but trusty Mac Mini exhibited a similar issue when I plugged it into a 1GB router. It just couldn't auto detect the network speed.

System Preferences / Network / Ethernet Adapter / Advanced / Hardware
Then configure manually and select a lower speed such as 100BaseTX.

Good luck.
posted by hh1000 at 7:32 PM on July 13, 2017


Wow, I can't believe how long ago this was. Thanks to everyone, I finally fixed this. I put my stubbornness aside and retested the cable. It was the cable. Bought a new cable and I am cooking with gas. But first I used everyone else's suggestions, just so I could waste as much time as possible. Best answers for everyone!
posted by OmieWise at 8:18 AM on September 17, 2017


« Older Care Package for Moving Cross-Country   |   New England vacation for two moms and a baby Newer »
This thread is closed to new comments.