I can't send emails from one gmail account as another - please help
February 10, 2017 10:58 AM   Subscribe

I have a new work address for a startup I cofounded (yay!) I am the admin on the startup's gsuite as far as I can tell, but I can't seem to make this happen. What I want is to be signed into my gmail and be able to send emails as my @startup.com email (also a gmail). It won't let me, details below.

Ok, so as admin I made it so users can decide whether to turn on access to less secure apps. As the user, I tried to say turn on access to less secure apps, it told me I can't with two step verification so I turned off two step verification on my @startup.com address. Then I said turn on access to less secure apps.

I go into my gmail.com, and go to settings>accounts and import and click, "add another address" under "send email as" and it asks about the address. I say myname@startup.com, and it takes me to the SMTP screen for "Add another email address you own." It automatically autopopulates
the server as smtp.startup.com with port 587. My password and username are correct. I've tried changing the port, changing the TLS to SSL, changing the SMTP to smtp.gmail.com given that it's a gmail. Nothing. Nothing works, the error I'm getting when I use smtp.gmail.com is:
Authentication failed. Please check your username/password and Less Secure Apps access for myname.
more details:
Server returned error: "535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials j14sm761420itd.0 - gsmtp code(535) "

Only other error I get is if I try 465/TLS it says "Your other email provider is responding too slowly. Please try again later, or contact the administrator of your other domain for further information.
"

If I stick with the suggested smtp.startup.com it gives me the error ""DNS Error: 46327198 DNS type 'aaaa' lookup of smtp.startup.com responded with code SERVFAIL 46327198 DNS type 'a' lookup of smtp.startup.com responded with code NXDOMAIN code(0) ""

I give up. Any thoughts, anyone? Would be so nice to just have one email window open.


Note, the problem is not email forwarding. That's happening fine, I'm receiving my @startup.com email in my gmail inbox.
posted by namesarehard to Computers & Internet (8 answers total) 3 users marked this as a favorite
 
I believe you want
SMTP: smtp.gmail.com
Port: 465
SSL

Have you tried that combo?
posted by Rock Steady at 11:10 AM on February 10, 2017


Response by poster: Rock Steady, yes:
Authentication failed. Please check your username/password and Less Secure Apps access for myname.
Server returned error: "535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials n72sm275587itc.26 - gsmtp code(535) "

Maybe one more piece of data, it asks "treat as alias" and I click yes. Could be a problem?

(and yes, I'm certain it's the correct username & pw)
posted by namesarehard at 11:11 AM on February 10, 2017


There's the "Send mail as" option under "Accounts and Import". I believe there are some subtle differences (mail headers?) but you don't need to set up SMTP or anything. Then you can just forward all mail from the other account to you.
posted by neckro23 at 11:27 AM on February 10, 2017


Response by poster: I'm confused, that's exactly where I am: "Send mail as"
It is asking me for SMTP...
posted by namesarehard at 11:31 AM on February 10, 2017


I ran into this issue. I do not recall specifically how I solved it, but I just looked in the settings part Accounts and Import tab and where it has "Send mail as" there is a link to "Learn More" I think the answer is in there somewhere. There are two ways to send, On behalf (which I don't think you want) and as the actual sender.

Also, the address you want to send as, will get an email from Google asking if this is kosher. You need to respond to that before you can send as.

Hope these tidbits help. Sorry I cannot be more specific.
posted by AugustWest at 11:39 AM on February 10, 2017


Best answer: Long shot, but for the 'username', it expects the full email address if it's a non-Gmail domain, so you'd need:

username: me@mystartup.com
password: ******
smtp: smtp.gmail.com
port: 587
type: TLS
posted by camcgee at 11:43 AM on February 10, 2017 [1 favorite]


I've experienced a similar issue with trying to add a google apps address as an alias in a different gmail account. I think it might be a permissions issue. Since you are an admin in gsuite, try this:

Go to Apps > Gmail > Advanced Settings

There is an option there that says 'Allow per-user outbound gateways' that will allow sending of email from your company's account through an external SMTP server, check that.

After doing that, try setting it up through your gmail again. You may get an error message about permissions, in which case you might have to enable another setting under your specific user (I don't remember exactly, but I know when that happened to me I copied and pasted the error message into google and got the answer right away).
posted by ap_classic at 11:44 AM on February 10, 2017


Response by poster: camcgee got it, thanks!
posted by namesarehard at 11:56 AM on February 10, 2017


« Older Do I need a second opinion regard a vocal...   |   Activities for Toddler - Palo Alto Edition Newer »
This thread is closed to new comments.