The Pain of Using Gmail to Send Email to Myself
January 15, 2017 4:23 PM   Subscribe

I frequently need to send emails to myself. Gmail keeps making it harder and harder. Details below.

I have two gmail accounts, one primary, the other secondary.

My iPhone defaults to sending mail from primary account. If I send email to that same account, Google gets erratic. It doesn't like self-directed mail. So when I need to send to myself, I send to my secondary account. And I configured the secondary account to forward incoming mail to my primary account. That's my workaround, and it's served me for years.

Until a month or two ago. Now, emails sent from primary account to my secondary account bypass the In box and go straight to All Mail. So I mostly miss them.

Is there a simple fix, and/or a simpler way of doing things? Gmail can be pretty opaque....
posted by Quisp Lover to Computers & Internet (19 answers total) 2 users marked this as a favorite
 
Argh. Fixing an ambiguity:

Until a month or two ago. Now, emails sent from primary account to my secondary account bypass the In box and go straight to All Mail. So I mostly miss them.



They bypass the In box of my primary account (to which, as I said, they forward).
posted by Quisp Lover at 4:24 PM on January 15, 2017


Huh. That's weird. I email myself All. The. Time. And have other addresses that forward to my primary account. Gmail has given me none of the issues you are reporting.

Could this be an iphone issue?
posted by Michele in California at 4:33 PM on January 15, 2017 [25 favorites]


I've never had an issue sending myself an email on Gmail. I just tested it - sent an email to my Gmail account, from that same Gmail account. It just showed up in the Inbox as an unread email. There's no reason why sending yourself an email shouldn't work. Could be an iPhone issue though, I don't have one to test.

If I send email to that same account, Google gets erratic.

What happens, exactly?

Now, emails sent from primary account to my secondary account bypass the In box and go straight to All Mail.

The part about skipping the Inbox makes me wonder if you have a Filter set up that does the Skip Inbox action on those incoming emails forwarded from your second account.
posted by EndsOfInvention at 4:41 PM on January 15, 2017 [3 favorites]


I also Gmail myself all the time. I have a filter to automatically mark emails from me to me as read because I don't want to have to open them right after I send them, and that works just fine and they stay in my inbox. You may want to review all your active filters to see if you did something strange at some point.
posted by brainmouse at 4:45 PM on January 15, 2017


I also came in to suggest reviewing your filters list to see if something's gone awry. I email myself in Gmail all the time (and always via my iPhone) and I deliberately created a filter to always mark emails from me to me as read.

Or maybe go ahead create a new filter NOW so that emails from you to you are always starred/marked as important/whatever and see if that part works?
posted by anderjen at 5:02 PM on January 15, 2017 [2 favorites]


I email myself all the time from my iPhone. Do you use Mail or the Gmail app? Does it happen with both? . Also if you are emailing yourself, you could just pluck the message straight out of your sent mail, it doesn't even have to make it to your inbox. That said, there is likely some filter that is being triggered that is causing this auto-archiving to happen. You can try clicking this link or checking your own filters yourself to see if something weird is set up in there.
posted by jessamyn at 5:03 PM on January 15, 2017


Agreeing with everybody else -- I do this 10x per day minimum with no trouble, from iPhone, with the app and without it.
posted by BlahLaLa at 6:05 PM on January 15, 2017


Another chronic self-mailer reporting in. I don't have an iPhone, but I haven't noticed any irregularities. (I also set up a filter so that all emails sent from myself to myself are automatically tagged "Note to Self.")
posted by Faint of Butt at 6:20 PM on January 15, 2017 [1 favorite]


I used to self-mail. Now my Draft folder is 99% full of notes to myself, which I can update at will and won't get lost amidst my other emails.
posted by steady-state strawberry at 8:35 PM on January 15, 2017 [6 favorites]


I wonder if your primary account is downgrading the importance of mail coming from your secondary account because every dang message that comes from that email address is a FWD. Can you create a rule or filter so that every message from that address gets sent to your Inbox?
posted by baseballpajamas at 9:37 PM on January 15, 2017 [2 favorites]


Seconding the use of Drafts if these are notes you're sending to yourself. Another upside of Drafts is that they're not going through any sendmail servers, so the "only" copy is on Google servers, and that one gets overwritten or deleted if you modify or delete the draft. Scarequotes because of course Google has server farms so there could be more than one copy on Google servers, but that's still a lot less of a security worry than copies on a bunch of intermediary servers.

For emails sent to yourself as documentation, definitely send to yourself, do not use Drafts. That way you will have unmodifiable, timestamped proof.

Can you tell I'm someone who emails herself? Never had issues either, have two Gmail accounts and an iPhone. I think there's a filter thing going on.
posted by fraula at 1:36 AM on January 16, 2017 [1 favorite]


The other option is to set up a filter to apply a label of your choice to emails from yourself, and that allows them to be collected and reviewed in one place.
posted by megatherium at 4:33 AM on January 16, 2017


Agree that you should check your filter situation, but as an alternative, you might want to try Captio or a similar app.

After setup, you just tap the app icon, type your note, and it automatically emails you. Pretty nifty (though admittedly not as satisfying as figuring out what's happening in Gmail itself).
posted by whoiam at 8:19 AM on January 16, 2017 [2 favorites]


My iPhone defaults to sending mail from primary account. If I send email to that same account, Google gets erratic. It doesn't like self-directed mail.

Chiming in as another serial self-emailer. I have multiple gmail and Exchange accounts set up on my iPhone Mail app, and have problems sending From my primary gmail, To my primary gmail. The message hangs in Outgoing before finally giving an error about the SMTP server being configured incorrectly. Which it's not.

I figured it was an iOS issue. I've worked around this by sending To my primary gmail, From my secondary gmail. Once in a while it still gives an SMTO error, but resolves quickly.
posted by rhapsodie at 10:48 AM on January 16, 2017


Ok, thanks, all. I will very thoroughly review the filters on both accounts, do some serious testing, and, if the problem persists, post more specifically about what's going on in a new question next week.

I'm not having rhapsodie's problem, specifically, but curious to see if anyone knows a solution.
posted by Quisp Lover at 11:00 AM on January 16, 2017


Captio looks cool, whoiam, thanks. If I can just find a way to Workflow these notes into my cross-platform To-Do manager ("The Hits List"), I'll be all set!

Drafts is also smart, though it creates a bit of a big sloppy mess in the drafts folder.
posted by Quisp Lover at 11:05 AM on January 16, 2017


I'll review this thread again later. But I'll pass on what I have heard from my club's IT guy.

I have two gmail accounts: One is myname@gmail.com, the other is myjob@club.com (for my correspondence as a club officer).

(I don't understand how mail via club.com (not addressed to gmail.com) can be "gmail," but I guess the club account is a Google account or something, so it is in fact gmail. I'm sure others will understand how that works better than I do.)

All mail from third parties to myjob@club.com is auto forwarded to myname@gmail.com because we set it up to do that. However, if I send a message to myjob@club.com, it is not forwarded to myname@gmail.com. The IT guy says that's just the way gmail works -- it simply doesn't allow me to write "to myself" in this way, writing to the club account expecting it to be forwarded to my main account.
posted by JimN2TAW at 11:47 AM on January 16, 2017


I also self-mail in my gmail account all the time and have had no issues. I'm wondering if you "upgraded" to Inbox? If so maybe that's the problem?
posted by rabbitrabbit at 4:32 PM on January 16, 2017


Figured it out.

As I said, I'd set my secondary account to forward to my primary account.

And it turns out that I'd set up a filter on the primary account to send those forwards straight to archive/all mail.

And it turns out that at some point I set my email client NOT to get mail from the secondary account.

So that explains it.

I've set the client to get that mail now, and I'm (naturally) getting dupes of all those mails. I guess the "just right" solution would be to NOT have client get secondary mail, and to remove the filter from my primary account, so forwarded mail goes to inbox, right?
posted by Quisp Lover at 8:38 AM on January 31, 2017 [3 favorites]


« Older Please recommend a long handled hand held...   |   Having friends is making me anxious Newer »
This thread is closed to new comments.