Windows 10 no longer detects second monitor
December 28, 2016 11:12 PM   Subscribe

I've been running Windows 10 on a Lenovo B590 for about a year, and have always used a second monitor without any problem... until now.

I traveled for the holidays and took my laptop with me; I came back tonight and reconnected the second monitor, but the system no longer detects it (when I go to Display Settings it only shows one display; when I click on "detect" I get a message reading "didn’t detect another display").

Everything I've found online regarding this issue seems to involve problems immediately following a Windows 10 upgrade, problems with a brand-new monitor, and/or problems with outdated drivers, software, etc. It doesn't seem like any of this should apply to me: everything worked fine less than a week ago, and now it doesn't. Any possible solutions? (Please note: my tech savvy is limited to a basic layperson's level, so suggestions/instructions tailored for a non-expert will be most helpful. Thanks!)
posted by the return of the thin white sock to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Make sure your second monitor is connected, powered up and awake, then try restarting. Not shutting down and then starting up again, which Windows 10 usually interprets as a request to do some kind of half-assed hibernatey thing, but doing an actual restart.

Braindead inbuilt firmware in some laptops detects external video displays during power-up self-test, and if they're not there it completely disables the external video port and doesn't tell Windows that a second display is even a possible thing. And if Windows doesn't do a full shutdown, which it often won't do except during an explicit restart, the power-up self-test never runs and the external display stays disabled.

Also worth playing with: if one of your laptop's function keys (like F7 or F8) also has a hieroglyphic that might look a bit like a display screen if you squint at it the right way, try holding down the Fn key and tapping that function key. You might find that this makes the inbuilt firmware step through all available combinations of internal and external displays. But try the restart thing first.
posted by flabdablet at 12:09 AM on December 29, 2016 [2 favorites]


Are you sure they didn't sneak in another upgrade? What are your settings for this? Mine are set at the Don't You Dare Upgrade Me Unless I Request It level and two days ago I got a message from Microsoft offering to do one while I'm asleep but I turn off my wifi at night. "Power" (click on Window icon at lower left) now say stuff like "update and shut down" and "update and restart".
posted by TWinbrook8 at 12:20 AM on December 29, 2016 [1 favorite]


If none of the above work, press and hold the Windows key then press P once or several times - this will cycle through extend/mirror/off for your external display - it could be that Windows has just turned the display off.
posted by parm at 1:45 AM on December 29, 2016 [1 favorite]


if one of your laptop's function keys (like F7 or F8) also has a hieroglyphic that might look a bit like a display screen if you squint at it the right way, try holding down the Fn key and tapping that function key. You might find that this makes the inbuilt firmware step through all available combinations of internal and external displays.

This seems to have done the trick in terms of getting the monitor recognized -- thanks. Unfortunately, now I'm faced with a fresh new irritation: in setting the Display Setting size to 125%, which is what I've always set it at, now the typefaces for various programs (Word, iTunes, Adobe, Scrivener, etc.) are all blurry and in some cases the proportions are off (Scrivener, in particular, is basically unreadable now). Making sure the ClearType option is turned on makes absolutely no difference. The monitor is definitely set at the correct resolution (1440 x 900).

Are you sure they didn't sneak in another upgrade?

Ha! I wouldn't put it past 'em, except that there was no wifi where I was staying -- so no means to sneak one in, even if they'd tried.
posted by the return of the thin white sock at 2:47 AM on December 29, 2016


The monitor is definitely set at the correct resolution (1440 x 900).

Windows might still be confused.

Doing the Fn key dance will often send you on a cycle through four firmware-supported modes: inbuilt panel only, external monitor only, both outputs active but separate, both outputs cloned. Sometimes Windows sees firmware-cloned mode as two separate outputs but can't actually set the resolutions separately, even though it claims to have done so.

Windows also has its own four-step display mode cycle, which you can get to using Windows-P. This brings up a menu of four options: computer only, projector (i.e. external display) only, extended, duplicated. With these you can actually see which mode Windows has chosen.

So do the Windows-P thing and choose Extended. Then do the Fn-key thing until you really do see two different things on your inbuilt and external displays.

You should now be in good shape to set each of them to its native resolution, and doing so should actually work. If it doesn't, restart Windows (again, not a shutdown+startup but an explicit Restart) and have another crack.
posted by flabdablet at 4:02 AM on December 29, 2016


Yeah, I just want to slip in a 'Hey-o' and a vote for 'Sneaky Undetected Driver/OS' Update. My #2 would be the 'adorable laptop iconographic display icon thing key [F7 for me].' Give it a whirl!
posted by mrdaneri at 4:24 AM on December 29, 2016


Do you have another computer or something to see if maybe the monitor is dead? It's rare but I have seen monitors call it quits with no warning at all.
posted by Gev at 6:35 AM on December 29, 2016


So do the Windows-P thing and choose Extended. Then do the Fn-key thing until you really do see two different things on your inbuilt and external displays.

The Fn-key dance (in my case, F3) and Win-P bring up the same menu of four options for me. I'm presently in Extended.

Monitor 1 (inbuilt) is set at its native resolution of 1366 x 768, and everything looks fine when the size is set at 100% (i.e., everything is readable and looks normal in terms of both size and crispness of type).

Monitor 2 (external) is set at its native resolution of 1440 x 900. Setting it at 100% (which Windows also tells me is recommended) makes most things too small, though type generally appears crisp (and at least I can zoom the display for Word and Chrome to readable levels, even though the menu tabs stay irritatingly small; there's no way to do this with iTunes, etc., though). Setting at 125% (listed as "not recommended") returns everything to the normal size I've always used, but makes most things weirdly blurry and/or weirdly proportioned to varying degrees. This is true whether I stay in Extended view or whether I switch to showing Monitor 2 only.

Restarting (multiple times) doesn't help. Adjusting ClearType settings doesn't help.

I went into the Graphics control panel (this an Intel panel, not Windows—no idea if that's relevant or not) and tried seeing if there was a difference in setting the refresh rate at 60 Hz vs. 75 Hz (I vaguely remember having to do this once in the past, pre-Windows 10 upgrade), but there was no apparent change either way. It's presently set at 60.

Definitely no sneaky updates in the past week as far as I can determine; last updates are listed as having been made on Dec. 9 and 13.
posted by the return of the thin white sock at 1:39 PM on December 29, 2016


OK, further googling has led me to stumble upon what seems (knock on wood) to be a workaround/solution:

- set Monitor 2 size at 125%
- right-click on the shortcut for each app with text display problems
- select Properties; in Properties, select Compatibility tab
- in Compatibility Settings, select "Disable display scaling on high DPI settings"
- click Apply

...and voila: readable text in terms of both size and crispness/proportions. No idea why it suddenly became necessary to do this manually for each app, and hopefully I haven't inadvertently created a different problem for myself, but for now I think I can proceed with using the computer again without needing to get a new Rx for glasses.
posted by the return of the thin white sock at 3:00 PM on December 29, 2016


You might find you get acceptable results with less hassle by setting your external monitor back to 100% instead of 125%, then running it at lower-than-native resolution. The display scaling hardware built into most monitors does a much more competent job than the rather rubbish software scaling Windows employs when it's not convinced that an application understands how to render itself at anything other than 96dpi.

These remarks about Windows 7 still apply to 10.
posted by flabdablet at 8:29 PM on December 29, 2016 [1 favorite]


« Older Criterion Collection for Books   |   Book recommendations for my grandma Newer »
This thread is closed to new comments.