Why can't I get messages from iPhones when cell data on mine is off?
May 11, 2016 1:26 PM   Subscribe

I have an iPhone 6. I turned off my cellular data because I got an alert that I was approaching my cap. However, I now do not receive text messages sent from iPhone users who use iMessages. Is there any way I can fix this?

I turned off cellular data because I was approaching my cap, but now I am not receiving messages from iMessages users. It's very annoying--I've been sent a few important texts messages and just not received them. I want to use iMessages when I am on wi-fi, but it seems strange that I can't communicate with iPhone users at all. Can I fix this?
posted by synecdoche to Technology (16 answers total) 2 users marked this as a favorite
 
Sometimes iMessage gets flaky--I missed a bunch of messages from my mother on Mother's Day because...they just didn't go through.

It shouldn't be related to having turned off cellular, it should still work fine on wifi.

Have you rebooted your phone recently? That's likely to help.
posted by leahwrenn at 1:47 PM on May 11, 2016


Sorry--I maybe wasn't clear. The issue is when I am away from wi-fi. Somebody using an iPhone with iMessages turns on texts me. In the past, this has worked. But if I'm in a place where I don't have wi-fi, the message never gets to me.
posted by synecdoche at 1:51 PM on May 11, 2016


If you aren't on a wifi network, and you have cellular data turned off, then unless I'm missing something, there's no way for your phone to communicate with the outside world, and thus no way for iMessages to get to your phone. Apologies if I am missing something.
posted by Salvor Hardin at 1:59 PM on May 11, 2016 [3 favorites]


Because iMessage only use data connections. When you aren't on wifi, you have no data connection. The solution is to turn off iMessages completely so you get regular text messages.
posted by Brent Parker at 1:59 PM on May 11, 2016 [3 favorites]


You can't get iMessages with cellular data off. They are data, and if you are not on Wi-Fi, you won't receive them. See this explainer from Apple. You can shut off cellular data per app, so I usually just shut off data to my most data-hungry apps (Facebook and Twitter are the worst) when I get close to my limit.
posted by Rock Steady at 2:01 PM on May 11, 2016


You know about green vs blue bubbles, right? Green bubbles are people sending you SMS, i.e., over cellular, and blue bubbles are people sending you via iMessage. You for sure won't be able to get green bubbles if cellular is turned off, nor will you be able to send messages to them.
posted by leahwrenn at 4:07 PM on May 11, 2016


Synecdoche is expecting iMessages to come through as SMS messages when data is off. This is a reasonable expectation (iMessage already sends messages in SMS form to non-Apple phones), but I don't think iMessage routing works like that. Once it knows you are on an Apple device, it will continue to send you messages as encrypted iMessages, not through SMS, even if you can't currently receive data.
posted by w0mbat at 4:15 PM on May 11, 2016 [1 favorite]


Yeah, so the frustrating thing is somebody is (in their mind) texting me (using iMessage). I've turned data off on my phone and am not on a wi-fi network. I get that I can't send iMessages. That's fine. I expect that my phone, in that case, automatically notices this and uses SMS instead. (Does it?) But on the other end, some person is sending me messages, getting annoyed that I'm not responding, but I never ever receive those messages. At the very least, I would hope that it would queue them up and deliver them when I do log in to a wi-fi network, but no dice.
posted by synecdoche at 4:36 PM on May 11, 2016


If you want other phones to know that you can't be reached by iMessage, you need to go into the settings and disable iMessage on your phone, while you still have data access. That will disassociate your phone number with iMessage, so other iOS devices won't try to use it.

I think you will continue to miss out on messages from previously existing group iMessage sessions, where everyone in the group is on iMessage, and there's nothing that can be done for that.
posted by aubilenon at 4:57 PM on May 11, 2016 [1 favorite]


If you use iMessage on any other devices, people may still end up sending you iMessages instead of texts, even if you unassociate the phone number in your own settings, because they'll still have your email or whatever in their own contacts. It's a huge pain in the ass!
posted by mskyle at 6:35 PM on May 11, 2016


I expect that my phone, in that case, automatically notices this and uses SMS instead. (Does it?)

It's supposed to but WOOOO BOY is that feature flaky. It's somehow now just as flaky as it was five freaking years ago when imessage was unveiled.

I work in an office with flaky cell service and flaky wifi. In some areas you get solid coverage of one, in some usable coverage of the other... but never both. In theory it should fairly seemlessly hand off between the two. In reality it's a mess of me manually enabling and disabling wifi and stuff all the time(despite the new iOS 9 features that were supposed to auto switch from bad wifi back to cell service!)

Text messages are mostly reliable at cuing up both to send and receive until you have cell coverage(and immediately notifying you if they cant send). iMessage is somehow, still, horrible at this.

So yea, the solution is as above to go in to settings>messages and turn off imessage, but holy god is this an opaque and shoddy feature. It's as reliable as power tools from harbor freight.

I am heinously bitter about this because all but 1-2 people i know use imessage non stop, and i constantly have issues with messages that never show up on my phone but pop up hours later on my laptop at home because of garbage situations like yours. WHY is it so bad at falling back to SMS. WHYYYYYYYYYYYY
posted by emptythought at 7:05 PM on May 11, 2016 [2 favorites]


iMessage is very unforgiving if you aren't doing what Apple expects you to. When I switched to Android, any time someone with an iPhone tried to text me, I didn't get the message because iMessage ate the messages (didn't send SMS). Eventually I logged into an Apple computer and found all the messages. Then, trying to reverse the process, so I could communicate with iPhone users, took weeks. It was super annoying.

With this in mind, I would try a different tack to get your messages, like the recommendation above to just cap data for other applications. Sorry.
posted by hungrytiger at 12:38 AM on May 12, 2016


You can deregister your phone number from iMessage here.
posted by veids at 11:01 AM on May 12, 2016


Defaulting to SMS is a setting on the sender's system. This is because the sender gets charged messaging fees. You can't fix it on your end.

Your best solution is to turn off cellular data on the specific applications that use it the most, as previously suggested. When you go to the screen, it will tell you how much data each app has used. Turn off Facebook and Instagram and you're most of the way there.
posted by snickerdoodle at 11:02 AM on May 12, 2016


I think iMessage should do this properly (fall back to SMS if Data is not available) but if not: Is the cost of going over your data cap (about $10 to $20 depending on your carrier) worth the hassle? If not, I'd just consider going over a little bit.
posted by soylent00FF00 at 5:20 PM on May 12, 2016


Is it a hard cap (cannot send or receive anything), or do they just turn the speed down to 2G? If it's the latter, just live with it and be more careful with your data usage next month.
posted by pmurray63 at 9:42 AM on May 14, 2016


« Older How does anyone start a business? (UK edition)   |   How do you wear sunglasses? Newer »
This thread is closed to new comments.