Google's Chrome browser is refusing to forget my passwords with LastPass
May 3, 2016 2:00 PM   Subscribe

I've used the Chrome browser with the LastPass extension for years, and for years it's been set to refuse automatic access to accounts such as Facebook, metafiilter, GMAIL, etc, unless I type in the master LastPass password. Suddenly, this has changed, and Chrome refuses to forget my passwords....it's driving me nuts!

Ok, I'll be thorough...I'll try.

I don't like automatically signing into social media sites, gmail, etc, so I use LastPass to store my passwords, and unless I type in the LastPass master password, Chrome will typically show the basic sign-in page for Facebook, GMAIL, etc. When I want to visit those sites, I type in the master password for LastPass, and it automatically signs me into multiple tabs for me to check my accounts. Once I'm done browsing, I close Chrome, and LastPass is supposed to sign me out of all sites IMMEDIATELY. This used to work... Simple, huh?

Somehow within the past week, Chrome has decided to never forget my passwords, and once I close my browser and restart it, Facebook will happily sign me right back into Facebook. I don't want this!

The LastPass settings don't appear to have changed...and I'm baffled as to what might be happening. I have NOT set Chrome itself to remember any passwords - in fact, in the process of trying to figure this out, by reinstalling LastPass, etc, once I signed into Facebook on a new copy of Chrome, it asked if I should let Chrome remember the password, to which I chose "Never remember". But guess what? It still remembers the bloody thing.

I went into Chrome settings, and under "Passwords", there are 2 categories to view, "Saved passwords", and "Never saved".

There's nothing listed in either....so Facebook should NOT be automatically signed into when I open the page on Chrome. I'm baffled.

It must be something really simple and obvious.

Please help!
posted by newfers to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
I've been having a problem with one of my own Chrome extensions getting automatically disabled whenever I close my browser, because "it is changing too many things" and Chrome wants me to reconfirm that I give it my approval to do so. It's a pain in the ass, but it doesn't seem to be anything I can do about it.

Check your extensions tab and see if LastPass is enabled.
posted by EmpressCallipygos at 2:02 PM on May 3, 2016


Facebook will happily sign me right back into Facebook. I don't want this!

Via the login form, or are you still logged in when you return? If the latter, it's probably cookies, not a login setting. Go to Settings > Advanced > Privacy > Content settings... and check the Cookies setting; sounds like you want "Keep local data only until you quit your browser".
posted by effbot at 2:10 PM on May 3, 2016


Effbot : That seems to have worked, partially!! Chrome no longer automatically signs me back into Facebook, for example, but when I put in my LastPass password, it is requiring my login code for the 2-factor authentication for both Facebook and GMAIL. It is requiring this each time...

You've brought me so much closer to a full solution, though, and I thank you!
posted by newfers at 2:48 PM on May 3, 2016


There's nothing listed in either....so Facebook should NOT be automatically signed into

Do you mean that upon opening the browser, you go to Facebook and see the login ("Email or Phone") and password blanks, and then Chrome fills them in, and then you click the Log In button, and then you're signed in?

Or, do you open a browser window, go to Facebook, and you're already logged in?

If it's the latter, Chrome isn't remembering your passwords--it's never logging you out. This could be happening because Chrome is, in fact, not closing. It's staying open in the background to run some kind of extension/app from the Chrome Web Store. Check your notifications area/system tray for a Chrome icon.
posted by pullayup at 4:16 PM on May 3, 2016 [1 favorite]


Pullayup : This happened once before, and I tracked down the cause as being a setting in Chrome that kept it running in the background... in my current situation, that setting has been disabled.

To answer your initial question : When I open Chrome, Facebook is already signed in... which is why I was originally convinced that it was related to my previous issue, ie. a background process... but this does not seem to be the case right now.
posted by newfers at 4:22 PM on May 3, 2016


There is a setting in Chrome called "Continue where I left off" or something similar. I would make sure that is disabled too.
posted by thorough at 5:36 PM on May 3, 2016


Yeah, it's sounding like Chrome isn't remembering your password, but it is remembering the cookies that are keeping you logged in. Generally speaking, unless you explicitly sign out of a website, you'll very likely stay logged-in, sometimes even if you close your browser, since websites like facebook really want you to stay signed in as long as possible, so that they can track your browsing behavior better.

The "Keep local data only until you quit your browser" setting deletes those login cookies automatically when you quit. However, keep in mind that this will delete all cookies, including the ones that might have been set to remember you when you come back so that it doesn't try to ask for your second factor authentication again. So, you'll need to decide how much convenience you're willing to give up in the name of privacy/security.

The "continue where I left off" setting is probably the one that changed Chrome's behavior, as that setting will artificially preserve cookies that would ordinarily not persist when you close your browser.
posted by Aleyn at 5:58 PM on May 3, 2016


FWIW this is not the default use case -- most people like websites to remember them -- so you are likely to keep facing problems even if you solve this one.

An easy solution is to only log in to websites in Incognito mode, which instructs Chrome to forget everything upon exit.
posted by katrielalex at 7:56 AM on May 4, 2016


The "Continue where I left off" setting is not being used. Instead, I sign in to a series of my commonly used tabs.

Prior to this issue, I would arrive at the sign-in pages of Facebook, Gmail, etc, and as soon as I typed in my LastPass password, all my tabs would sign in, keeping me from having to sign into each one individually.

Now that Chrome seems to be working, in one regard (it's forgetting the password on closing), the two-factor authentication issue is a major annoyance.

The main reason this is annoying, is that IT ALL WORKED LAST WEEK!!

I didn't have to continually go through authentication...

I wish I knew what changed.
posted by newfers at 9:26 AM on May 4, 2016


It's entirely possible that Facebook is the one that changed. The cookies they set can either be marked as session cookies, which are cleared when the browser is closed, or as persistent, with an explicit expiration at some point in the future. I don't use Facebook, so I don't know if this is the case, but it's possible they switched from using session cookies to persistent ones recently.
posted by Aleyn at 1:40 PM on May 4, 2016


« Older Ceiling light bulb hole?   |   Vegan traveling to New Orleans with non-vegan... Newer »
This thread is closed to new comments.