Firefox and Streaming Video: No Can Do
December 21, 2005 8:14 PM   Subscribe

Firefox 1.5 on Win XP refuses to play streaming video.

Specifically, if I go to CNN and try to stream one of their videos, the pop-up opens fine and it appears to be doing something but just sits there. I can open the video fine in IE, unfortunately. Am I missing some secret Firefox sauce?
posted by KevinSkomsvold to Technology (19 answers total)
 
When you type about:plugins into the address bar what does it say?
posted by holloway at 8:24 PM on December 21, 2005


Well, in case you're missing a Codec, I'd recommend installing the K-Lite Mega Codec Pack. I've not had any problems going that route with Firefox.
posted by Handcoding at 8:25 PM on December 21, 2005


Codec packs are usually overkill bucketware, and as likely to screw things up as fix them.

If you must go that route, I recommend the DefilerPak.
posted by stavrosthewonderchicken at 8:38 PM on December 21, 2005


Make sure you have flash installed. I believe CNN are flash encoded.
posted by pealco at 8:55 PM on December 21, 2005


CNN videos, I mean.
posted by pealco at 8:56 PM on December 21, 2005


No luck with any of the above solutions but thanks everyone!
I installed Gordian Knot, DefilerPak and K-Lite but still, the pop-up just sits there. I've allowed javascript, pop-ups and whatever else FF will let me but no luck. Any other ideas/suggestions would be appreciated.
posted by KevinSkomsvold at 9:16 PM on December 21, 2005


Have you tried the IE Tab extension? It's not a perfect solution, but at least it would let you play the videos without opening the full version of IE.

(Also, I seem to be able to play the CNN videos in FF 1.5, but they are missing their control bar - no stop, volume, etc.)
posted by neurodoc at 9:27 PM on December 21, 2005


I have had nothing but problems with Firefox 1.5- many of my favorite extensions didn't work write, including DownThemAll utterly breaking- unfixably, in the case of the latter (their own site says, despite an auto-update, to uninstall the 1.0x version FIRST or it'll never work), and NO embedded video work, period. Flash, windows media, etc.

1.5 was a great gaping hole of embarassingly bad browser. The only solution I found was to revert back to 1.07 by saving my profile directory first, then uninstalling FF1.5, deleting the profile directory for myself and the program files directory, and then installing 1.07 fresh with my previous extensions.

Firefox 1.07 works great!!!
posted by hincandenza at 10:37 PM on December 21, 2005


KevinSkomsvold are you using adblock? I was having a similar problem (upgraded to ff 1.5 and magically audio worked but saw no moving pictures) until I updated the extension.

hincandenza have you tried using the extension, "nightly tester tools"? It will force an extension to think it is compatible with the latest firefox, it worked like a charm on a few of the extensions I use that weren't compatible with 1.5
posted by squeak at 12:23 AM on December 22, 2005


Do you have AdBlock installed?
posted by mr.dan at 12:31 AM on December 22, 2005


What mr.dan is referring to, I think, are the reports far and wide that Adblock makes 1.5 very weird. Adblock plus, not so much.

I finally switched with the release of 1.5 because I like the improved renderer, and I haven't had a single issue so far.

My thought as far as KevinSkomsvold's problem goes would be to nuke Firefox entirely, and all settings and customizations, scorched-earth, and start from scratch with a clean install.
posted by stavrosthewonderchicken at 1:00 AM on December 22, 2005


try these guides: 1 & 2

don't use codec packs, they just accelerate the built-in decay of winxp

(i'm not trying to troll, but since deer park opera is the better browser again)
posted by suni at 2:28 AM on December 22, 2005


Hmmm- my own takeaway from this AMF is to give 1.5 a try, with no adblock.. but also to install 1.5 as a fresh, non-upgrade install (i.e., remove 1.07 completely first, THEN do 1.5). That might work for OP:KS.
posted by hincandenza at 6:03 AM on December 22, 2005


I've been having exactly this problem. Uninstalling adblock fixed it, without reinstalling the browser. Thanks mr. dan & stavros.
posted by putzface_dickman at 6:06 AM on December 22, 2005


thanks for the adblock tip, folks.
posted by andrew cooke at 6:28 AM on December 22, 2005


Thanks for the adblock tip. Does adblock show up as a separate uninstallable app in Control Panel? (I don't see it) or is it integrated with something else? Ironically, I'm having the same issue here at work so it has to be something universal like that.

Also, Holloway, to answer your question, what specifically in about:plugins am I looking for? There's a lot of stuff there.
posted by KevinSkomsvold at 6:34 AM on December 22, 2005


kevin - it's shown in tools -> extensions. it also appears in the bottom right corner of the firefox window frame.
posted by andrew cooke at 7:23 AM on December 22, 2005


Thanks Andrew. Unfortunately I don't have that installed. I'm going to try a clean install of FF 1.5 to see if that remedies the problem.
posted by KevinSkomsvold at 8:05 AM on December 22, 2005


I had the same video problem after upgrading firefox to 1.5. Updating Adblock solved the problem.
posted by Roger Dodger at 11:09 AM on January 15, 2006


« Older Screen-me up Scotty!   |   Should I use an exercise/balance ball instead of... Newer »
This thread is closed to new comments.