Disk drive me crazy
December 15, 2005 5:46 PM   Subscribe

Some years ago I accidentally disabled the media drives (compact flash, memorystick) on the front of my HP Pavillion. I didn't worry so much at the time. But now I want to use it, and I can't make it come back.

When I connect my PSP via USB, it skips four drive letters and shows it as K:\ -- so I presume the four disabled drives were G:, H:, I:, and J:. Typing these into an address bar doesn't work though. I fear I'll have to poke around the device manager, but so far, no solutions are presenting themselves even in there.
posted by evilcolonel to Computers & Internet (9 answers total)
OS? If you disabled them I'd suspect one of the three: In windows (a la device manager) 2. In bios 3. Physically disconnected the cables. I'd troubleshoot in that order.
posted by AllesKlar at 5:58 PM on December 15, 2005

Response by poster: Sorry... Windows XP. I've tinkered with device manager, but can't seem to locate them in there.
posted by evilcolonel at 6:31 PM on December 15, 2005

Look here:

- Right click your My Computer icon
- Click Manage
- Go to Disk Management

Don't know if it'll help or not.
posted by Anoxs at 6:33 PM on December 15, 2005

Are you doing this testing with media inserted into the drives? Some of those devices are triggered by the presence of media and won't show up at all without them.

Also, check for HP applets in the control panel and power settings - sometimes those devices are disabled/enabled by proprietary apps written by vendors.
posted by helios at 7:59 PM on December 15, 2005

The drive letters probably won't show up until you insert media into the slots. They don't work like floppy drives, where they show up all the time, they work like a removable hard drive. Do you have media inserted?
posted by GuyZero at 6:21 AM on December 16, 2005

Insert the media and then do as Anoxs suggests. You will probably see a drive without a letter. Right click on the letter-less drive and choose 'Change drive letter and path'. Select a new drive letter. After you assign a drive letter it will show up in My Computer.
posted by banshee at 9:21 AM on December 16, 2005

Response by poster: Tried it with media inserted. No letterless drives showed up, sadly.
posted by evilcolonel at 5:55 PM on December 16, 2005

With the media still inserted check in Device Manager for anything marked with a red X. If you find anything, right click it and choose Enable.

Can you provide any more details about how the drives were disabled? Drivers removed? Hardware disconnected?
posted by banshee at 9:48 PM on December 16, 2005

Response by poster: I'm trying to remember how I managed to do it. It seems to me I was trying to enable a USB something-or-other, or was having a device conflict somewhere, and deleted the four drives in "My Computer" or from the Device Manager.

Actually, I just remembered -- it was a USB "TV Wonder" card that was not supported in XP, and I was tinkering to get it working.

Does anyone know what these drives are normally called in Device Manager?
posted by evilcolonel at 4:44 PM on December 18, 2005

« Older Where cn I buy a cheap Santa Suit in San Francisco...   |   Help me spend my travel budget! Newer »
This thread is closed to new comments.